<!DOCTYPE html><html lang="en-US" prefix="og: https://ogp.me/ns#"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script>
<script>window.ezslots_raw=[];var __sellerid='16189183c417d6d7659948da9c312c5b';var __ez_nid ='1254144';__advertiserRule=[''];var ezasVars = {'cid':'','pid':'','ssid':44};window.ezasvEvent=function(e,o){if(e[0].isIntersecting===true){var i=e[0].target.attributes[0].value.substr(0,e[0].target.attributes[0].value.length-9);window.ezoSTPixelAdd(i,'viewed',1);o.disconnect();}};window.ezaslEvent=function(m,o){if(typeof m[0].target.attributes['data-ad-status']!='undefined'){var v=m[0].target.attributes['data-ad-status'].value;var i=m[0].target.attributes[0].value.substr(0,m[0].target.attributes[0].value.length-9);if(v=='filled'){window.ezoSTPixelAdd(i,'loaded',1);var vo=new IntersectionObserver(window.ezasvEvent,{threshold:[1]});vo.observe(document.getElementById(i+'-asloaded'));}
o.disconnect();}};window.ezoSTPixels=[];var stPixelInterval=setInterval(function(){if(typeof __ez!=='undefined'&&typeof __ezDotData!=='undefined'&&(typeof ezslots!=='undefined'&&window.ezslots_raw.length>0)){window.ezoSTPixelFire();clearInterval(stPixelInterval);}},250);window.ezoSTPixelAdd=function(id,name,value){window.ezoSTPixels.push({id:id,name:name,value:value});window.ezoSTPixelFire();};window.ezoGetSlotById=function(id){var slotId=id.split('div-gpt-ad-')[1].split('-',3).join('-');for(s in window.ezslots_raw){if(window.ezslots_raw[s].tap.includes(slotId)){return window.ezslots_raw[s];}}};window.ezoSTPixelFire=function(){if(typeof __ez!=='undefined'&&typeof __ezDotData!=='undefined'&&(typeof ezslots!=='undefined'&&window.ezslots_raw.length>0)){while(window.ezoSTPixels.length>0){var event=window.ezoSTPixels.shift();var s=window.ezoGetSlotById(event.id);var pxData=[{type:'impression',impression_id:s.eid,domain_id:window.did.toString(),unit:event.id,t_epoch:__ez.dot.getEpoch(0),ad_position:parseInt(s.ap),country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:1,data:__ez.dot.dataToStr([(new __ezDotData(event.name,event.value.toString()))]),is_orig:0}];var pxURL='/porpoiseant/army.gif';var pixelURL=__ez.dot.getURL(pxURL)+'?orig=0&sts='+btoa(JSON.stringify(pxData));__ez.dot.Fire(pixelURL);}}};</script>
<script>window.ezhbopt=true;</script>
<link rel='preload' as='script' href='//securepubads.g.doubleclick.net/tag/js/gpt.js'>
<link href="//ad.doubleclick.net" rel="dns-prefetch">
<link href="//pagead2.googlesyndication.com" rel="dns-prefetch">
<link href="//googleads.g.doubleclick.net" rel="dns-prefetch">
<link href="//tpc.googlesyndication.com" rel="dns-prefetch">
<link href="//adservice.google.com" rel="dns-prefetch">
<link href="//secureads.g.doubleclick.net" rel="dns-prefetch">
<link href="//www.googletagservices.com" rel="dns-prefetch">
<link rel='preload' as='script' href='//go.ezodn.com/hb/dall.js?b=amx,criteo,oftmedia,onemobile,onetag,pubmatic,pulsepoint,sharethrough,smilewanted,yahoossp,yieldmo&cb=195-0-34' onerror="window.ezDallErr=true">
<script type="text/javascript">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</script>
<script type='text/javascript'>_ebcids=[138231308856,138231308940,138231308949,138231387842,138231421744,138231421759,138231421774,138231421783,138231421789,138231421792,138242067587,138242067590,138242067602,138242067605,138242067608,138242067614,138242229406,138242229415,138242229421,138242229430];</script>
<script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>ezobv=103;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>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</script><script type='text/javascript' data-ezscrex="false">var ezorbf = []; </script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.isEZABL=false;window.ezmadspc=300;window.ezoViewCheck=false;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.ezDisableInitialLoad=false;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.googletag=window.googletag||{};googletag.cmd=googletag.cmd||[];</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>(function(){var gads=document.createElement('script');gads.async=true;gads.type='text/javascript';var useSSL='https:'==document.location.protocol;gads.src=(useSSL?'https:':'http:')+
'//securepubads.g.doubleclick.net/tag/js/gpt.js';var node=document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads,node);})();</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>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</script>
<script type="text/javascript">(function(){function storageAvailable(type){var storage;try{storage=window[type];var x='__storage_test__';storage.setItem(x,x);storage.removeItem(x);return true;}
catch(e){return e instanceof DOMException&&(e.code===22||e.code===1014||e.name==='QuotaExceededError'||e.name==='NS_ERROR_DOM_QUOTA_REACHED')&&(storage&&storage.length!==0);}}
function remove_ama_config(){if(storageAvailable('localStorage')){localStorage.removeItem("google_ama_config");}}
remove_ama_config()})()</script>
<script type="text/javascript">var ezoicTestActive = true</script>
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">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</script><script data-ezscrex="false" data-pagespeed-no-defer data-cfasync="false" type="text/javascript">__ez.queue.addFile('banger.js', '/porpoiseant/banger.js?cb=195-0&bv=103&v=57&PageSpeed=off', true, [], true, false, false, true);</script>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.vep=(function(){var pixels=[],pxURL="/detroitchicago/grapefruit.gif";function AddPixel(vID,pixelData){if(__ez.dot.isDefined(vID)&&__ez.dot.isValid(pixelData)){pixels.push({type:'video',video_impression_id:vID,domain_id:__ez.dot.getDID(),t_epoch:__ez.dot.getEpoch(0),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender"){return;}
if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&v="+btoa(JSON.stringify(pushPixels));__ez.dot.Fire(pixelURL);}}
pixels=[];}
return{Add:AddPixel,Fire:Fire};})();</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){if(impId!=="0"&&adUnit!==""){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();</script>
	
	<meta name="viewport" content="width=device-width, initial-scale=1"/>
	<link rel="profile" href="https://gmpg.org/xfn/11"/>
	
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer="" type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="RXkib4zQQ3OMs4BhnpM0zLxzD_1u4PlHktSsr5hfm7g"/>

<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>Using SlickStack to Install WordPress Automatically on Ubuntu 20.04</title>
<meta name="description" content="SlickStack is essentially a collection of scripts for quickly and easily installing WordPress, with NginxVery nice video explanation on YouTube: NGINX"/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://bytexd.com/slickstack/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04"/>
<meta property="og:description" content="SlickStack is essentially a collection of scripts for quickly and easily installing WordPress, with NginxVery nice video explanation on YouTube: NGINX"/>
<meta property="og:url" content="https://bytexd.com/slickstack/"/>
<meta property="og:site_name" content="ByteXD"/>
<meta property="article:publisher" content="https://www.facebook.com/ByteXD/"/>
<meta property="article:section" content="WordPress"/>
<meta property="og:updated_time" content="2022-02-11T18:16:05+00:00"/>
<meta property="og:image" content="https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04.png"/>
<meta property="og:image:secure_url" content="https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04.png"/>
<meta property="og:image:width" content="1280"/>
<meta property="og:image:height" content="720"/>
<meta property="og:image:alt" content="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04"/>
<meta property="og:image:type" content="image/png"/>
<meta property="article:published_time" content="2021-11-23T13:56:45+00:00"/>
<meta property="article:modified_time" content="2022-02-11T18:16:05+00:00"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:title" content="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04"/>
<meta name="twitter:description" content="SlickStack is essentially a collection of scripts for quickly and easily installing WordPress, with NginxVery nice video explanation on YouTube: NGINX"/>
<meta name="twitter:site" content="@ByteXD"/>
<meta name="twitter:creator" content="@shwayguy"/>
<meta name="twitter:image" content="https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04.png"/>
<meta name="twitter:label1" content="Written by"/>
<meta name="twitter:data1" content="EdXD"/>
<meta name="twitter:label2" content="Time to read"/>
<meta name="twitter:data2" content="17 minutes"/>
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["Organization"],"@id":"https://bytexd.com/#organization","name":"ByteXD","url":"https://bytexd.com","logo":{"@type":"ImageObject","@id":"https://bytexd.com/#logo","url":"https://bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-Main.png","caption":"ByteXD","inLanguage":"en-US","width":"214","height":"72"},"openingHours":["Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday 09:00-17:00"]},{"@type":"WebSite","@id":"https://bytexd.com/#website","url":"https://bytexd.com","name":"ByteXD","publisher":{"@id":"https://bytexd.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04.png","url":"https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04.png","width":"1280","height":"720","caption":"Using SlickStack to Install WordPress Automatically on Ubuntu 20.04","inLanguage":"en-US"},{"@type":"Person","@id":"https://bytexd.com/author/edxd/","name":"EdXD","url":"https://bytexd.com/author/edxd/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/908729a6f7effb4a6f8c5b48c6855cd2?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/908729a6f7effb4a6f8c5b48c6855cd2?s=96&amp;d=mm&amp;r=g","caption":"EdXD","inLanguage":"en-US"},"sameAs":["https://twitter.com/https://twitter.com/shwayguy"],"worksFor":{"@id":"https://bytexd.com/#organization"}},{"@type":"WebPage","@id":"https://bytexd.com/slickstack/#webpage","url":"https://bytexd.com/slickstack/","name":"Using SlickStack to Install WordPress Automatically on Ubuntu 20.04","datePublished":"2021-11-23T13:56:45+00:00","dateModified":"2022-02-11T18:16:05+00:00","author":{"@id":"https://bytexd.com/author/edxd/"},"isPartOf":{"@id":"https://bytexd.com/#website"},"primaryImageOfPage":{"@id":"https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04.png"},"inLanguage":"en-US"},{"@type":"BlogPosting","headline":"Using SlickStack to Install WordPress Automatically on Ubuntu 20.04","datePublished":"2021-11-23T13:56:45+00:00","dateModified":"2022-02-11T18:16:05+00:00","author":{"@id":"https://bytexd.com/author/edxd/"},"publisher":{"@id":"https://bytexd.com/#organization"},"description":"SlickStack is essentially a collection of scripts for quickly and easily installing WordPress, with NginxVery nice video explanation on YouTube: NGINX","name":"Using SlickStack to Install WordPress Automatically on Ubuntu 20.04","@id":"https://bytexd.com/slickstack/#richSnippet","isPartOf":{"@id":"https://bytexd.com/slickstack/#webpage"},"image":{"@id":"https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04.png"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://bytexd.com/slickstack/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel="dns-prefetch" href="//s.w.org"/>
<link href="https://fonts.gstatic.com" crossorigin="" rel="preconnect"/>
<link rel="alternate" type="application/rss+xml" title="ByteXD » Feed" href="https://bytexd.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="ByteXD » Comments Feed" href="https://bytexd.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="ByteXD » Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 Comments Feed" href="https://bytexd.com/slickstack/feed/"/>
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/bytexd.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="alternate stylesheet" id="powerkit-icons-css" href="https://bytexd.com/wp-content/plugins/powerkit/assets/fonts/powerkit-icons.woff?ver=2.6.6" type="text/css" as="font" crossorigin=""/>
<link rel="stylesheet" id="powerkit-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/powerkit-vc934af1e2ce9f947e911ad4ba65c3d823012e840.css" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-block-library-css" href="https://bytexd.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9" type="text/css" media="all"/>
<style id="wp-block-library-inline-css" type="text/css">
.has-text-align-justify{text-align:justify;}
</style>
<link rel="stylesheet" id="mediaelement-css" href="https://bytexd.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-mediaelement-css" href="https://bytexd.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9" type="text/css" media="all"/>
<style id="global-styles-inline-css" type="text/css">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</style>
<link rel="stylesheet" id="modern_footnotes-css" href="https://bytexd.com/wp-content/plugins/modern-footnotes/styles.min.css?ver=1.4.11" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-author-box-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/powerkit-author-box-ve2ed2d77101778ecf24079e88d664c896aa65bc9.css" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-basic-elements-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/powerkit-basic-elements-vb4b9214b790ef36e2c0f7bc8f8ff2a7f60f7b85d.css" type="text/css" media="screen"/>
<link rel="stylesheet" id="powerkit-content-formatting-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/powerkit-content-formatting-v17cffffc03ab86f75871863981f753164d420136.css" type="text/css" media="all"/>
<link rel="stylesheet" id="glightbox-css" href="https://bytexd.com/wp-content/plugins/powerkit/modules/lightbox/public/css/glightbox.min.css?ver=2.6.6" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-lightbox-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/powerkit-lightbox-v39248e9c97b35063e9968458652b80d77e5fdb55.css" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-share-buttons-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/powerkit-share-buttons-v60a4de61023dcad56be81482f85d919c2654a769.css" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-table-of-contents-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/powerkit-table-of-contents-v38378cc5a352fc854167aa65156f6274c1b9b604.css" type="text/css" media="all"/>
<link rel="stylesheet" id="wpel-style-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/wpel-style-v802f6b70fb48ef2d9edac47c9361adfad7cb5823.css" type="text/css" media="all"/>
<link rel="stylesheet" id="wpdiscuz-frontend-css-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/wpdiscuz-frontend-css-v7c3e99f0fe45d4a030ece9b68465f6e83d13baa8.css" type="text/css" media="all"/>
<style id="wpdiscuz-frontend-css-inline-css" type="text/css">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</style>
<link rel="stylesheet" id="wpdiscuz-fa-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/css/fa.min.css?ver=7.3.12" type="text/css" media="all"/>
<link rel="stylesheet" id="quill-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/quill/quill.snow.min.css?ver=1.3.6" type="text/css" media="all"/>
<link rel="stylesheet" id="wmu-colorbox-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/colorbox/colorbox.min.css?ver=5.9" type="text/css" media="all"/>
<link rel="stylesheet" id="wpdiscuz-mu-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-mu-frontend.min.css?ver=5.9" type="text/css" media="all"/>
<link rel="stylesheet" id="wpdiscuz-user-content-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-user-content.min.css?ver=7.3.12" type="text/css" media="all"/>
<link rel="stylesheet" id="csco-styles-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/csco-styles-v8176a303f65e8305e5ff5eccee8bf9854c258f8e.css" type="text/css" media="all"/>
<style id="csco-styles-inline-css" type="text/css">
.searchwp-live-search-no-min-chars:after { content: "Continue typing" }
</style>
<link rel="stylesheet" id="searchwp-live-search-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/searchwp-live-search-v0f1aee806421be2dcb1d93b8eae367a18114ae2c.css" type="text/css" media="all"/>
<link rel="stylesheet" id="tablepress-default-css" href="https://bytexd.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.14" type="text/css" media="all"/>
<link rel="stylesheet" id="tablepress-responsive-tables-css" href="https://bytexd.com/wp-content/plugins/tablepress-responsive-tables/css/tablepress-responsive.min.css?ver=1.8" type="text/css" media="all"/>
<link rel="stylesheet" id="aawp-css" href="https://bytexd.com/wp-content/plugins/aawp/assets/dist/css/main.css?ver=3.17.3" type="text/css" media="all"/>
<link rel="stylesheet" id="csco_child_css-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/csco_child_css-vfc5b8d25b193461260209885a276abb29753aa0b.css" type="text/css" media="all"/>
<link rel="stylesheet" id="jetpack_css-css" href="https://bytexd.com/wp-content/cache/asset-cleanup/css/item/jetpack_css-va0ff04b07329e18a3089bb12f2cf4cddda4d3a41.css" type="text/css" media="all"/>
<script type="text/javascript" id="jquery-core-js-extra">
/* <![CDATA[ */
var csco_mega_menu = {"rest_url":"https:\/\/bytexd.com\/wp-json\/csco\/v1\/menu-posts"};
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0" id="jquery-core-js"></script>
<script type="text/javascript" id="jquery-migrate-js" data-type="lazy" data-src="https://bytexd.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2"></script>
<link rel="https://api.w.org/" href="https://bytexd.com/wp-json/"/><link rel="alternate" type="application/json" href="https://bytexd.com/wp-json/wp/v2/posts/6715"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bytexd.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://bytexd.com/wp-includes/wlwmanifest.xml"/> 
<meta name="generator" content="WordPress 5.9"/>
<link rel="shortlink" href="https://bytexd.com/?p=6715"/>
<link rel="alternate" type="application/json+oembed" href="https://bytexd.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbytexd.com%2Fslickstack%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://bytexd.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbytexd.com%2Fslickstack%2F&amp;format=xml"/>
<style type="text/css">.aawp .aawp-tb__row--highlight{background-color:#256aaf;}.aawp .aawp-tb__row--highlight{color:#256aaf;}.aawp .aawp-tb__row--highlight a{color:#256aaf;}</style>
<link rel="dns-prefetch" href="https://cdn.statically.io/"/>
<link rel="preconnect" href="https://cdn.statically.io/" crossorigin=""/>
        <style>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</style>
<style>

.tablepress td.column-3 {
	font-size: 15px;
}
	
.feature-attribute {
    font-weight: 600;
}

.tablepress tbody td,.tablepress tfoot th{
    border:none!important;
}
table tfoot th,table thead th{
    background-color:#EAEAEC !important;
}
.tablepress tr{
    margin:0 0 2rem 0;
    border:1px solid #EAEAEC!important;
}
.tablepress td{
    vertical-align:middle!important;
}
table.tablepress td.column-2 a{
    color:#000;
    font-weight:600;
    text-decoration:underline;
}
@media only screen and (min-width:761px){
    .tablepress .column-1 img{
        max-width:200px!important;
    }
    .tablepress .column-4{
        min-width:10rem;
    }
    .tablepress .column-3{
        min-width:15rem;
    }
    .tablepress .column-2{
        min-width:8rem;
    }
    table.tablepress td.column-1{
        text-align:center;
    }
    table.tablepress td.column-1 img{
        max-height:200px;
    }
    .product-container a img{
        max-width:300px;
        max-height:300px;
    }
}
@media only screen and (max-width:760px),(min-device-width:768px) and (max-device-width:1200px){
    table.tablepress,table.tablepress tbody,table.tablepress td,table.tablepress th,table.tablepress thead,table.tablepress tr{
        display:block;
    }
    .tablepress thead tr{
        position:absolute;
        top:-9999px;
        left:-9999px;
    }
    .tablepress tr{
        margin:0 0 2rem 0;
        border:1px solid #d0d4dc!important;
    }
    .tablepress td:nth-child(2),.tablepress td:nth-child(3),.tablepress td:nth-child(4){
        position:relative;
        padding-left:35%!important;
    }
    .tablepress figure{
        width:100%;
    }
    .tablepress td:first-child{
        text-align:center;
    }
    .tablepress td:before{
        position:absolute;
        top:50%;
        transform:translateY(-50%);
        left:6px;
        padding:8px;
        white-space:nowrap;
        font-weight:500;
        font-size:1em;
    }
    .tablepress td:nth-of-type(2):before{
        content:"Product";
    }
    .tablepress td:nth-of-type(3):before{
        content:"Details";
    }
	.tablepress td:nth-of-type(4):before{
        content:"Vendor";
    }
    .tablepress figure img{
        width:100%;
    }
	
	.tablepress .aawp-custom-price,
	.tablepress .price-currentness {
		text-align: center;
	}
}

@media (max-width:1200px){

    .tablepress .column-3{
        min-width:2rem!important;
    }
    .tablepress .column-2{
        min-width:2rem!important;
    }
}
	
@media only screen and (min-width: 600px) {
.tablepress .column-1 img {
    max-width: 200px !important;
}}
	
.tablepress>tbody td.column-3 span>strong{
    color:#000;
}

table.tablepress td.column-2 a{
    color:#2176FF !important;
    line-height:1;
    text-decoration:none!important;
}
table.tablepress td.column-2 a strong{
    font-size:16px!important;
    text-decoration:none!important;
}

.tablepress td.column-2,
.tablepress td.column-3,
.tablepress td.column-4	{
	text-align: left !important;
}

.tablepress tfoot th, .tablepress thead th {
	font-weight: 600;
	color: #000;
}


</style>
<style>

.aawp-custom-price {
	text-align: right;
	margin-bottom: 0.25rem;
}

.aawp-custom-price .price {
	font-weight: 600;
	font-size: 1rem;
}

.price-currentness {
	display: block;
	margin-top: 1.5rem;
	font-size: 0.75rem;
	text-align: right;
	color: #A8AAB2;
}

a.aawp-button.aawp-button--buy {
	width: 100%;
	border: none !important;
	background: #2176FF ;
	border-radius: 3px;
	color: #EAEAEC !important;
	font-weight: 600;
}
.aawp-button:focus, .aawp-button:hover, .aawp .aawp-button:focus, .aawp .aawp-button:hover, a.aawp-button.aawp-button--buy:hover {
  border: none !important;
  background: #5C9AFF;
  color: #EAEAEC !important;
	
}
	
.aawp-product.aawp-product--horizontal {
	border: none;
	box-shadow: 0 16px 36px 0 rgba(0,0,0,0.08);
}

/* AAWP Amazon Link icons resize when hovering over containing links. We prevent this because resizing makes things look clunky */
.aawp-link-icon-container:hover .aawp-link-icon, .aawp-link:hover+.aawp-link-icon-container .aawp-link-icon {
    height: 16px;
    width: 16px;
}

/* Style Affiliate Disclosure */
.commission-disclosure {
	font-size: 14px;
	display: block;
    margin: auto;
    max-width: 750px;
    margin-bottom: 2rem;
    color: #A8AAB2;
}

.commission-disclosure a {
	color: #A8AAB2;
	text-decoration: underline;
}

.aawp-container .aawp-product__thumb {
	display:flex;
	align-items: center;
}

.aawp .aawp-product--vertical .aawp-product__image {
	width: unset;
}

.aawp-container .aawp-product__footer {
	clear: both;
	width: 100%;
	margin-left: unset !important;
	padding-left: unset !important;
}

.aawp-container {
    display: flex;
    max-width: 350px;
    flex-direction: column;
	  float: right;
	  margin-left: 1.5rem;
}

.aawp-container .aawp-product__content {
	min-height: unset !important;
}

.aawp-container .aawp-disclaimer {
	display: block;
	max-width: 350px;
	color: #A8AAB2;
}

	
h2 a.aawp-link {
	color: #2176FF;
}
	
@media (max-width: 600px)  {
	.aawp-container {
		float: none;
		margin: auto;
	}
}

	/* Amazon Price Change Disclaimer */
.price-change-details .string {
	text-decoration: underline;
}
	
.price-change-details {
    position: relative;
    display: inline-flex;
}

.price-change-details .info {
    position: absolute;
    border: 1px solid #eaeaea;
    background: #fff;
    padding: 1rem;
    visibility: hidden;
    opacity: 0;
    width: 100vw;
    max-width: 250px;
    position: absolute;
    z-index: 2;
    bottom: 2rem;
    right: -1.5rem;
    font-size: 14px !important;
    line-height: normal;
    color: #000 !important;
    transition: opacity .3s;
    border-radius: 0.3rem;
    white-space: normal;
    text-align: left;
}

.price-change-details:hover .info {
    opacity: 1;
    visibility: visible;
}
	
aawp-product__footer {
	padding-top: 0.5rem;
}
</style>

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer="" type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["wordpress","ubuntu","website-setup"],"pagePostAuthor":"EdXD"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KX8VTB3');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><style type="text/css">img#wpstats{display:none}</style>
	<link rel="icon" href="https://bytexd.com/wp-content/uploads/2020/06/cropped-ByteXD-Logo-_-Icon-2-32x32.png" sizes="32x32"/>
<link rel="icon" href="https://bytexd.com/wp-content/uploads/2020/06/cropped-ByteXD-Logo-_-Icon-2-192x192.png" sizes="192x192"/>
<link rel="apple-touch-icon" href="https://bytexd.com/wp-content/uploads/2020/06/cropped-ByteXD-Logo-_-Icon-2-180x180.png"/>
<meta name="msapplication-TileImage" content="https://bytexd.com/wp-content/uploads/2020/06/cropped-ByteXD-Logo-_-Icon-2-270x270.png"/>
<style id="kirki-inline-styles">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</style><style>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</style><script type="text/javascript">var ezouid = "1";</script><base href="https://bytexd.com/slickstack/"><script type='text/javascript'>
var ezoTemplate = 'pub_site';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 283186;
var ezdomain = 'bytexd.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_283186=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["1904890e-0edb-4d1f-5a31-091b9e0cfa10", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script>
<script type="text/javascript">var _audins_dom="bytexd_com",_audins_did=283186;__ez.queue.addFile('/detroitchicago/cmbv2.js', '/detroitchicago/cmbv2.js?gcb=195-0&cb=04-1y02-5y06-12y07-1y0b-5y0d-14y13-3y17-4y1f-5y21-3y34-23y53-1y57-21&cmbcb=20&sj=x04x02x06x07x0bx0dx13x17x1fx21x34x53x57', true, [], true, false, true, false);</script>
<script type="text/javascript" defer>__ez.queue.addFile('/detroitchicago/cmbdv2.js', '/detroitchicago/cmbdv2.js?gcb=195-0&cb=03-5y0c-5y18-4y35-23y58-21&cmbcb=20&sj=x03x0cx18x35x58', true, ['/detroitchicago/cmbv2.js'], true, false, true, false);</script><script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js'></script></head>

<body class="post-template-default single single-post postid-6715 single-format-standard wp-embed-responsive aawp-custom cs-page-layout-right header-compact navbar-width-fullwidth navbar-alignment-left navbar-sticky-enabled navbar-smart-enabled sticky-sidebar-enabled stick-to-bottom block-align-enabled">

	<div class="site-overlay"></div>

	<div class="offcanvas">

		<div class="offcanvas-header">

			
			<nav class="navbar navbar-offcanvas">

									<a class="navbar-brand" href="https://bytexd.com/" rel="home" data-wpel-link="internal">
						<img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="ByteXD" sizes="(max-width: 214px) 100vw, 214px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?w=214&amp;quality=100&amp;f=auto 214w,"/>					</a>
					
				<button type="button" class="toggle-offcanvas">
					<i class="cs-icon cs-icon-x"></i>
				</button>

			</nav>

			
		</div>

		<aside class="offcanvas-sidebar">
			<div class="offcanvas-inner widget-area">
				<div class="widget widget_nav_menu cs-d-lg-none"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-2624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2624"><a href="#">Linux Tutorials</a>
<ul class="sub-menu">
	<li id="menu-item-5238" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5238"><a href="https://bytexd.com/category/linux-commands/" data-wpel-link="internal">Linux Commands</a></li>
	<li id="menu-item-2617" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2617"><a href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal">Ubuntu</a></li>
	<li id="menu-item-2618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2618"><a href="https://bytexd.com/category/centos/" data-wpel-link="internal">CentOS</a></li>
	<li id="menu-item-5237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5237"><a href="https://bytexd.com/category/debian/" data-wpel-link="internal">Debian</a></li>
</ul>
</li>
<li id="menu-item-2625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2625"><a href="#">General Tutorials</a>
<ul class="sub-menu">
	<li id="menu-item-2620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2620"><a href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal">Miscellaneous</a></li>
	<li id="menu-item-2621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2621"><a href="https://bytexd.com/category/digital-marketing/" data-wpel-link="internal">Digital Marketing</a></li>
	<li id="menu-item-2622" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2622"><a href="https://bytexd.com/category/website-setup/" data-wpel-link="internal">Website Setup</a></li>
</ul>
</li>
<li id="menu-item-6705" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6705"><a href="https://bytexd.com/hardware/" data-wpel-link="internal">Hardware</a></li>
</ul></div></div>
							</div>
		</aside>
	</div>

<div id="page" class="site">

	
	<div class="site-inner">

		
		<header id="masthead" class="site-header">
			


<nav class="navbar navbar-primary navbar-shadow-enabled">

	
	<div class="navbar-wrap">

		<div class="navbar-container">

			<div class="navbar-content">

				<div class="navbar-col">
							<button type="button" class="navbar-toggle-offcanvas toggle-offcanvas  cs-d-lg-none">
			<i class="cs-icon cs-icon-menu"></i>
		</button>
				<div class="navbar-brand">
							<a href="https://bytexd.com/" rel="home" data-wpel-link="internal">
					<img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="ByteXD" sizes="(max-width: 214px) 100vw, 214px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?w=214&amp;quality=100&amp;f=auto 214w,"/>				</a>
						</div>
		<ul id="menu-primary-1" class="navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2624"><a href="#"><span>Linux Tutorials</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5238"><a href="https://bytexd.com/category/linux-commands/" data-wpel-link="internal">Linux Commands</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2617"><a href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal">Ubuntu</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2618"><a href="https://bytexd.com/category/centos/" data-wpel-link="internal">CentOS</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5237"><a href="https://bytexd.com/category/debian/" data-wpel-link="internal">Debian</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2625"><a href="#"><span>General Tutorials</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2620"><a href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal">Miscellaneous</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2621"><a href="https://bytexd.com/category/digital-marketing/" data-wpel-link="internal">Digital Marketing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2622"><a href="https://bytexd.com/category/website-setup/" data-wpel-link="internal">Website Setup</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6705"><a href="https://bytexd.com/hardware/" data-wpel-link="internal"><span>Hardware</span></a></li>
</ul>				</div>

				<div class="navbar-col">
									</div>

				<div class="navbar-col">
							<div class="navbar-social-links">
				<div class="pk-social-links-wrap  pk-social-links-template-nav pk-social-links-align-default pk-social-links-scheme-light pk-social-links-titles-disabled pk-social-links-counts-disabled pk-social-links-labels-disabled">
		<div class="pk-social-links-items">
								<div class="pk-social-links-item pk-social-links-facebook  pk-social-links-no-count" data-id="facebook">
						<a href="https://facebook.com/ByteXD" class="pk-social-links-link" target="_blank" rel="nofollow noopener" aria-label="Facebook" data-wpel-link="exclude">
							<i class="pk-social-links-icon pk-icon pk-icon-facebook"></i>
							
							
							
													</a>
					</div>
										<div class="pk-social-links-item pk-social-links-twitter  pk-social-links-no-count" data-id="twitter">
						<a href="https://twitter.com/ByteXD" class="pk-social-links-link" target="_blank" rel="nofollow noopener" aria-label="Twitter" data-wpel-link="exclude">
							<i class="pk-social-links-icon pk-icon pk-icon-twitter"></i>
							
							
							
													</a>
					</div>
										<div class="pk-social-links-item pk-social-links-mastodon  pk-social-links-no-count" data-id="mastodon">
						<a href="https://mastodon.online/@bytexd" class="pk-social-links-link" target="_blank" rel="nofollow noopener" aria-label="Mastodon" data-wpel-link="exclude">
							<i class="pk-social-links-icon pk-icon pk-icon-mastodon"></i>
							
							
							
													</a>
					</div>
							</div>
	</div>
			</div>
					<div class="navbar-follow navbar-follow-button">
				<a class="button navbar-follow-btn" href="https://www.instagram.com/byte.xd/" target="_blank" data-wpel-link="exclude">
					Follow <i class="pk-icon pk-icon-instagram"></i>				</a>
			</div>
					<button type="button" class="navbar-toggle-search toggle-search">
			<i class="cs-icon cs-icon-search"></i>
		</button>
						</div>

			</div><!-- .navbar-content -->

		</div><!-- .navbar-container -->

	</div><!-- .navbar-wrap -->

	
<div class="site-search-wrap" id="search">
	<div class="site-search">
		<div class="cs-container">
			<div class="search-form-wrap">
				
<form role="search" method="get" class="search-form" action="https://bytexd.com/">
	<label class="sr-only">Search for:</label>
	<div class="cs-input-group">
		<input type="search" value="" name="s" data-swplive="true" data-swpengine="default" data-swpconfig="default" class="search-field" placeholder="Enter your search topic" required=""/>
		<button type="submit" class="search-submit">Search</button>
	</div>
</form>
				<span class="search-close"></span>
			</div>
		</div>
	</div>
</div>

</nav><!-- .navbar -->
		</header><!-- #masthead -->

		
		<div class="site-primary">

			
			<div class="site-content sidebar-enabled sidebar-right post-sidebar-enabled">

				
				<div class="cs-container">

					
					<div id="content" class="main-content">

						
	<div id="primary" class="content-area">

		
		<main id="main" class="site-main">

			
			
				
					
<article class="entry-preview entry post-6715 post type-post status-publish format-standard has-post-thumbnail category-wordpress category-ubuntu category-website-setup">

	
	<!-- Full Post Layout -->
	
	
<section class="entry-header entry-header-standard entry-header-thumbnail">

	<div class="entry-header-inner">

		
		
					<div class="entry-inline-meta">
				<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal"><span style="background:#e95420" class="char cs-bg-dark">U</span><span class="label">Ubuntu</span></a></div>			</div>
		
					<h1 class="entry-title">Using SlickStack to Install WordPress Automatically on Ubuntu 20.04</h1>		
		<ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">November 23, 2021</li><li class="meta-shares">			<span class="total">
				<i class="cs-icon cs-icon-share"></i>
				<span class="total-number">
					3 shares				</span>
			</span>
			<div class="meta-share-links">
						<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-post_meta pk-share-buttons-mode-cached" data-post-id="6715" data-share-url="https://bytexd.com/slickstack/">

			
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">3</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=Using%20SlickStack%20to%20Install%20WordPress%20Automatically%20on%20Ubuntu%2020.04&amp;via=ByteXD&amp;url=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/slickstack/&amp;media=https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04-1024x576.png" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
				</div>
		</li><li class="meta-comments"><i class="cs-icon cs-icon-message-square"></i><a href="https://bytexd.com/slickstack/#respond" class="comments-link" data-wpel-link="internal">No comments</a></li><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>12 minute read</li></ul>
					<div class="post-media">
				<figure>
					<a href="https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04.png" data-wpel-link="internal">
						<img width="800" height="500" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="pk-lazyload-disabled wp-post-image" alt="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 1" sizes="(max-width: 800px) 100vw, 800px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04-800x500.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04-800x500.png?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04-800x500.png?w=800&amp;quality=100&amp;f=auto 800w,"/>					</a>
									</figure>
			</div>
			
		
	</div>

</section><span id="ezoic-pub-ad-placeholder-108" class="ezoic-adpicker-ad"></span><span class="ezoic-ad box-3 box-3108 adtester-container adtester-container-108" data-ez-name="bytexd_com-box-3"><span id="div-gpt-ad-bytexd_com-box-3-0" ezaw="728" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:90px;min-width:728px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-box-3-0')};</script></span></span>
			<div class="entry-container">
											<div class="entry-sidebar-wrap">
								<div class="entry-sidebar">
									<div class="post-sidebar-shares">
										<div class="post-sidebar-inner">
													<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-has-total-counts pk-share-buttons-post_sidebar pk-share-buttons-mode-php pk-share-buttons-mode-rest" data-post-id="6715" data-share-url="https://bytexd.com/slickstack/">

							<div class="pk-share-buttons-total">
							<div class="pk-share-buttons-caption">
			<div class="pk-share-buttons-count cs-font-primary"> 3</div>
			<div class="pk-share-buttons-label cs-font-secondary">Shares</div>
		</div>
						</div>
				
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">3</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=Using%20SlickStack%20to%20Install%20WordPress%20Automatically%20on%20Ubuntu%2020.04&amp;via=ByteXD&amp;url=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/slickstack/&amp;media=https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04-1024x576.png" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-mail pk-share-buttons-no-count" data-id="mail">

							<a href="/cdn-cgi/l/email-protection#8bb4f8fee9e1eee8ffb6def8e2e5ecaeb9bbd8e7e2e8e0d8ffeae8e0aeb9bbffe4aeb9bbc2e5f8ffeae7e7aeb9bbdce4f9efdbf9eef8f8aeb9bbcafeffe4e6eaffe2e8eae7e7f2aeb9bbe4e5aeb9bbdee9fee5fffeaeb9bbb9bba5bbbfadeae6fbb0e9e4eff2b6def8e2e5ecaeb9bbd8e7e2e8e0d8ffeae8e0aeb9bbffe4aeb9bbc2e5f8ffeae7e7aeb9bbdce4f9efdbf9eef8f8aeb9bbcafeffe4e6eaffe2e8eae7e7f2aeb9bbe4e5aeb9bbdee9fee5fffeaeb9bbb9bba5bbbfaeb9bbe3fffffbf8b1a4a4e9f2ffeef3efa5e8e4e6a4f8e7e2e8e0f8ffeae8e0a4" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-mail"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
											</div>
									</div>
								</div>
							</div>
						
	<!-- Full Post Layout and Full Content -->
	<div class="entry-content-wrap">

		
		<div class="entry-content">

			<p><strong>SlickStack</strong> is essentially a collection of scripts for quickly and easily installing WordPress, with Nginx<sup class="modern-footnotes-footnote modern-footnotes-footnote--hover-on-desktop" data-mfn="1" data-mfn-post-scope="0000000034eb1feb00000000004a0a4b_6715"><a href="javascript:void(0)" role="button" aria-pressed="false" aria-describedby="mfn-content-0000000034eb1feb00000000004a0a4b_6715" data-wpel-link="internal">1</a></sup><span id="mfn-content-0000000034eb1feb00000000004a0a4b_6715" role="tooltip" class="modern-footnotes-footnote__note" tabindex="0" data-mfn="1">Very nice video explanation on YouTube: <a href="https://www.youtube.com/watch?v=JKxlsvZXG7c" target="_blank" rel="noopener external" data-wpel-link="external" class="wpel-icon-right">NGINX Explained in 100 Seconds (YouTube)<span class="wpel-icon wpel-image wpel-icon-7"></span></a> by Fireship.io</span> as a web server, on Ubuntu LTS.</p>
<p>It aims at making it easier for users to deploy lightweight, fast and secure WordPress websites, and guides users and helps them secure their server during the installation process.</p>
<p>This is especially useful for new users who just need to painlessly setup a fast and secure WordPress website on a cheap Ubuntu server, which can be cheaper and faster than paying for shared hosting. These servers usually cost $5-$10.</p>
<p>The philosophy of SlickStack can be found towards the end of their main page at <a href="https://slickstack.io/" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">slickstack.io<span class="wpel-icon wpel-image wpel-icon-7"></span></a>. That, along with the fact that the developer is <a href="https://slickstack.io/hosting/littlebizzy" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">very experienced in web hosting<span class="wpel-icon wpel-image wpel-icon-7"></span></a> and passionate about the project, are the factors that I think make SlickStack worth considering for your projects.</p>
<p>The developer is very helpful and frequently asks for feedback regarding the direction of SlickStack, so they can improve. This is <em><span style="text-decoration: underline;">very important</span></em>, because if you adopt a software for your long term project, you want to know that software will stay up-to-date, will get new features, and will patch any potential vulnerabilities.<span id="ezoic-pub-ad-placeholder-160" class="ezoic-adpicker-ad"></span><span class="ezoic-ad medrectangle-3 medrectangle-3160 adtester-container adtester-container-160" data-ez-name="bytexd_com-medrectangle-3"><span id="div-gpt-ad-bytexd_com-medrectangle-3-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-medrectangle-3-0')};</script></span></span></p>
<div class="analogy">In this article we’ll go over how to use SlickStack to install WordPress on a server running Ubuntu 20.04 LTS, as well as give you a basic overview of some of its options. We won’t be able to cover all of its options, however, so be sure to check <a href="https://github.com/littlebizzy/slickstack" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">their Github<span class="wpel-icon wpel-image wpel-icon-7"></span></a> and <a href="https://slickstack.io/" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">slickstack.io<span class="wpel-icon wpel-image wpel-icon-7"></span></a> for more in-depth info.</div><span id="ezoic-pub-ad-placeholder-104" class="ezoic-adpicker-ad"></span><span class="ezoic-ad banner-1 banner-1104 adtester-container adtester-container-104" data-ez-name="bytexd_com-banner-1"><span id="div-gpt-ad-bytexd_com-banner-1-0" ezaw="468" ezah="60" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:60px;min-width:468px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-banner-1-0')};</script></span></span>
			<div class="pk-toc">
									<h5 class="pk-title pk-toc-title pk-font-block">
						Table of Contents
											</h5>
				
				<ol><li><a href="#demo-installing-wordpress-with-slickstack">Demo Installing WordPress with SlickStack</a></li><li><a href="#prerequisites">Prerequisites</a><ol><li><a href="#hardware-requirements">Hardware Requirements</a></li><li><a href="#software-server-configuration-requirements">Software &amp; Server Configuration Requirements</a></li><li><a href="#dns-requirements">DNS Requirements</a><ol><li><a href="#using-cloudflare-dns">Using Cloudflare DNS</a></li><li><a href="#why-slickstack-requires-cloudflare">Why SlickStack Requires Cloudflare</a></li><li><a href="#how-to-add-a-new-domain-to-cloudflare">How to Add a New Domain to Cloudflare</a></li><li><a href="#point-your-domain-to-our-server-add-a-records">Point Your Domain to Our Server (Add A Records)</a></li><li><a href="#recommended-cloudflare-settings-for-wordpress">Recommended Cloudflare Settings for WordPress</a></li></ol></li></ol></li><li><a href="#using-slickstack-to-install-wordpress">Using SlickStack to Install WordPress</a><ol><li><a href="#method-1-quick-install-setup-wizard">Method 1. Quick Install (Setup Wizard)</a><ol><li><a href="#slickstack-interactive-setup-wizard-ss-config">SlickStack Interactive Setup Wizard (SS-Config)</a></li></ol></li><li><a href="#method-2-setting-up-slickstack-configuration-manually">Method 2. Setting Up SlickStack Configuration Manually</a></li></ol></li><li><a href="#post-installation">Post Installation</a></li><li><a href="#additional-notes">Additional Notes</a><ol><li><a href="#slickstack-disables-the-root-user">SlickStack disables the root user</a></li><li><a href="#redirect-loop-err_too_many_redirects">Redirect Loop (ERR_TOO_MANY_REDIRECTS)</a></li><li><a href="#changing-the-config-file-and-applying-changes">Changing the config file and applying changes</a></li></ol></li><li><a href="#conclusion">Conclusion</a></li></ol>			</div>
		
<h2 id="demo-installing-wordpress-with-slickstack">Demo Installing WordPress with SlickStack</h2>
<p>We’ll start quick demo of how you can install WordPress with SlickStack. We’ll get into the details and requirements further in this tutorial.<span id="ezoic-pub-ad-placeholder-117" class="ezoic-adpicker-ad"></span></p>
<p>Assuming you meet all the requirements, to download and run SlickStack just run the command below.<span id="ezoic-pub-ad-placeholder-131" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-leaderboard-2 large-leaderboard-2131 adtester-container adtester-container-131" data-ez-name="bytexd_com-large-leaderboard-2"><span id="div-gpt-ad-bytexd_com-large-leaderboard-2-0" ezaw="250" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-large-leaderboard-2-0')};</script></span></span></p>
<p>It will ask you to wait 30 seconds if you want to be guided by the setup wizard to configure your WordPress installation, otherwise you can skip waiting and edit the configuration file yourself.</p>
<p>In our example I’ll install WordPress using the setup wizard:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">cd /tmp/ &amp;&amp; wget -O ss slick.fyi &amp;&amp; bash ss</pre>
<div class="asciinema"><asciinema-player src="https://bytexd.com/wp-content/uploads/2021/11/slickstack-1.json" cols="100" rows="24" start-at="0" speed="1" idle-time-limit="" font-size="small" theme="asciinema" poster="data:text/plain,&#34;"></asciinema-player></div>
<p>After the script has finished running you can save your details somewhere safe, and visit the website to finish up the WordPress installation.<span id="ezoic-pub-ad-placeholder-125" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-1 leader-1125 adtester-container adtester-container-125" data-ez-name="bytexd_com-leader-1"><span id="div-gpt-ad-bytexd_com-leader-1-0" ezaw="468" ezah="60" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-1-0')};</script></span></span></p>
<p><img class="alignnone size-large wp-image-6802 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="install wp" width="1024" height="788" sizes="(max-width: 1024px) 100vw, 1024px" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 17" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-1024x788.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-1024x788.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-300x231.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-768x591.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-380x292.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-800x616.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-1160x893.png?quality=100&amp;f=auto 1160w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp.png?quality=100&amp;f=auto 1398w,"/></p>
<p>After you have gone through the installation steps WordPress is set up.</p>
<p><img class="alignnone size-large wp-image-6803 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="wordpress installed" width="1024" height="740" sizes="(max-width: 1024px) 100vw, 1024px" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 18" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed-1024x740.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed-1024x740.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed-300x217.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed-768x555.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed-1536x1110.png?quality=100&amp;f=auto 1536w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed-380x275.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed-800x578.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed-1160x838.png?quality=100&amp;f=auto 1160w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/wordpress_installed.png?quality=100&amp;f=auto 1814w,"/></p>
<h2 id="prerequisites">Prerequisites</h2>
<p>SlickStack encourages users to stick to best practices when it comes to security, speed, and performance.</p>
<p>This is very important and useful, especially to newer Linux users, because it sets you up with the knowledge to rapidly deploy fast and secure WordPress websites in the future, even if you decide not to use SlickStack.</p>
<p>For this reason, if you’re not already familiar with them, the following requirements and recommended settings may seem a bit more intimidating at first glance, compared to other tutorials on installing WordPress automatically.<span id="ezoic-pub-ad-placeholder-126" class="ezoic-adpicker-ad"></span><span class="ezoic-ad narrow-sky-2 narrow-sky-2126 adtester-container adtester-container-126" data-ez-name="bytexd_com-narrow-sky-2"><span id="div-gpt-ad-bytexd_com-narrow-sky-2-0" ezaw="250" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-narrow-sky-2-0')};</script></span></span></p>
<p>This mostly applies to Cloudflare and its recommended settings, because not everyone uses Cloudflare, and many who use it may not configure all of its settings, but we’ll go through them in this article.</p>
<p>As such, before running the SlickStack install command, let’s make sure we fulfill the following requirements:</p>
<h3 id="hardware-requirements">Hardware Requirements</h3>
<ul>
<li>Recommended RAM:
<ul>
<li><strong>1GB RAM</strong> for smaller sites, less complex sites</li>
<li><strong>2GB+ RAM</strong> for more complex or dynamic websites (such as running WooCommerce)</li>
</ul>
</li>
<li><span style="text-decoration: underline;">At least 1 CPU core</span> is recommended (but 2+ CPU cores make it much more responsive)</li>
<li>If you’re using a VPS (Virtual Private Server), <span style="text-decoration: underline;">KVM</span> virtualization is recommended, rather than OpenVZ, Xen, etc. (<a href="https://lowendbox.com/openvz-xen-and-kvm-the-differences-the-advantages-a-comparison/" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">differences between KVM, OpenVZ, Xen<span class="wpel-icon wpel-image wpel-icon-7"></span></a>)</li>
</ul>
<h3 id="software-server-configuration-requirements">Software &amp; Server Configuration Requirements</h3>
<ul>
<li>A server running <span style="text-decoration: underline;">Ubuntu 20.04 LTS</span>. Please take note that it may not work on non-LTS Ubuntu, such as 21.04, or other distros.</li>
<li>Acting as a user with <code data-enlighter-language="raw" class="EnlighterJSRAW">sudo</code> privileges</li>
<li>No containers installed (such as <em>Docker</em>, <em>Kubernetes</em>)</li>
</ul>
<h3 id="dns-requirements">DNS Requirements</h3>
<h4 id="using-cloudflare-dns">Using Cloudflare DNS</h4>
<p>SlickStack requires that you use <a href="https://cloudflare.com" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">Cloudflare<span class="wpel-icon wpel-image wpel-icon-7"></span></a> for DNS<sup class="modern-footnotes-footnote modern-footnotes-footnote--hover-on-desktop" data-mfn="2" data-mfn-post-scope="0000000034eb1feb00000000004a0a4b_6715"><a href="javascript:void(0)" refnum="2" role="button" aria-pressed="false" aria-describedby="mfn-content-0000000034eb1feb00000000004a0a4b_6715" data-wpel-link="internal">2</a></sup><span id="mfn-content-0000000034eb1feb00000000004a0a4b_6715" role="tooltip" class="modern-footnotes-footnote__note" tabindex="0" data-mfn="2">Great explanation on what DNS is: <a href="https://www.youtube.com/watch?v=UVR9lhUGAyU" target="_blank" rel="noopener external" data-wpel-link="external" class="wpel-icon-right">DNS Explained in 100 Seconds (YouTube)<span class="wpel-icon wpel-image wpel-icon-7"></span></a> by Fireship.io</span> management (it’s free), instead of your registrar or your webhost.</p>
<p>If you’re not familiar with Cloudflare DNS, it’s a DNS service that can be used to associate a domain name with an IP address. It can be used as an alternative to traditional DNS services provided by your hosting provider. Cloudflare makes DNS faster, more reliable, and easier to use.</p>
<h4 id="why-slickstack-requires-cloudflare">Why SlickStack Requires Cloudflare</h4>
<p>SlickStack assumes pairing with Cloudflare by default.<span id="ezoic-pub-ad-placeholder-161" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-3 leader-3161 adtester-container adtester-container-161" data-ez-name="bytexd_com-leader-3"><span id="div-gpt-ad-bytexd_com-leader-3-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-3-0')};</script></span></span></p>
<p>The way this works is it installs <a href="https://linux.die.net/man/1/openssl" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">OpenSSL<span class="wpel-icon wpel-image wpel-icon-7"></span></a>, which is a free software library that will generate a self-signed SSL certificate.</p>
<p><em>A self-signed certificate is a certificate that is signed by the same entity that is the subject of the certificate. In other words, the certificate is signed by itself. </em></p>
<p><em>We’re basically creating a certificate and signing it ourselves, instead of having an SSL certificate signed by a trusted certificate authority (commonly referred to as CA), such as Lets Encrypt, DigiCert, Comodo, Verisign, and others you may have heard of.</em></p>
<p><a href="https://certbot.eff.org/" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">Certbot<span class="wpel-icon wpel-image wpel-icon-7"></span></a> (Lets Encrypt client) is used as a backup SSL mechanism. SlickStack uses OpenSSL by default, because it’s native to Ubuntu and Nginx, it’s lightweight, and is a very safe and secure method.</p>
<p>Since OpenSSL is self-signed, and browsers don’t trust it by default, we’ll need to use Cloudflare, which offers a solution for a free SSL.</p><span id="ezoic-pub-ad-placeholder-107" class="ezoic-adpicker-ad"></span><span class="ezoic-ad sky-1 sky-1107 adtester-container adtester-container-107" data-ez-name="bytexd_com-sky-1"><span id="div-gpt-ad-bytexd_com-sky-1-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-sky-1-0')};</script></span></span>
<p>SlickStack will automatically set up WordPress with a free Cloudflare plugin from <a href="https://www.littlebizzy.com/" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">LittleBizzy<span class="wpel-icon wpel-image wpel-icon-7"></span></a> (the developer of SlickStack), which lets you connect to Cloudflare via their API.</p>
<p><em>For more details: </em><a href="https://slickstack.io/modules/cloudflare" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right"><em>https://slickstack.io/modules/cloudflare</em><span class="wpel-icon wpel-image wpel-icon-7"></span></a></p>
<h4 id="how-to-add-a-new-domain-to-cloudflare">How to Add a New Domain to Cloudflare</h4>
<p>To add your domain to Cloudflare, you can check the following video tutorial. It also offers some useful explanations along the way:</p>
<div class="lyte-wrapper" style="width:853px;max-width:100%;margin:5px;"><div class="lyMe hidef" id="WYL_7hY3gp_-9EU"><div id="lyte_7hY3gp_-9EU" data-src="https://bytexd.com/wp-content/plugins/wp-youtube-lyte/lyteCache.php?origThumbUrl=%2F%2Fi.ytimg.com%2Fvi%2F7hY3gp_-9EU%2Fhqdefault.jpg" class="pL"><div class="tC"><div class="tT"></div></div><div class="play"></div><div class="ctrl"><div class="Lctrl"></div><div class="Rctrl"></div></div></div><noscript><a href="https://youtu.be/7hY3gp_-9EU" rel="noopener external" data-wpel-link="external" target="_blank"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="lyteCache.php?origThumbUrl=https%3A%2F%2Fi.ytimg.com%2Fvi%2F7hY3gp 9EU%2F0" width="853" height="460" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 19" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/plugins/wp-youtube-lyte/lyteCache.php?origThumbUrl=https%3A%2F%2Fi.ytimg.com%2Fvi%2F7hY3gp_-9EU%2F0.jpg&quality=100&f=auto"><br />Watch this video on YouTube</a></noscript></div></div><div class="lL" style="max-width:100%;width:853px;margin:5px;"></div><p></p>
<h4 id="point-your-domain-to-our-server-add-a-records">Point Your Domain to Our Server (Add A Records)</h4>
<p>After you’ve added your domain to Cloudflare, we’ll need to point the domain to the server where our website will live. To do this, go into the <strong>DNS</strong> tab in Cloudflare, and add <strong>A records</strong> for your <strong>root domain</strong> ( <code data-enlighter-language="raw" class="EnlighterJSRAW">@</code> ) and <code data-enlighter-language="raw" class="EnlighterJSRAW">www</code> to your server’s IPv4 address. <span style="text-decoration: underline;">If you’re using IPv6 then you’ll need to add AAAA records</span>.</p>
<p>Here’s how I set up the domain I’m using for this tutorial (<strong>mrtest.website</strong>). I’m using a <a href="https://www.vultr.com/products/cloud-compute/" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">$5 Vultr VPS<span class="wpel-icon wpel-image wpel-icon-7"></span></a> (1GB RAM) and I’m pointing my domain to it’s IP.</p>
<p><img width="1536" height="360" class="wp-image-6766 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 1536px) 100vw, 1536px" alt="word image 40" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 20" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-40.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-40.png?quality=100&amp;f=auto 1536w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-40-300x70.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-40-1024x240.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-40-768x180.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-40-380x89.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-40-800x188.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-40-1160x272.png?quality=100&amp;f=auto 1160w,"/></p>
<h4 id="recommended-cloudflare-settings-for-wordpress">Recommended Cloudflare Settings for WordPress</h4>
<p>We’ll also need to configure a few Cloudflare settings for optimal performance. Many users don’t configure some of these settings, unless they encounter some unexpected issues at some point, that requires them to do so.</p>
<p>As it states in a blog post on SlickStack:</p>
<div class="analogy">“These days, CloudFlare is almost universally well known among tech-savvy WordPress servers and web performance geeks. However, many users don’t realize how important it is to optimize all the settings. Many users will simply enable CloudFlare and then leave it, and then wonder why they are having some performance issues later on.” (<a href="https://slickstack.io/blog/best-cloudflare-settings" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">source<span class="wpel-icon wpel-image wpel-icon-7"></span></a>)</div>
<p>So, assuming you have your domain added to Cloudflare, let’s proceed to optimize some settings.</p>
<p>In the following screenshots I’m using the new Cloudflare navigation, which can be switched on/off from <strong>Preferences</strong> in your account: <a href="https://dash.cloudflare.com/profile" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">https://dash.cloudflare.com/profile<span class="wpel-icon wpel-image wpel-icon-7"></span></a></p>
<p>In the <strong>DNS</strong> tab, on the same page where you added records for your domain, scroll a bit downard and you’ll see two of the section we need to edit:</p>
<ol>
<li><strong>DNSSEC</strong></li>
<li><strong>CNAME Flattening</strong></li>
</ol>
<p><img class="alignnone size-large wp-image-6784 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="DNSSEC CNAME Flatten" width="839" height="1024" sizes="(max-width: 839px) 100vw, 839px" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 21" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten-839x1024.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten-839x1024.png?quality=100&amp;f=auto 839w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten-246x300.png?quality=100&amp;f=auto 246w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten-768x938.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten-1258x1536.png?quality=100&amp;f=auto 1258w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten-380x464.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten-800x977.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten-1160x1416.png?quality=100&amp;f=auto 1160w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/DNSSEC-CNAME-Flatten.png?quality=100&amp;f=auto 1384w,"/></p>
<h5 id="dnssec-enabled">DNSSEC = Enabled</h5>
<p>If you don’t have it already, then go ahead and click <strong>Enable DNSSEC</strong>. You’ll see a modal window like this:<span id="ezoic-pub-ad-placeholder-133" class="ezoic-adpicker-ad"></span><span class="ezoic-ad mobile-leaderboard-1 mobile-leaderboard-1133 adtester-container adtester-container-133 ezoic-ad-adaptive" data-ez-name="bytexd_com-mobile-leaderboard-1"><span class="ezoic-ad mobile-leaderboard-1 mobile-leaderboard-1-multi-133 adtester-container adtester-container-133" data-ez-name="bytexd_com-mobile-leaderboard-1"><span id="div-gpt-ad-bytexd_com-mobile-leaderboard-1-0" ezaw="290" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:290px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-mobile-leaderboard-1-0')};</script></span></span><span class="ezoic-ad mobile-leaderboard-1 mobile-leaderboard-1-multi-133 adtester-container adtester-container-133" data-ez-name="bytexd_com-mobile-leaderboard-1"><span id="div-gpt-ad-bytexd_com-mobile-leaderboard-1-0_1" ezaw="290" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:290px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-mobile-leaderboard-1-0_1')};</script></span></span><style> .mobile-leaderboard-1-multi-133{border:none !important;display:block !important;float:none;line-height:0px;margin-bottom:15px !important;margin-left:0px !important;margin-right:0px !important;margin-top:15px !important;max-width:100% !important;min-height:250px;min-width:250px;padding:0;text-align:center !important;}</style></span></p>
<p><img width="960" height="1532" class="wp-image-6768 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 960px) 100vw, 960px" alt="word image 42" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 22" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-42.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-42.png?quality=100&amp;f=auto 960w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-42-188x300.png?quality=100&amp;f=auto 188w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-42-642x1024.png?quality=100&amp;f=auto 642w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-42-768x1226.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-42-380x606.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-42-800x1277.png?quality=100&amp;f=auto 800w,"/></p>
<p>If you’ve never done this before, don’t worry. Cloudflare has compiled a very useful list of tutorials on how to enable DNSSEC for many common registrars – <a href="https://support.cloudflare.com/hc/en-us/articles/360006660072" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">Setting up DNSSEC in Cloudflare<span class="wpel-icon wpel-image wpel-icon-7"></span></a>.</p>
<h5 id="cname-flattening-enabled">CNAME Flattening = Enabled</h5>
<p>CNAME Flattening is most likely enabled by default, however you should enable it if it isn’t already.<span id="ezoic-pub-ad-placeholder-128" class="ezoic-adpicker-ad"></span></p>
<p><img class="alignnone size-full wp-image-7269 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="CNAME Flattening Screenshot in CloudFlare" width="1536" height="318" sizes="(max-width: 1536px) 100vw, 1536px" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 23" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/CNAME-Flattening.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/CNAME-Flattening.png?quality=100&amp;f=auto 1536w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/CNAME-Flattening-300x62.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/CNAME-Flattening-1024x212.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/CNAME-Flattening-768x159.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/CNAME-Flattening-380x79.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/CNAME-Flattening-800x166.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/CNAME-Flattening-1160x240.png?quality=100&amp;f=auto 1160w,"/></p>
<h5 id="ssl-tls-settings">SSL/TLS Settings</h5>
<p>Next we’ll have to set <strong>SSL/TLS encryption mode</strong> to <strong>Full</strong>.</p>
<p>You can find it in the <strong>SSL/TLS &gt; Overview</strong> section.</p>
<p>Don’t leave this setting on Flexible, or you’ll risk getting redirect loops, and you’ll find yourself with the dreaded “too many redirects error”. This would happen because Cloudflare’s <em>Flexible</em> setting tries to allow your website to load on both <strong>http</strong> and <strong>https</strong>, while SlickStack force redirects everything to <strong>https</strong>.</p>
<p>So please remember to check <strong>Full</strong>.</p><span id="ezoic-pub-ad-placeholder-112" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-mobile-banner-2 large-mobile-banner-2112 adtester-container adtester-container-112" data-ez-name="bytexd_com-large-mobile-banner-2"><span id="div-gpt-ad-bytexd_com-large-mobile-banner-2-0" ezaw="336" ezah="280" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-large-mobile-banner-2-0')};</script></span></span>
<p>You can find this setting in the <strong>SSL/TLS</strong> tab.</p>
<p><img width="2048" height="985" class="wp-image-6769 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 2048px) 100vw, 2048px" alt="word image 43" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 24" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43.png?quality=100&amp;f=auto 2048w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43-300x144.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43-1024x493.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43-768x369.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43-1536x739.png?quality=100&amp;f=auto 1536w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43-380x183.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43-800x385.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-43-1160x558.png?quality=100&amp;f=auto 1160w,"/></p>
<p>Next, in the <strong>SSL/TLS &gt; Edge Certificates</strong> section we’ll need to change some settings as follows:</p>
<ul>
<li><strong>Always Use HTTPS</strong> = Enabled</li>
<li><strong>HTTP Strict Transport Security (HSTS)</strong> = Disabled (This can be enabled in Nginx, which it will, by SlickStack)</li>
<li><strong>Minimum TLS Version</strong> = 1.1</li>
<li><strong>Opportunistic Encryption</strong> = Enabled</li>
<li><strong>TLS 1.3</strong> = Enabled</li>
<li><strong>Automatic HTTPS Rewrites</strong> = Enabled</li>
<li><strong>Certificate Transparency Monitoring</strong> = Enabled</li>
</ul>
<p><img width="1384" height="1634" class="wp-image-6770 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 1384px) 100vw, 1384px" alt="word image 44" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 25" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44.png?quality=100&amp;f=auto 1384w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44-254x300.png?quality=100&amp;f=auto 254w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44-867x1024.png?quality=100&amp;f=auto 867w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44-768x907.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44-1301x1536.png?quality=100&amp;f=auto 1301w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44-380x449.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44-800x945.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-44-1160x1370.png?quality=100&amp;f=auto 1160w,"/></p>
<p><img width="1384" height="1476" class="wp-image-6771 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 1384px) 100vw, 1384px" alt="word image 45" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 26" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-45.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-45.png?quality=100&amp;f=auto 1384w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-45-281x300.png?quality=100&amp;f=auto 281w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-45-960x1024.png?quality=100&amp;f=auto 960w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-45-768x819.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-45-380x405.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-45-800x853.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-45-1160x1237.png?quality=100&amp;f=auto 1160w,"/></p>
<p>Next, let’s switch to the <strong>SSL/TLS &gt; Origin Server</strong>. Here just make sure we have:</p>
<p><span id="ezoic-pub-ad-placeholder-134" class="ezoic-adpicker-ad"></span><span class="ezoic-ad portrait-1 portrait-1134 adtester-container adtester-container-134" data-ez-name="bytexd_com-portrait-1"><span id="div-gpt-ad-bytexd_com-portrait-1-0" ezaw="250" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-portrait-1-0')};</script></span></span><strong>Authenticated Origin Pulls</strong> = Disabled</p>
<p><img width="1385" height="751" class="wp-image-6772 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 1385px) 100vw, 1385px" alt="word image 46" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 27" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-46.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-46.png?quality=100&amp;f=auto 1385w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-46-300x163.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-46-1024x555.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-46-768x416.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-46-380x206.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-46-800x434.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-46-1160x629.png?quality=100&amp;f=auto 1160w,"/></p>
<h5 id="network-settings">Network Settings</h5>
<p>Finally, in the <strong>Network</strong> tab, scroll a little until you find <strong>Onion Routing</strong>. We want:</p>
<p><strong>Onion Routing</strong> = Enabled</p>
<p><img width="2007" height="1442" class="wp-image-6773 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 2007px) 100vw, 2007px" alt="word image 47" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 28" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47.png?quality=100&amp;f=auto 2007w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47-300x216.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47-1024x736.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47-768x552.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47-1536x1104.png?quality=100&amp;f=auto 1536w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47-380x273.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47-800x575.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/word-image-47-1160x833.png?quality=100&amp;f=auto 1160w,"/></p>
<p>That’s it. Now that we have Cloudflare properly configured, we can proceed to installing WordPress.</p>
<h2 id="using-slickstack-to-install-wordpress">Using SlickStack to Install WordPress</h2>
<p>You can install WordPress with SlickStack using two methods.</p>
<h3 id="method-1-quick-install-setup-wizard">Method 1. Quick Install (Setup Wizard)</h3>
<p>Using this method we’ll run a command that downloads and runs the SlickStack install script that guides you interactively to configure your installation in the terminal, which is more beginner friendly and easier for some. After which, your configurations will be written in the SlickStack configuration file, called <strong>ss-config</strong>, which will be used to proceed with the installation.</p>
<p>To install SlickStack this way, just run:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">cd /tmp/ &amp;&amp; wget -O ss slick.fyi &amp;&amp; bash ss</pre>
<p>The command will change our current directory to <code data-enlighter-language="raw" class="EnlighterJSRAW">/tmp/</code>, which is used to store temporary data, then it will download the SlickStack installation script from <strong>slick.fyi</strong>, and save it into a file called <code data-enlighter-language="raw" class="EnlighterJSRAW">ss</code>, and it will run the script by using the bash command.</p>
<p><span id="ezoic-pub-ad-placeholder-156" class="ezoic-adpicker-ad"></span><span class="ezoic-ad narrow-sky-1 narrow-sky-1156 adtester-container adtester-container-156" data-ez-name="bytexd_com-narrow-sky-1"><span id="div-gpt-ad-bytexd_com-narrow-sky-1-0" ezaw="250" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-narrow-sky-1-0')};</script></span></span>Upon running it we’ll see a greeting message with a few details about the current SlickStack build, and a few of our server details.</p>
<p>The interactive wizard also pre-fills the options, so it’s easier for you to tell what to fill in. If this is the first time you’re running SlickStack, then I recommend waiting for the timer to reach 0 and configuring SlickStack using the interactive wizard.</p>
<p>We already demonstrated how the install using this method looks like at the <a href="https://bytexd.com/slickstack/#demo-installing-wordpress-with-slickstack" data-wpel-link="internal">beginning of this tutorial</a>.</p>
<p>In this section we’ll explore the options that we’re configuring during the setup wizard:</p>
<h4 id="slickstack-interactive-setup-wizard-ss-config">SlickStack Interactive Setup Wizard (SS-Config)</h4>
<p>This will be your new <strong>sudo user</strong> and <strong>password</strong>. You’ll need to take a note of this after finishing the install and make sure you don’t lose them. Slickstack <em><span style="text-decoration: underline;">disables root</span></em>, so you’ll need this use this to SSH into your server.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose sudo username (for SSH): edxd
Choose sudo password (should be strong): 8738ccac6c1a6d2a8c6eeb7d</pre>
<p>This option is for changing your SSH port.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose SSH port (use 22 for best compatibility): 2268</pre>
<p>Enabling <a href="https://bytexd.com/ssh-authentication-methods/#2-public-key-authentication" data-wpel-link="internal">SSH keys</a> means that you’ll use these keys to SSH into your server, instead of your password. If you’re not familiar with the concept, then we encourage you to check <a href="https://wiki.archlinux.org/title/SSH_keys" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">this article<span class="wpel-icon wpel-image wpel-icon-7"></span></a>. The intro offers a good overview of SSH keys.<span id="ezoic-pub-ad-placeholder-137" class="ezoic-adpicker-ad"></span><span class="ezoic-ad portrait-2 portrait-2137 adtester-container adtester-container-137" data-ez-name="bytexd_com-portrait-2"><span id="div-gpt-ad-bytexd_com-portrait-2-0" ezaw="336" ezah="280" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-portrait-2-0')};</script></span></span></p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Enable SSH keys (advanced users only): false</pre>
<p>This creates a SFTP user. If you changed the SSH port, remember to use the same port when connecting via SFTP.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose SFTP username (limited access): mruser
Choose SFTP password (should be strong): 3af1b7066fb43159ed0245e0</pre>
<p><span id="ezoic-pub-ad-placeholder-138" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-2 leader-2138 adtester-container adtester-container-138" data-ez-name="bytexd_com-leader-2"><span id="div-gpt-ad-bytexd_com-leader-2-0" ezaw="250" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-2-0')};</script></span></span>SlickStack aims to support more apps in the future, such as Magento, MediaWiki, Moodle, and probably others. For our purposes we’ll leave <code>wordpress</code>:</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose app (only wordpress supported currently): wordpress</pre>
<p>SlickStack blacklists certain plugins for a number of reasons. You can read the <a href="https://slickstack.io/faq/blacklisted-plugins" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">motivation for blacklisted plugins here<span class="wpel-icon wpel-image wpel-icon-7"></span></a> and the <a href="https://github.com/littlebizzy/slickstack/blob/master/modules/wordpress/blacklist.txt" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">list of blacklisted plugins here<span class="wpel-icon wpel-image wpel-icon-7"></span></a>.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Enable the WordPress plugin blacklist: true</pre>
<p><span id="ezoic-pub-ad-placeholder-158" class="ezoic-adpicker-ad"></span><span class="ezoic-ad netboard-2 netboard-2158 adtester-container adtester-container-158" data-ez-name="bytexd_com-netboard-2"><span id="div-gpt-ad-bytexd_com-netboard-2-0" ezaw="468" ezah="60" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-netboard-2-0')};</script></span></span>More on <a href="https://slickstack.io/faq/what-is-a-pilot-file" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">SlickStack pilot files here<span class="wpel-icon wpel-image wpel-icon-7"></span></a>.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Link to your pilot file (leave blank if none): https://gist.githubusercontent.com/...</pre>
<p>Here you’re asked if you’re using an external database, such as on another server. It’s <code data-enlighter-language="raw" class="EnlighterJSRAW">false</code> by default. Typical WordPress install have their database hosted locally.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Are you using a remote database: false</pre>
<p>Then you’ll configure your database details:</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose database name (single database): mrsdatabase
Choose database user (non-root user): mrs_user
Choose database user password (should be strong): 55e0166f662263d52eaabd37
Choose database host (IP address): 127.0.0.1
Choose database table prefix: wp_</pre>
<p>Next, we’ll set our TLD (top level domain). The top level domain the domain extension. The most common ones are <code>com</code>, <code>net</code>, <code>co</code>. In my case it’s <code data-enlighter-language="raw" class="EnlighterJSRAW">website</code> since my domain is <code>mrtest.website</code>.<span id="ezoic-pub-ad-placeholder-159" class="ezoic-adpicker-ad"></span></p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose site TLD (subdomains not allowed): website</pre>
<p>This will be our site’s domain. In my case it’s <code>mrtest.website</code>.</p>
<p><span id="ezoic-pub-ad-placeholder-139" class="ezoic-adpicker-ad"></span><span class="ezoic-ad mobile-leaderboard-2 mobile-leaderboard-2139 adtester-container adtester-container-139" data-ez-name="bytexd_com-mobile-leaderboard-2"><span id="div-gpt-ad-bytexd_com-mobile-leaderboard-2-0" ezaw="336" ezah="280" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-mobile-leaderboard-2-0')};</script></span></span>If you’re installing WordPress on a subdomain you could have <code>yoursubdomain.yoursite.com</code>, for example.</p>
<p>Where it says <strong>subdirectories not allowed</strong>, it means that it won’t install on subdirectories like <code>mrtest.website/blog</code>.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose site domain (subdirectories not allowed): mrtest.website</pre>
<p>This option is for when you want to block search engines from indexing your site.</p>
<p>It refers to a file called <code>robots.txt</code> that all websites usually have. Search engines will check that file and see if they’re allowed to crawl the site or not. By default it’s set to <code>false</code>.</p>
<p>If you want to block search engines from finding your site then set <code>true</code>.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Enable site noindexing (block robots): false</pre>
<p>By default SlickStack uses OpenSSL (we mentioned this when discussing Cloudflare earlier). SlickStack also offers <a href="https://slickstack.io/faq/letsencrypt-support" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">support for Let’s Encrypt (Certbot)<span class="wpel-icon wpel-image wpel-icon-7"></span></a>.</p>
<p>You can set <code>certbot</code> instead of <code>openssl</code>, after which you can disable Cloudflare if you want, and your Let’s Encrypt certificate will be 100% CA-signed, and you’ll get an A+ score on SSL Labs.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose SSL cert [openssl|certbot]: openssl</pre>
<p>By default SlickStack has WordPres Multisite set to false. You can change this to true if you plan on using the Multisite feature.<span id="ezoic-pub-ad-placeholder-140" class="ezoic-adpicker-ad"></span></p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Enable WordPress Multisite (experimental): false</pre>
<p>SlickStack will need your Cloudflare API key and email so it can connect to Cloudflare. You can find these in your Cloudflare dashboard in <strong>My Profile &gt; API Tokens &gt; Global API Key</strong>. Click <strong>View</strong> and you’ll have to fill in your password for the API key to be displayed. You can also go directly here (<code>https://dash.cloudflare.com/profile/api-tokens</code>), which will take you to that section.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Choose Cloudflare API key (account profile): 5gq1zkpanyyztcgarzvnhsfp6p626dgohos2h3
Choose Cloudflare API email (account profile): <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e78f828b8b88a7859e93829f83c984888a">[email&#160;protected]</a></pre>
<p>Finally you can decide if you want to set up <strong>dev</strong> and <strong>staging</strong> sites. By default these are set to <code>false</code>. If you want to enable them set to <code>true</code>.</p>
<div class="analogy">If you enable this, however, make sure to create records for the <strong>dev</strong> and <strong>staging</strong> subdomains in Cloudflare. For example, if I enable them I’d have my <strong>dev</strong> site at https://dev.mrtest.website and <strong>staging</strong> at https://staging.mrtest.website.</div>
<p>You can also protect your <strong>dev </strong>and <strong>staging</strong> stites with a popup login. If you enable this, then you can use the <strong>guest username</strong> and <strong>guest password</strong> to access them.</p>
<pre class="EnlighterJSRAW" data-enlighter-language="generic">Enable staging site (subdomain): false
Password protect staging site: false
Enable dev site (subdomain): false
Password protect dev site: false
Choose guest username (to view staging/dev): guest
Choose guest password (easy is fine): 454a2f030998cdf757317f9e</pre>
<h3 id="method-2-setting-up-slickstack-configuration-manually">Method 2. Setting Up SlickStack Configuration Manually</h3>
<p>Instead of having the SlickStack script ask you each option and how you want to set it, you can just edit the <strong>ss-config</strong> file yourself, and then run the install script as we did above.</p>
<p>To do this we’ll just set up the <strong>/var/www/ss-config</strong> file before downloading and running the SlickStack install script.</p>
<p>We’ll first download a template for the <strong>ss-config</strong> file:<span id="ezoic-pub-ad-placeholder-141" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-mobile-banner-1 large-mobile-banner-1141 adtester-container adtester-container-141" data-ez-name="bytexd_com-large-mobile-banner-1"><span id="div-gpt-ad-bytexd_com-large-mobile-banner-1-0" ezaw="336" ezah="280" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-large-mobile-banner-1-0')};</script></span></span></p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">wget -O /tmp/ss-config http://mirrors.slickstack.io/bash/ss-config-sample.txt</pre>
<p>Next we’ll create the directory where SlickStack is going to look for the config file (<strong>/var/www/ss-config</strong>), move our <strong>ss-config</strong> file there, and open the file so we can set up the configurations we want:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">mkdir -p /var/www/ &amp;&amp; cp /tmp/ss-config /var/www/ss-config &amp;&amp; nano /var/www/ss-config</pre>
<p>After you set up all the options that you want, save and exit the file, and run:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">cd /tmp/ &amp;&amp; wget -O ss slick.fyi &amp;&amp; bash ss</pre>
<p>If you’d like to see how the <strong>ss-config</strong> file looks like, then you can find it in the GitHub SlickStack Repository <a href="https://github.com/littlebizzy/slickstack/blob/master/bash/ss-config-sample.txt" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">https://github.com/littlebizzy/slickstack/blob/master/bash/ss-config-sample.txt<span class="wpel-icon wpel-image wpel-icon-7"></span></a></p>
<p>Both options are intuitive, since the interactive setup wizard asks you for your preferred options, one by one, and the <strong>ss-config</strong> file has detailed explanations for each option.</p>
<p>After the installation is done, you’ll be presented with the configurations we set up when we first ran the script.</p>
<p>You can now store them somewhere safe. At the very least, you should take note of your <strong>sudo</strong> user and password, or SSH keys (if you enabled them).<span id="ezoic-pub-ad-placeholder-142" class="ezoic-adpicker-ad"></span><span class="ezoic-ad netboard-1 netboard-1142 adtester-container adtester-container-142" data-ez-name="bytexd_com-netboard-1"><span id="div-gpt-ad-bytexd_com-netboard-1-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-netboard-1-0')};</script></span></span></p>
<div class="analogy">You can find all configuration details in the <code data-enlighter-language="raw" class="EnlighterJSRAW">/var/www/ss-config</code> file. So even if you forget them, all you need to know are your sudo user and password.</div>
<p>Finally, after SlickStack has finished setting up WordPress, you can visit your site and you’ll be guided by WordPress to finalize the installation.</p>
<p>We trust that the WordPress setup is intuitive so we won’t cover the final steps. If you encounter any issues then feel free to leave a comment and we’ll get back to you as soon as we can.</p>
<p><img class="alignnone size-large wp-image-6802 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="install wp" width="1024" height="788" sizes="(max-width: 1024px) 100vw, 1024px" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 17" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-1024x788.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-1024x788.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-300x231.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-768x591.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-380x292.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-800x616.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp-1160x893.png?quality=100&amp;f=auto 1160w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/install_wp.png?quality=100&amp;f=auto 1398w,"/></p>
<h2 id="post-installation"><span id="ezoic-pub-ad-placeholder-105" class="ezoic-adpicker-ad"></span>Post Installation</h2>
<p>After WordPress is installed, you can log into the WP dashboard. You’ll notice a few new menu items, compared to the usual fresh WordPress install:</p>
<ol>
<li><strong>SlickStack</strong> menu item in the left sidebar, which leads to some SlickStack settings.</li>
<li>A green <strong>PRODUCTION</strong> menu item in the top bar. If you hover over it, you’ll have links to the <strong>dev</strong> and <strong>staging</strong> sites, if you have them enabled.</li>
<li><strong>Cloudflare</strong> – this is a lightweight plugin created by LittleBizzy (the developers of SlickStack), which offers a few functionalities, including clearing Cloudflare cache, and is lighter than the official Cloudflare plugin. More info on this plugin here <a href="https://github.com/littlebizzy/cloudflare" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">https://github.com/littlebizzy/cloudflare<span class="wpel-icon wpel-image wpel-icon-7"></span></a></li>
<li><strong>Clear Caches</strong> – if you hover over it you’ll see options to <strong>Clear PHP OPcache, Clear Nginx Cache, Clear Object Cache</strong></li>
</ol>
<p><img class="alignnone size-large wp-image-6833 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="SlickStack First View" width="1024" height="588" sizes="(max-width: 1024px) 100vw, 1024px" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 30" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/SlickStack-First-View-1024x588.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/SlickStack-First-View-1024x588.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/SlickStack-First-View-300x172.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/SlickStack-First-View-768x441.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/SlickStack-First-View-380x218.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/SlickStack-First-View-800x459.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/SlickStack-First-View-1160x666.png?quality=100&amp;f=auto 1160w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/SlickStack-First-View.png?quality=100&amp;f=auto 1464w,"/></p>
<p>If you click the <strong>SlickStack</strong> item in the left sidebar  you’ll be taken to the <strong>SlickStack Settings</strong> dashboard, where you can see some server details about your server.<span id="ezoic-pub-ad-placeholder-143" class="ezoic-adpicker-ad"></span><span class="ezoic-ad sky-2 sky-2143 adtester-container adtester-container-143" data-ez-name="bytexd_com-sky-2"><span id="div-gpt-ad-bytexd_com-sky-2-0" ezaw="250" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-sky-2-0')};</script></span></span></p>
<p>Some of these tabs are not yet functional and the features are under development at the time of writing – such as you can see if you click on <strong>Backups</strong>, which presents you with a coming soon message <code data-enlighter-language="raw" class="EnlighterJSRAW">Coming soon... powered by Rclone! Choose from Backblaze, Dropbox, Amazon S3, Google Drive, and more...</code>.</p>
<p>A useful feature here is <strong>Adminer</strong>, which is a GUI for managing your databases.</p>
<p><img class="alignnone size-large wp-image-6834 block-shadow" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="Adminer" width="1024" height="789" sizes="(max-width: 1024px) 100vw, 1024px" title="Using SlickStack to Install WordPress Automatically on Ubuntu 20.04 31" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer-1024x789.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer-1024x789.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer-300x231.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer-768x592.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer-1536x1184.png?quality=100&amp;f=auto 1536w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer-380x293.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer-800x617.png?quality=100&amp;f=auto 800w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer-1160x894.png?quality=100&amp;f=auto 1160w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/11/Adminer.png?quality=100&amp;f=auto 1767w,"/></p>
<h2 id="additional-notes">Additional Notes</h2>
<p>These are some additional details I’d like to outline.</p>
<h3 id="slickstack-disables-the-root-user">SlickStack disables the root user</h3>
<p>I missed this when first installing, but SlickStack says this after finishing the install:</p>
<div class="analogy">SlickStack install complete! Please note the sudo user and password above to avoid being locked out of your new server (<em><span style="text-decoration: underline;"><strong>the root user is disabled</strong></span></em>).</div>
<h3 id="redirect-loop-err_too_many_redirects">Redirect Loop (ERR_TOO_MANY_REDIRECTS)</h3>
<p>This usually happens because Cloudflare SSL\TLS encryption mode isn’t set to <strong>Full</strong> and is left to <strong>Flexible.</strong><span id="ezoic-pub-ad-placeholder-144" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-4 leader-4144 adtester-container adtester-container-144" data-ez-name="bytexd_com-leader-4"><span id="div-gpt-ad-bytexd_com-leader-4-0" ezaw="580" ezah="400" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-4-0')};</script></span></span></p>
<p>You can check how to change this setting in the <a href="https://bytexd.com/slickstack/#ssl-tls-settings" data-wpel-link="internal">SSL\TLS Settings</a> section of this article.</p>
<h3 id="changing-the-config-file-and-applying-changes">Changing the config file and applying changes</h3>
<p>Sometime you may want to change some of the initial settings. For example, you may want to switch from OpenSSL to Let’s Encrypt (certbot).</p>
<p>To do this just edit your <code>/var/www/ssh-config</code> file, save and exit the file, and run the install script:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">sudo ./var/www/ss-install</pre>
<h2 id="conclusion">Conclusion</h2>
<p>Well done. Hopefully you successfully installed WordPress using SlickStack. There are many more options and configurations that we haven’t covered in this article. So if you’d like to find out more, be sure to check the official site at <a href="https://slickstack.io/" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">slickstack.io<span class="wpel-icon wpel-image wpel-icon-7"></span></a>, especially in their <a href="https://slickstack.io/modules" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">Modules<span class="wpel-icon wpel-image wpel-icon-7"></span></a> and <a href="https://slickstack.io/faq" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">Docs<span class="wpel-icon wpel-image wpel-icon-7"></span></a> sections.</p>
<p>If you encountered any issues, or have any questions at all, feel free to leave a comment below and we’ll get back to you as soon as we can.</p>
<ul class="modern-footnotes-list modern-footnotes-list--hide-for-print"><li><span>1</span><div>Very nice video explanation on YouTube: <a href="https://www.youtube.com/watch?v=JKxlsvZXG7c" target="_blank" rel="noopener external" data-wpel-link="external" class="wpel-icon-right">NGINX Explained in 100 Seconds (YouTube)<span class="wpel-icon wpel-image wpel-icon-7"></span></a> by Fireship.io</div></li><li><span>2</span><div>Great explanation on what DNS is: <a href="https://www.youtube.com/watch?v=UVR9lhUGAyU" target="_blank" rel="noopener external" data-wpel-link="external" class="wpel-icon-right">DNS Explained in 100 Seconds (YouTube)<span class="wpel-icon wpel-image wpel-icon-7"></span></a> by Fireship.io</div></li></ul>
		</div>
				<div class="pk-share-buttons-wrap pk-share-buttons-layout-default pk-share-buttons-scheme-bold-bg pk-share-buttons-has-counts pk-share-buttons-has-total-counts pk-share-buttons-after-post pk-share-buttons-mode-php pk-share-buttons-mode-rest" data-post-id="6715" data-share-url="https://bytexd.com/slickstack/">

							<div class="pk-share-buttons-total">
							<div class="pk-share-buttons-count cs-font-primary">3 Shares:</div>
						</div>
				
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">3</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=Using%20SlickStack%20to%20Install%20WordPress%20Automatically%20on%20Ubuntu%2020.04&amp;via=ByteXD&amp;url=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Tweet</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/slickstack/&amp;media=https://bytexd.com/wp-content/uploads/2021/11/Using-SlickStack-to-Install-WordPress-Automatically-on-Ubuntu-20.04-1024x576.png" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Pin it</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-whatsapp pk-share-buttons-no-count" data-id="whatsapp">

							<a href="whatsapp://send?text=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="internal">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-whatsapp"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-fb-messenger pk-share-buttons-no-count" data-id="fb-messenger">

							<a href="fb-messenger://share/?link=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="internal">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-fb-messenger"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-reddit pk-share-buttons-no-count" data-id="reddit">

							<a href="https://www.reddit.com/submit?url=https://bytexd.com/slickstack/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-reddit"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
	

<section class="post-author">

	<div class="authors-compact">

			<div class="author-wrap">
			<div class="author">
				<div class="author-avatar">
					<a href="https://bytexd.com/author/edxd/" rel="author" data-wpel-link="internal">
						<img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="avatar avatar-120 photo" height="120" width="120" data-loading="lazy" data-src="https://secure.gravatar.com/avatar/908729a6f7effb4a6f8c5b48c6855cd2?s=120&amp;d=mm&amp;r=g&amp;quality=100" data-srcset=""/>					</a>
				</div>
				<div class="author-description">
					<h5 class="title-author">
						<span class="fn">
							<a href="https://bytexd.com/author/edxd/" rel="author" data-wpel-link="internal">
								EdXD							</a>
						</span>
					</h5>
					<p class="note"></p>
							<div class="pk-author-social-links pk-social-links-wrap pk-social-links-template-default">
			<div class="pk-social-links-items">
										<div class="pk-social-links-item pk-social-links-twitter">
							<a href="https://twitter.com/shwayguy" class="pk-social-links-link" target="_blank" rel="nofollow" data-wpel-link="exclude">
								<i class="pk-icon pk-icon-twitter"></i>
															</a>
						</div>
								</div>
		</div>
						</div>
			</div>
		</div>
	
	</div>

</section>

    <div class="wpdiscuz_top_clearing"></div>
    <div id="comments" class="comments-area"><div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div><span id="ezoic-pub-ad-placeholder-148" class="ezoic-adpicker-ad"></span><span class="ezoic-ad nativedouble-1 nativedouble-1148 adtester-container adtester-container-148" data-ez-name="bytexd_com-nativedouble-1"><div class="OUTBRAIN" data-ob-contenturl="https://bytexd.com/slickstack/" data-ob-installation-key="EZOICL9MFJN21JB32NFBE7ODP" data-external-id="283186_1_148_100x480" data-widget-id="AR_1"></div>
<div data-expand="100" class="ezlazyload" data-script="//widgets.outbrain.com/outbrain.js"></div></span>    <div id="wpdcom" class="wpdiscuz_unauth wpd-default wpd-layout-1 wpd-comments-open">
                    <div class="wc_social_plugin_wrapper">
                            </div>
            <div class="wpd-form-wrap">
                <div class="wpd-form-head">
                                            <div class="wpd-sbs-toggle">
                            <i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i>
                        </div>
                                            <div class="wpd-auth">
                                                <div class="wpd-login">
                            <a rel="nofollow" href="https://bytexd.com/wp-login.php?redirect_to=https%3A%2F%2Fbytexd.com%2Fslickstack%2F" data-wpel-link="internal"><i class="fas fa-sign-in-alt"></i> Login</a>                        </div>
                    </div>
                </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://bytexd.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Notify of </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType">
                                                                                    <option value="post">new follow-up comments</option>
                                                                                                                                <option value="all_comment">new replies to my comments</option>
                                                                                </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                    <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" class="wpd-prim-button" type="submit" value="›" name="wpdiscuz_subscription_button"/>
                                </div> 
                                                                    <div class="wpdiscuz-subscribe-agreement">
                                        <input id="show_subscription_agreement" type="checkbox" required="required" name="show_subscription_agreement" value="1"/>
                                        <label for="show_subscription_agreement">I allow to use my email address and send notification about new comments and replies (you can unsubscribe at any time).</label>
                                    </div>
                                    <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="1f991dd549"/><input type="hidden" name="_wp_http_referer" value="/slickstack/"/>                            </form>
                                                </div>
                            <div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id="wpd-main-form-wrapper-0_0">
                                        <form class="wpd_comm_form wpd_main_comm_form" method="post" enctype="multipart/form-data">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap">
                                                                                                        <div class="wpd-avatar">
                                        <img alt="guest" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="avatar avatar-56 photo avatar-default" height="56" width="56" data-loading="lazy" data-src="https://secure.gravatar.com/avatar/?s=56&amp;d=mm&amp;r=g&amp;quality=100" data-srcset=""/>                                    </div>
                                                <div id="wpd-editor-wraper-0_0" style="display: none;">
                <div id="wpd-editor-char-counter-0_0" class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-0_0">Label</label>
                <textarea id="wc-textarea-0_0" required="" name="wc_comment" class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-0_0"></div>
                        <div id="wpd-editor-toolbar-0_0">
                            <button title="Bold" class="ql-bold"></button>
                                <button title="Italic" class="ql-italic"></button>
                                <button title="Underline" class="ql-underline"></button>
                                <button title="Strike" class="ql-strike"></button>
                                <button title="Ordered List" class="ql-list" value="ordered"></button>
                                <button title="Unordered List" class="ql-list" value="bullet"></button>
                                <button title="Blockquote" class="ql-blockquote"></button>
                                <button title="Code Block" class="ql-code-block"></button>
                                <button title="Link" class="ql-link"></button>
                                <button title="Source Code" class="ql-sourcecode" data-wpde_button_name="sourcecode">{}</button>
                                <button title="Spoiler" class="ql-spoiler" data-wpde_button_name="spoiler">[+]</button>
                            <div class="wpd-editor-buttons-right">
                <span class="wmu-upload-wrap" wpd-tooltip="Attach an image to this comment" wpd-tooltip-position="left"><label class="wmu-add"><i class="far fa-image"></i><input style="display:none;" class="wmu-add-files" type="file" name="wmu_files[]" accept="image/*"/></label></span>            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot">
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"><div class="wmu-action-wrap"><div class="wmu-tabs wmu-images-tab wmu-hide"></div></div></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                    <input id="wc_name-0_0" value="" required="required" aria-required="true" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title=""/>
                <label for="wc_name-0_0" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                    <input id="wc_email-0_0" value="" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email"/>
                <label for="wc_email-0_0" class="wpdlb">Email</label>
                                    <div class="wpd-field-desc"><i class="far fa-question-circle"></i><span>Receive notifications when your comment receives a reply. (Optional)</span></div>
                                    </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input id="wc_website-0_0" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website"/>
                    <label for="wc_website-0_0" class="wpdlb">Website</label>
                                            <div class="wpd-field-desc"><i class="far fa-question-circle"></i><span>Your username will link to your website. (Optional)</span></div>
                                            </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-0_0" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment"/>
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id"/>
                </form>
                        </div>
                <div id="wpdiscuz_hidden_secondary_form" style="display: none;">
                    <div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id="wpd-secondary-form-wrapper-wpdiscuzuniqueid" style="display: none;">
                            <div class="wpd-secondary-forms-social-content"></div><div class="clearfix"></div>
                                        <form class="wpd_comm_form wpd-secondary-form-wrapper" method="post" enctype="multipart/form-data">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap">
                                                                                                        <div class="wpd-avatar">
                                        <img alt="guest" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="avatar avatar-56 photo avatar-default" height="56" width="56" data-loading="lazy" data-src="https://secure.gravatar.com/avatar/?s=56&amp;d=mm&amp;r=g&amp;quality=100" data-srcset=""/>                                    </div>
                                                <div id="wpd-editor-wraper-wpdiscuzuniqueid" style="display: none;">
                <div id="wpd-editor-char-counter-wpdiscuzuniqueid" class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-wpdiscuzuniqueid">Label</label>
                <textarea id="wc-textarea-wpdiscuzuniqueid" required="" name="wc_comment" class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-wpdiscuzuniqueid"></div>
                        <div id="wpd-editor-toolbar-wpdiscuzuniqueid">
                            <button title="Bold" class="ql-bold"></button>
                                <button title="Italic" class="ql-italic"></button>
                                <button title="Underline" class="ql-underline"></button>
                                <button title="Strike" class="ql-strike"></button>
                                <button title="Ordered List" class="ql-list" value="ordered"></button>
                                <button title="Unordered List" class="ql-list" value="bullet"></button>
                                <button title="Blockquote" class="ql-blockquote"></button>
                                <button title="Code Block" class="ql-code-block"></button>
                                <button title="Link" class="ql-link"></button>
                                <button title="Source Code" class="ql-sourcecode" data-wpde_button_name="sourcecode">{}</button>
                                <button title="Spoiler" class="ql-spoiler" data-wpde_button_name="spoiler">[+]</button>
                            <div class="wpd-editor-buttons-right">
                <span class="wmu-upload-wrap" wpd-tooltip="Attach an image to this comment" wpd-tooltip-position="left"><label class="wmu-add"><i class="far fa-image"></i><input style="display:none;" class="wmu-add-files" type="file" name="wmu_files[]" accept="image/*"/></label></span>            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot">
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"><div class="wmu-action-wrap"><div class="wmu-tabs wmu-images-tab wmu-hide"></div></div></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                    <input id="wc_name-wpdiscuzuniqueid" value="" required="required" aria-required="true" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title=""/>
                <label for="wc_name-wpdiscuzuniqueid" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                    <input id="wc_email-wpdiscuzuniqueid" value="" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email"/>
                <label for="wc_email-wpdiscuzuniqueid" class="wpdlb">Email</label>
                                    <div class="wpd-field-desc"><i class="far fa-question-circle"></i><span>Receive notifications when your comment receives a reply. (Optional)</span></div>
                                    </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input id="wc_website-wpdiscuzuniqueid" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website"/>
                    <label for="wc_website-wpdiscuzuniqueid" class="wpdlb">Website</label>
                                            <div class="wpd-field-desc"><i class="far fa-question-circle"></i><span>Your username will link to your website. (Optional)</span></div>
                                            </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-wpdiscuzuniqueid" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment"/>
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id"/>
                </form>
                        </div>
                </div>
                    </div>
                        <div id="wpd-threads" class="wpd-thread-wrapper">
                <div class="wpd-thread-head">
                    <div class="wpd-thread-info" data-comments-count="0">
                        <span class="wpdtc" title="0">0</span> Comments                    </div>
                                        <div class="wpd-space"></div>
                    <div class="wpd-thread-filter">
                                                    <div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div>
                                                        <div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div>
                                                </div>
                </div>
                <div class="wpd-comment-info-bar">
                    <div class="wpd-current-view"><i class="fas fa-quote-left"></i> Inline Feedbacks</div>
                    <div class="wpd-filter-view-all">View all comments</div>
                </div>
                                <div class="wpd-thread-list">
                    <!-- // From wpDiscuz's Caches // -->                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
            </div>
                </div>
        </div>
    <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div>
    <div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div>
    	</div>

				</div>
			
	
</article><span id="ezoic-pub-ad-placeholder-106" class="ezoic-adpicker-ad"></span>

					<div class="post-prev-next">
						<a class="link-item prev-link" href="https://bytexd.com/how-to-use-make-and-makefile-in-linux/" data-wpel-link="internal">
					<div class="link-content">
						<div class="link-label">
							<span class="link-arrow"></span><span class="link-text"> — Previous article</span>
						</div>

						<h2 class="entry-title">
							How to Use make and makefile in Linux						</h2>
					</div>
				</a>
							<a class="link-item next-link" href="https://bytexd.com/osi-model/" data-wpel-link="internal">
					<div class="link-content">
						<div class="link-label">
							<span class="link-text">Next article — </span><span class="link-arrow"></span>
						</div>

						<h2 class="entry-title">
							What is the OSI Model - 7 Layers of OSI Model Explained						</h2>
					</div>
				</a>
				</div>
		<section class="post-archive archive-related">

			<div class="archive-wrap">

				
				<div class="title-block-wrap">
					<h5 class="title-block">
						You May Also Like					</h5>
				</div>

				<div class="archive-main archive-list  archive-heading-medium archive-borders-disabled archive-shadow-enabled archive-scale-disabled">

					
<article class="entry-preview post-2966 post type-post status-publish format-standard has-post-thumbnail category-ubuntu category-debian tag-debian-10 tag-remote-desktop tag-ubuntu-20-04">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="214" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="Install on Chrome Remote Desktop on a Headless Ubuntu 20.04 Machine (1)" loading="lazy" sizes="(max-width: 380px) 100vw, 380px" title="Install Chrome Remote Desktop on a Headless Ubuntu 20.04 Server 32" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/Install-on-Chrome-Remote-Desktop-on-a-Headless-Ubuntu-20.04-Machine-1.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/Install-on-Chrome-Remote-Desktop-on-a-Headless-Ubuntu-20.04-Machine-1.jpg?quality=100&amp;f=auto 1920w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/Install-on-Chrome-Remote-Desktop-on-a-Headless-Ubuntu-20.04-Machine-1-300x169.jpg?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/Install-on-Chrome-Remote-Desktop-on-a-Headless-Ubuntu-20.04-Machine-1-1024x576.jpg?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/Install-on-Chrome-Remote-Desktop-on-a-Headless-Ubuntu-20.04-Machine-1-768x432.jpg?quality=100&amp;f=auto 768w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>6 minute read</li></ul>											</div>
					<a href="https://bytexd.com/install-chrome-remote-desktop-headless/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal"><span style="background:#e95420" class="char cs-bg-dark">U</span><span class="label">Ubuntu</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/install-chrome-remote-desktop-headless/" rel="bookmark" data-wpel-link="internal">Install Chrome Remote Desktop on a Headless Ubuntu 20.04 Server</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">March 18, 2021</li><li class="meta-shares">			<span class="total">
				<i class="cs-icon cs-icon-share"></i>
				<span class="total-number">
					1 share				</span>
			</span>
			<div class="meta-share-links">
						<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-post_meta pk-share-buttons-mode-cached" data-post-id="2966" data-share-url="https://bytexd.com/install-chrome-remote-desktop-headless/">

			
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/install-chrome-remote-desktop-headless/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">1</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=Install%20Chrome%20Remote%20Desktop%20on%20a%20Headless%20Ubuntu%2020.04%20Server&amp;via=ByteXD&amp;url=https://bytexd.com/install-chrome-remote-desktop-headless/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/install-chrome-remote-desktop-headless/&amp;media=https://bytexd.com/wp-content/uploads/2021/03/Install-on-Chrome-Remote-Desktop-on-a-Headless-Ubuntu-20.04-Machine-1-1024x576.jpg" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
				</div>
		</li><li class="meta-comments"><i class="cs-icon cs-icon-message-square"></i><a href="https://bytexd.com/install-chrome-remote-desktop-headless/#comments" class="comments-link" data-wpel-link="internal">2 comments</a></li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							Chrome Remote Desktop is a remote desktop tool developed by Google. It uses a proprietary protocol, unofficially called…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-5883 post type-post status-publish format-standard has-post-thumbnail category-linux category-linux-commands category-ubuntu">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="8 CPU" loading="lazy" title="8 Commands to Check Linux CPU Usage 41" sizes="(max-width: 380px) 100vw, 380px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/8-CPU--380x220.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/8-CPU--380x220.png?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/8-CPU--380x220.png?w=380&amp;quality=100&amp;f=auto 380w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>4 minute read</li></ul>											</div>
					<a href="https://bytexd.com/8-commands-to-check-linux-cpu-usage/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal"><span style="background:#e95420" class="char cs-bg-dark">U</span><span class="label">Ubuntu</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/8-commands-to-check-linux-cpu-usage/" rel="bookmark" data-wpel-link="internal">8 Commands to Check Linux CPU Usage</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/samreena-alam/" title="View all posts by Samreena Aslam" data-wpel-link="internal">Samreena Aslam</a></span></li><li class="meta-date">October 23, 2021</li><li class="meta-shares">			<span class="total">
				<i class="cs-icon cs-icon-share"></i>
				<span class="total-number">
					4 shares				</span>
			</span>
			<div class="meta-share-links">
						<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-post_meta pk-share-buttons-mode-cached" data-post-id="5883" data-share-url="https://bytexd.com/8-commands-to-check-linux-cpu-usage/">

			
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/8-commands-to-check-linux-cpu-usage/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">4</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=8%20Commands%20to%20Check%20Linux%20CPU%20Usage&amp;via=ByteXD&amp;url=https://bytexd.com/8-commands-to-check-linux-cpu-usage/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/8-commands-to-check-linux-cpu-usage/&amp;media=https://bytexd.com/wp-content/uploads/2021/10/8-CPU--1024x576.png" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
				</div>
		</li><li class="meta-comments"><i class="cs-icon cs-icon-message-square"></i><a href="https://bytexd.com/8-commands-to-check-linux-cpu-usage/#respond" class="comments-link" data-wpel-link="internal">No comments</a></li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							Sometimes, due to the high utilization of resources, system applications get slow or unresponsive. All the programs must…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-6012 post type-post status-publish format-standard has-post-thumbnail category-ubuntu category-miscellaneous">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="samba" loading="lazy" title="How to Setup Samba Server in Ubuntu 20.04 61" sizes="(max-width: 380px) 100vw, 380px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/samba-380x220.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/samba-380x220.png?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/samba-380x220.png?w=380&amp;quality=100&amp;f=auto 380w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>7 minute read</li></ul>											</div>
					<a href="https://bytexd.com/how-to-setup-samba-server-in-ubuntu/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal"><span style="background:#1B1B3A" class="char cs-bg-dark">M</span><span class="label">Miscellaneous</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/how-to-setup-samba-server-in-ubuntu/" rel="bookmark" data-wpel-link="internal">How to Setup Samba Server in Ubuntu 20.04</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/muhammad-aziz/" title="View all posts by Muhammad Aziz" data-wpel-link="internal">Muhammad Aziz</a></span></li><li class="meta-date">October 31, 2021</li><li class="meta-shares">			<span class="total">
				<i class="cs-icon cs-icon-share"></i>
				<span class="total-number">
					1 share				</span>
			</span>
			<div class="meta-share-links">
						<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-post_meta pk-share-buttons-mode-cached" data-post-id="6012" data-share-url="https://bytexd.com/how-to-setup-samba-server-in-ubuntu/">

			
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/how-to-setup-samba-server-in-ubuntu/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">1</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=How%20to%20Setup%20Samba%20Server%20in%20Ubuntu%2020.04&amp;via=ByteXD&amp;url=https://bytexd.com/how-to-setup-samba-server-in-ubuntu/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/how-to-setup-samba-server-in-ubuntu/&amp;media=https://bytexd.com/wp-content/uploads/2021/10/samba-1024x576.png" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
				</div>
		</li><li class="meta-comments"><i class="cs-icon cs-icon-message-square"></i><a href="https://bytexd.com/how-to-setup-samba-server-in-ubuntu/#respond" class="comments-link" data-wpel-link="internal">No comments</a></li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							Samba is a utility present in Linux that allows sharing of folders and printers across different operating systems…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-6035 post type-post status-publish format-standard has-post-thumbnail category-ubuntu category-linux-commands">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="ioncube" loading="lazy" title="How To Install IonCube Loader on Ubuntu 20.04 76" sizes="(max-width: 380px) 100vw, 380px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/ioncube-380x220.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/ioncube-380x220.png?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/10/ioncube-380x220.png?w=380&amp;quality=100&amp;f=auto 380w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>3 minute read</li></ul>											</div>
					<a href="https://bytexd.com/how-to-install-an-ioncube-loader-on-ubuntu/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal"><span style="background:#e95420" class="char cs-bg-dark">U</span><span class="label">Ubuntu</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/how-to-install-an-ioncube-loader-on-ubuntu/" rel="bookmark" data-wpel-link="internal">How To Install IonCube Loader on Ubuntu 20.04</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/ozair-malik/" title="View all posts by Ozair Malik" data-wpel-link="internal">Ozair Malik</a></span></li><li class="meta-date">October 31, 2021</li><li class="meta-shares">			<span class="total">
				<i class="cs-icon cs-icon-share"></i>
				<span class="total-number">
					19 shares				</span>
			</span>
			<div class="meta-share-links">
						<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-post_meta pk-share-buttons-mode-cached" data-post-id="6035" data-share-url="https://bytexd.com/how-to-install-an-ioncube-loader-on-ubuntu/">

			
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/how-to-install-an-ioncube-loader-on-ubuntu/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">19</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=How%20To%20Install%20IonCube%20Loader%20on%20Ubuntu%2020.04&amp;via=ByteXD&amp;url=https://bytexd.com/how-to-install-an-ioncube-loader-on-ubuntu/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/how-to-install-an-ioncube-loader-on-ubuntu/&amp;media=https://bytexd.com/wp-content/uploads/2021/10/ioncube-1024x576.png" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
				</div>
		</li><li class="meta-comments"><i class="cs-icon cs-icon-message-square"></i><a href="https://bytexd.com/how-to-install-an-ioncube-loader-on-ubuntu/#respond" class="comments-link" data-wpel-link="internal">No comments</a></li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							What is IonCube? IonCube is a code encryption tool, created in 2003. It was introduced to protect codes…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-5339 post type-post status-publish format-standard has-post-thumbnail category-miscellaneous category-website-setup">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="Introduction to Ngrok A Tutorial for Beginners" loading="lazy" title="Introduction to Ngrok: A Tutorial for Beginners 86" sizes="(max-width: 380px) 100vw, 380px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-380x220.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-380x220.jpg?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-380x220.jpg?w=380&amp;quality=100&amp;f=auto 380w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>6 minute read</li></ul>											</div>
					<a href="https://bytexd.com/ngrok-tutorial-for-beginners/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal"><span style="background:#1B1B3A" class="char cs-bg-dark">M</span><span class="label">Miscellaneous</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/ngrok-tutorial-for-beginners/" rel="bookmark" data-wpel-link="internal">Introduction to Ngrok: A Tutorial for Beginners</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">September 19, 2021</li><li class="meta-shares">			<span class="total">
				<i class="cs-icon cs-icon-share"></i>
				<span class="total-number">
					3 shares				</span>
			</span>
			<div class="meta-share-links">
						<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-post_meta pk-share-buttons-mode-cached" data-post-id="5339" data-share-url="https://bytexd.com/ngrok-tutorial-for-beginners/">

			
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">3</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=Introduction%20to%20Ngrok%3A%20A%20Tutorial%20for%20Beginners&amp;via=ByteXD&amp;url=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/ngrok-tutorial-for-beginners/&amp;media=https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-1024x576.jpg" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
				</div>
		</li><li class="meta-comments"><i class="cs-icon cs-icon-message-square"></i><a href="https://bytexd.com/ngrok-tutorial-for-beginners/#comments" class="comments-link" data-wpel-link="internal">One comment</a></li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							If you are into web development, at times, you might have wondered how people on a different network…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-3187 post type-post status-publish format-standard has-post-thumbnail category-ubuntu tag-remote-desktop tag-ubuntu-20-04">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="How to Connect to a Ubuntu 20.04 Server via Remote Desktop Connection using xRDP" loading="lazy" sizes="(max-width: 380px) 100vw, 380px" title="How to Connect to a Ubuntu 20.04 Server via Remote Desktop Connection using xRDP 104" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/How-to-Connect-to-a-Ubuntu-20.04-Server-via-Remote-Desktop-Connection-using-xRDP-380x220.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/How-to-Connect-to-a-Ubuntu-20.04-Server-via-Remote-Desktop-Connection-using-xRDP-380x220.jpg?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/How-to-Connect-to-a-Ubuntu-20.04-Server-via-Remote-Desktop-Connection-using-xRDP-80x46.jpg?quality=100&amp;f=auto 80w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>10 minute read</li></ul>											</div>
					<a href="https://bytexd.com/xrdp-ubuntu/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal"><span style="background:#e95420" class="char cs-bg-dark">U</span><span class="label">Ubuntu</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/xrdp-ubuntu/" rel="bookmark" data-wpel-link="internal">How to Connect to a Ubuntu 20.04 Server via Remote Desktop Connection using xRDP</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">March 27, 2021</li><li class="meta-shares">			<span class="total">
				<i class="cs-icon cs-icon-share"></i>
				<span class="total-number">
					9 shares				</span>
			</span>
			<div class="meta-share-links">
						<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-post_meta pk-share-buttons-mode-cached" data-post-id="3187" data-share-url="https://bytexd.com/xrdp-ubuntu/">

			
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/xrdp-ubuntu/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">9</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=How%20to%20Connect%20to%20a%20Ubuntu%2020.04%20Server%20via%20Remote%20Desktop%20Connection%20using%20xRDP&amp;via=ByteXD&amp;url=https://bytexd.com/xrdp-ubuntu/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/xrdp-ubuntu/&amp;media=https://bytexd.com/wp-content/uploads/2021/03/How-to-Connect-to-a-Ubuntu-20.04-Server-via-Remote-Desktop-Connection-using-xRDP-1024x576.jpg" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
				</div>
		</li><li class="meta-comments"><i class="cs-icon cs-icon-message-square"></i><a href="https://bytexd.com/xrdp-ubuntu/#respond" class="comments-link" data-wpel-link="internal">No comments</a></li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							xRDP is an open source implementation of the Remote Desktop Protocol (RDP), developed by Microsoft. RDP allows users…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>
				</div>

			</div>

		</section>
	
	

			
			
		</main>

		
	</div><!-- .content-area -->


	<aside id="secondary" class="widget-area sidebar-area">
		<div class="sidebar sidebar-1"><span id="ezoic-pub-ad-placeholder-130" class="ezoic-adpicker-ad"></span>
						<div class="widget categories-2 widget_categories"><div class="title-block-wrap"><h5 class="title-block title-widget">Categories</h5></div><form action="https://bytexd.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select name="cat" id="cat" class="postform">
	<option value="-1">Select Category</option>
	<option class="level-0" value="16">CentOS  (10)</option>
	<option class="level-0" value="34">Debian  (10)</option>
	<option class="level-0" value="19">Digital Marketing  (1)</option>
	<option class="level-0" value="77">Hardware  (13)</option>
	<option class="level-0" value="32">Linux  (76)</option>
	<option class="level-0" value="38">Linux Commands  (58)</option>
	<option class="level-0" value="1">Miscellaneous  (14)</option>
	<option class="level-0" value="10">Ubuntu  (23)</option>
	<option class="level-0" value="29">Website Setup  (5)</option>
	<option class="level-0" value="33">WordPress  (4)</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</div><div class="widget powerkit_widget_posts-1 powerkit_widget_posts"><span id="ezoic-pub-ad-placeholder-101" class="ezoic-adpicker-ad"></span><div class="title-block-wrap"><span id="ezoic-pub-ad-placeholder-110" class="ezoic-adpicker-ad"></span><span class="ezoic-ad box-1 box-1110 adtester-container adtester-container-110" data-ez-name="bytexd_com-box-1"><span id="div-gpt-ad-bytexd_com-box-1-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-box-1-0')};</script></span><span style="width:300px;display:block;height:14px;margin:auto" class="reportline"><span style="text-align:center;font-size: smaller;float:left;line-height:normal;"><a href="https://www.ezoic.com/what-is-ezoic/" target="_blank" rel="noopener noreferrer nofollow" style="cursor:pointer"><img src="https://go.ezoic.net/utilcave_com/img/ezoic.png" alt="Ezoic" loading="lazy" style="height:12px !important; padding:2px !important; border:0px !important; cursor:pointer !important; width: 58px !important; margin:0 !important; box-sizing: content-box !important;"/></a></span><span class="ez-report-ad-button" name="?pageview_id=1904890e-0edb-4d1f-5a31-091b9e0cfa10&amp;ad_position_id=110&amp;impression_group_id=bytexd_com-box-1/2022-02-15/7950801320687993&amp;ad_size=300x250&amp;domain_id=283186&amp;url=https://bytexd.com/slickstack/" style="cursor: pointer!important; font-size:12px !important;color: #a5a5a5 ;float:right;text-decoration:none !important;font-family:arial !important;line-height:normal;">report this ad</span></span></span><h5 class="title-block title-widget">Featured Posts</h5></div>
			<div class="widget-body pk-widget-posts pk-widget-posts-template-default pk-widget-posts-template-numbered posts-per-page-4">
				<ul>
											<li class="pk-post-item">
									<article class="pk-preview-enabled post-7698 post type-post status-publish format-standard has-post-thumbnail category-debian tag-remote-desktop">
			<div class="pk-post-outer">
									<div class="pk-post-inner pk-post-thumbnail">
						<a href="https://bytexd.com/how-to-install-configure-vnc-on-debian/" class="post-thumbnail" data-wpel-link="internal">
							<img width="80" height="80" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-small size-csco-small wp-post-image" alt="How to Install &amp; Configure VNC Server on Debian" loading="lazy" sizes="(max-width: 80px) 100vw, 80px" title="How to Install and Configure VNC on Debian 10/11 120" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/How-to-Install-Configure-VNC-Server-on-Debian-80x80.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/How-to-Install-Configure-VNC-Server-on-Debian-80x80.png?quality=100&amp;f=auto 80w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/How-to-Install-Configure-VNC-Server-on-Debian-150x150.png?quality=100&amp;f=auto 150w,"/>						</a>
					</div>
				
				<div class="pk-post-inner pk-post-data">
										<h5 class="entry-title">
						<a href="https://bytexd.com/how-to-install-configure-vnc-on-debian/" data-wpel-link="internal">How to Install and Configure VNC on Debian 10/11</a>
					</h5>
					<ul class="post-meta"><li class="meta-date">February 14, 2022</li></ul>				</div>
			</div>
		</article>
							</li>
											<li class="pk-post-item">
									<article class="pk-preview-enabled post-7777 post type-post status-publish format-standard has-post-thumbnail category-hardware">
			<div class="pk-post-outer">
									<div class="pk-post-inner pk-post-thumbnail">
						<a href="https://bytexd.com/hardware/laptops-wifi-6e/" class="post-thumbnail" data-wpel-link="internal">
							<img width="80" height="80" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-small size-csco-small wp-post-image" alt="Laptops with Wifi 6e" loading="lazy" sizes="(max-width: 80px) 100vw, 80px" title="Best Laptops with WiFi 6E and Bluetooth 5.2 121" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/Laptops-with-Wifi-6e-80x80.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/Laptops-with-Wifi-6e-80x80.png?quality=100&amp;f=auto 80w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/Laptops-with-Wifi-6e-150x150.png?quality=100&amp;f=auto 150w,"/>						</a>
					</div>
				
				<div class="pk-post-inner pk-post-data">
										<h5 class="entry-title">
						<a href="https://bytexd.com/hardware/laptops-wifi-6e/" data-wpel-link="internal">Best Laptops with WiFi 6E and Bluetooth 5.2</a>
					</h5>
					<ul class="post-meta"><li class="meta-date">February 14, 2022</li></ul>				</div>
			</div>
		</article>
							</li>
											<li class="pk-post-item">
									<article class="pk-preview-enabled post-7731 post type-post status-publish format-standard has-post-thumbnail category-linux category-centos tag-rhel">
			<div class="pk-post-outer">
									<div class="pk-post-inner pk-post-thumbnail">
						<a href="https://bytexd.com/install-iredmail-rhel/" class="post-thumbnail" data-wpel-link="internal">
							<img width="80" height="80" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-small size-csco-small wp-post-image" alt="How to Install iRedMail on RHEL" loading="lazy" sizes="(max-width: 80px) 100vw, 80px" title="How to Install iRedMail on RHEL (CentOS, RockyLinux, etc) 122" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/How-to-Install-iRedMail-on-RHEL-80x80.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/How-to-Install-iRedMail-on-RHEL-80x80.png?quality=100&amp;f=auto 80w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/How-to-Install-iRedMail-on-RHEL-150x150.png?quality=100&amp;f=auto 150w,"/>						</a>
					</div>
				
				<div class="pk-post-inner pk-post-data">
										<h5 class="entry-title">
						<a href="https://bytexd.com/install-iredmail-rhel/" data-wpel-link="internal">How to Install iRedMail on RHEL (CentOS, RockyLinux, etc)</a>
					</h5>
					<ul class="post-meta"><li class="meta-date">February 12, 2022</li></ul>				</div>
			</div>
		</article>
							</li>
											<li class="pk-post-item">
									<article class="pk-preview-enabled post-7684 post type-post status-publish format-standard has-post-thumbnail category-linux category-linux-commands tag-bash">
			<div class="pk-post-outer">
									<div class="pk-post-inner pk-post-thumbnail">
						<a href="https://bytexd.com/bash-comments/" class="post-thumbnail" data-wpel-link="internal">
							<img width="80" height="80" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-small size-csco-small wp-post-image" alt="Bash Comments" loading="lazy" sizes="(max-width: 80px) 100vw, 80px" title="Bash Comments 123" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/Bash-Comments-80x80.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/Bash-Comments-80x80.png?quality=100&amp;f=auto 80w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/Bash-Comments-150x150.png?quality=100&amp;f=auto 150w,"/>						</a>
					</div>
				
				<div class="pk-post-inner pk-post-data">
										<h5 class="entry-title">
						<a href="https://bytexd.com/bash-comments/" data-wpel-link="internal">Bash Comments</a>
					</h5>
					<ul class="post-meta"><li class="meta-date">February 11, 2022</li></ul>				</div>
			</div>
		</article>
							</li>
									</ul>
			</div>

			</div><div class="widget_text widget custom_html-2 widget_custom_html"><div class="textwidget custom-html-widget"><span id="ezoic-pub-ad-placeholder-102" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-leaderboard-1 large-leaderboard-1102 adtester-container adtester-container-102" data-ez-name="bytexd_com-large-leaderboard-1"><span id="div-gpt-ad-bytexd_com-large-leaderboard-1-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-large-leaderboard-1-0')};</script></span><span style="width:300px;display:block;height:14px;margin:auto" class="reportline"><span style="text-align:center;font-size: smaller;float:left;line-height:normal;"><a href="https://www.ezoic.com/what-is-ezoic/" target="_blank" rel="noopener noreferrer nofollow" style="cursor:pointer"><img src="https://go.ezoic.net/utilcave_com/img/ezoic.png" alt="Ezoic" loading="lazy" style="height:12px !important; padding:2px !important; border:0px !important; cursor:pointer !important; width: 58px !important; margin:0 !important; box-sizing: content-box !important;"/></a></span><span class="ez-report-ad-button" name="?pageview_id=1904890e-0edb-4d1f-5a31-091b9e0cfa10&amp;ad_position_id=102&amp;impression_group_id=bytexd_com-large-leaderboard-1/2022-02-15/2585867320691656&amp;ad_size=300x250&amp;domain_id=283186&amp;url=https://bytexd.com/slickstack/" style="cursor: pointer!important; font-size:12px !important;color: #a5a5a5 ;float:right;text-decoration:none !important;font-family:arial !important;line-height:normal;">report this ad</span></span></span><a href="https://www.tkqlhce.com/click-100576779-12740668" target="_top" rel="noopener external" data-wpel-link="external"> <img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" width="250" height="250" alt="" border="0" sizes="(max-width: 250px) 100vw, 250px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/12740668-1613045654601.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/12740668-1613045654601.png?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2022/02/12740668-1613045654601.png?w=250&amp;quality=100&amp;f=auto 250w,"/></a></div></div>					</div>
		<div class="sidebar sidebar-2"></div>
	</aside><!-- .widget-area -->


						
					</div><!-- .main-content -->

					
				</div><!-- .cs-container -->

				
			</div><!-- .site-content -->

			
			
			<footer id="colophon" class="site-footer">
				
				
				<div class="footer-info">

					<div class="cs-container">

						<div class="site-info">

							<div class="footer-col-info">
																	<span class="site-title footer-title" href="https://bytexd.com/" rel="home">
										<img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="ByteXD" sizes="(max-width: 214px) 100vw, 214px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?w=214&amp;quality=100&amp;f=auto 214w,"/>									</span>
																										<div class="footer-copyright">
										© 2021 ByteXD.com									</div>
																</div>

							
															<div class="footer-col-nav footer-col-nav-full">
									<nav class="navbar-footer"><ul id="menu-footer-menu" class="navbar-nav"><li id="menu-item-2508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2508"><a href="https://bytexd.com/contact/" data-wpel-link="internal">Contact</a></li>
<li id="menu-item-2510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2510"><a href="https://bytexd.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li id="menu-item-2509" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2509"><a href="https://bytexd.com/terms-and-conditions/" data-wpel-link="internal">Terms and Conditions</a></li>
<li id="menu-item-6289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6289"><a href="https://bytexd.com/affiliate-disclosure/" data-wpel-link="internal">Affiliate Disclosure</a></li>
</ul></nav>								</div>
								
						</div>

					</div>

				</div>

			<span id="ezoic-pub-ad-placeholder-151" class="ezoic-adpicker-ad"></span><span class="ezoic-ad medrectangle-1 medrectangle-1151 adtester-container adtester-container-151" data-ez-name="bytexd_com-medrectangle-1"><span id="div-gpt-ad-bytexd_com-medrectangle-1-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-medrectangle-1-0')};</script></span><span style="width:300px;display:block;height:14px;margin:auto" class="reportline"><span style="text-align:center;font-size: smaller;float:left;line-height:normal;"><a href="https://www.ezoic.com/what-is-ezoic/" target="_blank" rel="noopener noreferrer nofollow" style="cursor:pointer"><img src="https://go.ezoic.net/utilcave_com/img/ezoic.png" alt="Ezoic" loading="lazy" style="height:12px !important; padding:2px !important; border:0px !important; cursor:pointer !important; width: 58px !important; margin:0 !important; box-sizing: content-box !important;"/></a></span><span class="ez-report-ad-button" name="?pageview_id=1904890e-0edb-4d1f-5a31-091b9e0cfa10&amp;ad_position_id=151&amp;impression_group_id=bytexd_com-medrectangle-1/2022-02-15/6152746392701737&amp;ad_size=300x250&amp;domain_id=283186&amp;url=https://bytexd.com/slickstack/" style="cursor: pointer!important; font-size:12px !important;color: #a5a5a5 ;float:right;text-decoration:none !important;font-family:arial !important;line-height:normal;">report this ad</span></span></span></footer>

			
		</div>

	</div><!-- .site-inner -->

	
</div><!-- .site -->


			<div class="pk-mobile-share-overlay">
							</div>
			<a href="javascript:void(0);" id="wpdUserContentInfoAnchor" style="display:none;" rel="#wpdUserContentInfo" data-wpd-lity="" data-wpel-link="internal">wpDiscuz</a><div id="wpdUserContentInfo" style="overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;" class="lity-hide"></div><div id="wpd-editor-source-code-wrapper-bg"></div><div id="wpd-editor-source-code-wrapper"><textarea id="wpd-editor-source-code"></textarea><button id="wpd-insert-source-code">Insert</button><input type="hidden" id="wpd-editor-uid"/></div>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KX8VTB3"
height="0" width="0" style="display:none;visibility:hidden" aria-hidden="true"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->			<script>
			var _SEARCHWP_LIVE_AJAX_SEARCH_BLOCKS = true;
			var _SEARCHWP_LIVE_AJAX_SEARCH_ENGINE = 'default';
			var _SEARCHWP_LIVE_AJAX_SEARCH_CONFIG = 'default';
			</script>
			<script type="text/javascript">/* <![CDATA[ */!function(e,n){var r={"selectors":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"options":{"indent":4,"ampersandCleanup":true,"linehover":true,"rawcodeDbclick":false,"textOverflow":"break","linenumbers":false,"theme":"wpcustom","language":"generic","retainCssClasses":true,"collapse":false,"toolbarOuter":"","toolbarTop":"{BTN_RAW}{BTN_COPY}{BTN_WINDOW}{BTN_WEBSITE}","toolbarBottom":""},"resources":["https:\/\/bytexd.com\/wp-content\/plugins\/enlighter\/cache\/enlighterjs.min.css?WtqZIEvPDriaoRi","https:\/\/bytexd.com\/wp-content\/plugins\/enlighter\/resources\/enlighterjs\/enlighterjs.min.js"]},o=document.getElementsByTagName("head")[0],t=n&&(n.error||n.log)||function(){};e.EnlighterJSINIT=function(){!function(e,n){var r=0,l=null;function c(o){l=o,++r==e.length&&(!0,n(l))}e.forEach(function(e){switch(e.match(/\.([a-z]+)(?:[#?].*)?$/)[1]){case"js":var n=document.createElement("script");n.onload=function(){c(null)},n.onerror=c,n.src=e,n.async=!0,o.appendChild(n);break;case"css":var r=document.createElement("link");r.onload=function(){c(null)},r.onerror=c,r.rel="stylesheet",r.type="text/css",r.href=e,r.media="all",o.appendChild(r);break;default:t("Error: invalid file extension",e)}})}(r.resources,function(e){e?t("Error: failed to dynamically load EnlighterJS resources!",e):"undefined"!=typeof EnlighterJS?EnlighterJS.init(r.selectors.block,r.selectors.inline,r.options):t("Error: EnlighterJS resources not loaded yet!")})},(document.querySelector(r.selectors.block)||document.querySelector(r.selectors.inline))&&e.EnlighterJSINIT()}(window,console); /* ]]> */</script><script type="text/javascript" data-cfasync="false">var bU="https://bytexd.com/wp-content/plugins/wp-youtube-lyte/lyte/";var mOs=null;style = document.createElement("style");style.type = "text/css";rules = document.createTextNode(".lyte-wrapper-audio div, .lyte-wrapper div {margin:0px; overflow:hidden;} .lyte,.lyMe{position:relative;padding-bottom:56.25%;height:0;overflow:hidden;background-color:#777;} .fourthree .lyMe, .fourthree .lyte {padding-bottom:75%;} .lidget{margin-bottom:5px;} .lidget .lyte, .widget .lyMe {padding-bottom:0!important;height:100%!important;} .lyte-wrapper-audio .lyte{height:38px!important;overflow:hidden;padding:0!important} .lyMe iframe, .lyte iframe,.lyte .pL{position:absolute !important;top:0;left:0;width:100%;height:100%!important;background:no-repeat scroll center #000;background-size:cover;cursor:pointer} .tC{left:0;position:absolute;top:0;width:100%} .tC{background-image:linear-gradient(to bottom,rgba(0,0,0,0.6),rgba(0,0,0,0))} .tT{color:#FFF;font-family:Roboto,sans-serif;font-size:16px;height:auto;text-align:left;padding:5px 10px 50px 10px} .play{background:no-repeat scroll 0 0 transparent;width:88px;height:63px;position:absolute;left:43%;left:calc(50% - 44px);left:-webkit-calc(50% - 44px);top:38%;top:calc(50% - 31px);top:-webkit-calc(50% - 31px);} .widget .play {top:30%;top:calc(45% - 31px);top:-webkit-calc(45% - 31px);transform:scale(0.6);-webkit-transform:scale(0.6);-ms-transform:scale(0.6);} .lyte:hover .play{background-position:0 -65px;} .lyte-audio .pL{max-height:38px!important} .lyte-audio iframe{height:438px!important} .ctrl{background:repeat scroll 0 -220px rgba(0,0,0,0.3);width:100%;height:40px;bottom:0px;left:0;position:absolute;} .lyte-wrapper .ctrl{display:none}.Lctrl{background:no-repeat scroll 0 -137px transparent;width:158px;height:40px;bottom:0;left:0;position:absolute} .Rctrl{background:no-repeat scroll -42px -179px transparent;width:117px;height:40px;bottom:0;right:0;position:absolute;padding-right:10px;}.lyte-audio .play{display:none}.lyte-audio .ctrl{background-color:rgba(0,0,0,1)}.lyte .hidden{display:none}");if(style.styleSheet) { style.styleSheet.cssText = rules.nodeValue;} else {style.appendChild(rules);}document.getElementsByTagName("head")[0].appendChild(style);</script><script type="text/javascript" data-cfasync="false" async="" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/d8e511b9ebcfebd1f2291cb4cf4f03df-vc6013015b043295fb3b958ff0ac89feb1bc70318.js?wyl_version=1.7.19"></script><script type="text/javascript" src="https://bytexd.com/wp-content/plugins/modern-footnotes/modern-footnotes.min.js?ver=1.4.11" id="modern_footnotes-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/powerkit-basic-elements-vee12b797dcf86abfd2082cdd64f5e14902e144cb.js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4" id="imagesloaded-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/powerkit/modules/lightbox/public/js/glightbox.min.js?ver=2.6.6" id="glightbox-js"></script>
<script type="text/javascript" id="powerkit-lightbox-js-extra">
/* <![CDATA[ */
var powerkit_lightbox_localize = {"text_previous":"Previous","text_next":"Next","text_close":"Close","text_loading":"Loading","text_counter":"of","single_image_selectors":".entry-content img,.single .post-media img","gallery_selectors":".wp-block-gallery, .gallery","exclude_selectors":"","zoom_icon":"true"};
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/powerkit-lightbox-v1c0d437d80b391664d107539a770a5dad568deb8.js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/powerkit-share-buttons-vcf913b3b4e1854cc4cb7c03292e4cb03b4c880bf.js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/powerkit-table-of-contents-vda06c91cfd9830e6a8ec8cf6052247119b8094af.js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/wpdiscuz-cookie-js-v774baeaed1674c0e60cd958eafeda0e85a19744b.js"></script>
<script type="text/javascript" id="quill-js-before">
        var wpdiscuzEditorOptions = {
        modules: {
        toolbar: "",
        counter: {
        uniqueID: "",
        commentmaxcount : 0,
        replymaxcount : 0,
        commentmincount : 1,
        replymincount : 1,
        },
                },
        wc_be_the_first_text: "Be the First to Comment!",
        wc_comment_join_text: "Join the discussion",
        theme: 'snow',
        debug: 'error'
        };
        
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/quill/quill.min.js?ver=1.3.6" id="quill-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/js/wpd-editor.min.js?ver=1.3.6" id="wpd-editor-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=1.3.6" id="autogrowtextarea-js-js"></script>
<script type="text/javascript" id="wpdiscuz-ajax-js-js-extra">
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment is no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"Spoiler Title","wc_cannot_rate_again":"You cannot rate again","wc_not_allowed_to_rate":"You're not allowed to rate here","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"30","liveUpdateGuests":"0","wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"0","commentTextMaxLength":"0","replyTextMaxLength":"0","commentTextMinLength":"1","replyTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"1","enableFbLogin":"0","fbUseOAuth2":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"18ed1fa9b0f8840218f1271c4263aeba","isLoadOnlyParentComments":"0","scrollToComment":"1","commentFormView":"expanded","enableDropAnimation":"1","isNativeAjaxEnabled":"1","enableBubble":"0","bubbleLiveUpdate":"0","bubbleHintTimeout":"45","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"1","bubbleLocation":"content_left","firstLoadWithAjax":"0","wc_copied_to_clipboard":"Copied to clipboard!","inlineFeedbackAttractionType":"blink","loadRichEditor":"1","wpDiscuzReCaptchaSK":"","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"1","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"2097152","wmuPostMaxSize":"104857600","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"Are you sure you want to delete this attachment?","wmuPhraseNotAllowedFile":"Not allowed file type","wmuPhraseMaxFileCount":"Maximum number of uploaded files is 1","wmuPhraseMaxFileSize":"Maximum upload file size is 2MB","wmuPhrasePostMaxSize":"Maximum post size is 100MB","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.3.12","wc_post_id":"6715","isCookiesEnabled":"1","loadLastCommentId":"0","dataFilterCallbacks":[],"phraseFilters":[],"scrollSize":"32","is_email_field_required":"0","url":"https:\/\/bytexd.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/bytexd.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/bytexd.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"f96448b3e7","validateNonceForGuests":""};
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.min.js?ver=7.3.12" id="wpdiscuz-ajax-js-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/colorbox/jquery.colorbox.min.js?ver=7.3.12" id="wmu-colorbox-js-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-mu-frontend.min.js?ver=7.3.12" id="wpdiscuz-mu-js-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/lity/lity.min.js?ver=7.3.12" id="wpdiscuz-lity-js-js"></script>
<script type="text/javascript" id="wpdiscuz-user-content-js-js-extra">
/* <![CDATA[ */
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?","additionalTab":"0"};
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-user-content.min.js?ver=7.3.12" id="wpdiscuz-user-content-js-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/colcade-v9c40b157718c433b6d3911571f86f4629c1c6fc5.js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/themes/squaretype/js/ofi.min.js?ver=3.2.3" id="object-fit-images-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/csco-scripts-v5febe739810b166badf2757e906f9fc5a32b22c0.js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-includes/js/comment-reply.min.js?ver=5.9" id="comment-reply-js"></script>
<script type="text/javascript" id="swp-live-search-client-js-extra">
/* <![CDATA[ */
var searchwp_live_search_params = [];
searchwp_live_search_params = {"ajaxurl":"https:\/\/bytexd.com\/wp-admin\/admin-ajax.php","origin_id":6715,"config":{"default":{"engine":"default","input":{"delay":300,"min_chars":3},"results":{"position":"bottom","width":"auto","offset":{"x":0,"y":5}},"spinner":{"lines":12,"length":8,"width":3,"radius":8,"scale":1,"corners":1,"color":"#424242","fadeColor":"transparent","speed":1,"rotate":0,"animation":"searchwp-spinner-line-fade-quick","direction":1,"zIndex":2000000000,"className":"spinner","top":"50%","left":"50%","shadow":"0 0 1px transparent","position":"absolute"}}},"msg_no_config_found":"No valid SearchWP Live Search configuration found!","aria_instructions":"When autocomplete results are available use up and down arrows to review and enter to go to the desired page. Touch device users, explore by touch or with swipe gestures."};;
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/searchwp-live-ajax-search/assets/javascript/dist/script.min.js?ver=1.6.1" id="swp-live-search-client-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/aawp/assets/dist/js/main.js?ver=3.17.3" id="aawp-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/cache/asset-cleanup/js/item/jco-asciinema-player-block-editor-vcaf55956bd6001b8a6c14e88c20c4a46afb349b9.js"></script>
<script>window.GA_ID='UA-137868766-3';</script><script src="https://bytexd.com/wp-content/plugins/flying-analytics/js/minimal-analytics.js" defer=""></script><script type="text/javascript" id="flying-scripts">const loadScriptsTimer=setTimeout(loadScripts,5*1000);const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){loadScripts();clearTimeout(loadScriptsTimer);userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}
function loadScripts(){document.querySelectorAll("script[data-type='lazy']").forEach(function(elem){elem.setAttribute("src",elem.getAttribute("data-src"))})}</script>
    <script type="text/javascript" id="flying-images">"use strict";window.FIConfig={lazyMethod:"javascript",lazyMargin:500};var flyingImages=function(){var a=document.querySelectorAll("[data-loading=\"lazy\"]");if(window.FIConfig.lazyMethod.includes("native")&&"loading"in HTMLImageElement.prototype)a.forEach(function(a){a.removeAttribute("data-loading"),a.setAttribute("loading","lazy"),a.dataset.srcset&&(a.srcset=a.dataset.srcset),a.src=a.dataset.src});else if(window.IntersectionObserver){var b=new IntersectionObserver(function(a){a.forEach(function(a){a.isIntersecting&&(b.unobserve(a.target),a.target.dataset.srcset&&(a.target.srcset=a.target.dataset.srcset),a.target.src=a.target.dataset.src,a.target.classList.add("lazyloaded"),a.target.removeAttribute("data-loading"))})},{rootMargin:window.FIConfig.lazyMargin+"px"});a.forEach(function(a){b.observe(a)})}else for(var c=0;c<a.length;c++)a[c].dataset.srcset&&(a[c].srcset=a[c].dataset.srcset),a[c].src=a[c].dataset.src};flyingImages();function throttle(a,b){var c=!1;return function(){c||(a.apply(null,arguments),c=!0,setTimeout(function(){c=!1},b))}}var dynamicContentObserver=new MutationObserver(throttle(flyingImages,125));dynamicContentObserver.observe(document.body,{attributes:!0,childList:!0,subtree:!0}),function(){var a=document.querySelectorAll("[data-loading=\"lazy-background\"]");if(window.IntersectionObserver){var d=new IntersectionObserver(function(a){a.forEach(function(a){if(a.isIntersecting){d.unobserve(a.target);var b=a.target.getAttribute("style"),c=b.replace("background:none;","");a.target.setAttribute("style",c),a.target.removeAttribute("data-loading")}})},{rootMargin:window.FIConfig.lazyMargin+"px"});a.forEach(function(a){d.observe(a)})}else for(var e=0;e<a.length;e++){var b=a[e].target.getAttribute("style"),c=b.replace("background:none;","");a[e].target.setAttribute("style",c),a[e].target.removeAttribute("data-loading")}}();</script>
    	<script type="text/javascript">
		"use strict";

		(function($) {

			$( window ).on( 'load', function() {

				// Each All Share boxes.
				$( '.pk-share-buttons-mode-rest' ).each( function() {

					var powerkitButtonsIds = [],
						powerkitButtonsBox = $( this );

					// Check Counts.
					if ( ! powerkitButtonsBox.hasClass( 'pk-share-buttons-has-counts' ) && ! powerkitButtonsBox.hasClass( 'pk-share-buttons-has-total-counts' ) ) {
						return;
					}

					powerkitButtonsBox.find( '.pk-share-buttons-item' ).each( function() {
						if ( $( this ).attr( 'data-id' ).length > 0 ) {
							powerkitButtonsIds.push( $( this ).attr( 'data-id' ) );
						}
					});

					// Generate accounts data.
					var powerkitButtonsData = {};

					if( powerkitButtonsIds.length > 0 ) {
						powerkitButtonsData = {
							'ids'     : powerkitButtonsIds.join(),
							'post_id' : powerkitButtonsBox.attr( 'data-post-id' ),
							'url'     : powerkitButtonsBox.attr( 'data-share-url' ),
						};
					}

					// Get results by REST API.
					$.ajax({
						type: 'GET',
						url: 'https://bytexd.com/wp-json/social-share/v1/get-shares',
						data: powerkitButtonsData,
						beforeSend: function(){

							// Add Loading Class.
							powerkitButtonsBox.addClass( 'pk-share-buttons-loading' );
						},
						success: function( response ) {

							if ( ! $.isEmptyObject( response ) && ! response.hasOwnProperty( 'code' ) ) {

								// Accounts loop.
								$.each( response, function( index, data ) {

									if ( index !== 'total_count' ) {

										// Find Bsa Item.
										var powerkitButtonsItem = powerkitButtonsBox.find( '.pk-share-buttons-item[data-id="' + index + '"]');

										// Set Count.
										if ( data.hasOwnProperty( 'count' ) && data.count  ) {

											powerkitButtonsItem.removeClass( 'pk-share-buttons-no-count' ).addClass( 'pk-share-buttons-item-count' );
											powerkitButtonsItem.find( '.pk-share-buttons-count' ).html( data.count );

										} else {
											powerkitButtonsItem.addClass( 'pk-share-buttons-no-count' );
										}
									}
								});

								if ( powerkitButtonsBox.hasClass( 'pk-share-buttons-has-total-counts' ) && response.hasOwnProperty( 'total_count' ) ) {
									var powerkitButtonsTotalBox = powerkitButtonsBox.find( '.pk-share-buttons-total' );

									if ( response.total_count ) {
										powerkitButtonsTotalBox.find( '.pk-share-buttons-count' ).html( response.total_count );
										powerkitButtonsTotalBox.show().removeClass( 'pk-share-buttons-total-no-count' );
									}
								}
							}

							// Remove Loading Class.
							powerkitButtonsBox.removeClass( 'pk-share-buttons-loading' );
						},
						error: function() {

							// Remove Loading Class.
							powerkitButtonsBox.removeClass( 'pk-share-buttons-loading' );
						}
					});
				});
			});

		})(jQuery);
	</script>
	<script src="https://stats.wp.com/e-202207.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.6',blog:'179315647',post:'6715',tz:'0',srv:'bytexd.com'} ]);
	_stq.push([ 'clickTrackerInit', '179315647', '6715' ]);
</script>



<div class="ezmob-footer ezoic-floating-bottom ezo_ad ezmob-footer-desktop" id="ezmobfooter"><center><span id="ezoic-pub-ad-placeholder-100"></span><div class="ezmob-footer ezoic-floating-bottom ezo_ad ezmob-footer-desktop" id="ezmobfooter"><center><span class="ezoic-ad medrectangle-2 medrectangle-2100 adtester-container adtester-container-100" data-ez-name="bytexd_com-medrectangle-2"><span id="div-gpt-ad-bytexd_com-medrectangle-2-0" ezaw="970" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:90px;min-width:970px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-medrectangle-2-0')};</script></span></span></center><span class="ezmob-footer-close" onclick="__ez_close_anchor()">x</span></div></center><span class="ezmob-footer-close" onclick="__ez_close_anchor()">x</span></div><div id="CCPA_opt_out" style="position: absolute;width: 100%;z-index:200000000001;background-color:#ffffff;">
	<div style="float: right;text-align: right;">
		<button onclick="submitCCPAPost('consent')" style="border: 0px; cursor: pointer; font-size:20px; background-color: transparent;color: #000000">&times;</button>
	</div>
	<div style="width:100%;border-top: 3px solid #5fa624; padding: 3px;font-size: 10px;color: #000000 !important;text-align: center;font-size:11px !important; font-family: Arial, Helvetica, sans-serif !important;">
		We and our partners share information on your use of this website to help improve your experience. 
		<button onclick="submitCCPAPost('nonconsent')" style="margin-top: 4px;border: 1px solid #5fa624; color: #000000; background: transparent!important;padding: 2px 4px !important;cursor: pointer;"> Do not sell my info </button>
		<button onclick="submitCCPAPost('consent')" style="margin-top: 4px;border: 1px solid #5fa624; background: #5fa624!important;margin-left: 5px; padding: 2px 10px !important;cursor: pointer;"> Ok </button>
	</div>
	</div>
	<script type="text/javascript" >
		function submitCCPAPost(value) {
			var xhttp = new XMLHttpRequest();
			xhttp.open("POST", '/ezoicUserDataProtection/consent', true);
			xhttp.setRequestHeader("Content-Type", "application/x-www-form-urlencoded");
			xhttp.onreadystatechange = function() {
				if (this.readyState === 4 && this.status === 200) {
					if (value === "nonconsent") {
						var language = "en";
						if(language == "fr") {
							alert("Nous traitons votre demande de retrait. Merci!");
						} else if (language == "de") {
							alert("Ihre Anfrage bezüglich Opt Out wird von uns durchgeführt. Vielen Dank!");
						} else {
							alert("We are processing your request to opt out. Thank you!");
						}
					}
					// Clean up the footer
					var footer_element = document.getElementById("CCPA_opt_out");
					footer_element.parentNode.removeChild(footer_element);
				}
			}
			xhttp.send("selected=" + value);
		}
	</script>
<script type="text/javascript">
				var __inScopeForCCPA = true;
		function __uspapi(command, version, callback) {
			var response = null;
			var successs = false;
			if (command === "getUSPData" && version === 1) {
				var uspString = "1"; // Version
				if (__inScopeForCCPA) {
					uspString += "Y"; // Has Explicit Notice for Opt Out been provided (ex footer or minor consent modal)
					var result;
					var consentCookie = (result = new RegExp('(?:^|; )ezoccpaconsent=([^;]*)').exec(document.cookie)) ? (result[1]) : null;
					if (consentCookie === "nonconsent") {
						uspString += "Y";
					}
					else {
						uspString += "N";
					}
					uspString += "N" // Is pub a signatory to the IAB Limited Service Provider Agreement (http://www.iabprivacy.com/)
				}
				else {
					uspString += "---";
				}
				response = {
					uspString: uspString,
					version: 1
				};
				success = true;
			}
			return callback(response, success);
		};
		function __receiveUspapiMessage(event) {
			if (event.data.hasOwnProperty('__uspapiCall')) {
				__uspapi('getUSPData', 1, function(uspData, success) {
					event.source.postMessage({
						__uspapiReturn: {
							returnValue: uspData,
							success: success,
							callId: event.data.__uspapiCall.callId
						}
					},
					event.origin);
				});
			}
			return null;
		};
		window.addEventListener("message", __receiveUspapiMessage, false);
</script>
<script>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</script>
<script>var __ez_tkn_evnt = function() { if(typeof(_ezaq) != 'undefined'){if(typeof window.ezogtk !== "undefined" && window.ezogtk !== "") {__ez.bit.AddAndFire(_ezaq.page_view_id,[new __ezDotData("ext_user_hash",window.ezogtk)]);}}};document.addEventListener("DOMContentLoaded", __ez.queue.addFunc("__ez_tkn_evnt", "__ez_tkn_evnt", event, false, ['/detroitchicago/minneapolis.js','/detroitchicago/memphis.js'], true, true, false, true));</script>
<script async data-ezscrex="false">__ez_fad_load(0,0);__ez_fad_doc_ht=__ez_fad_docht();__ez_fad_vp_ht=__ez_fad_vpht();function __ez_fad_scroll(){return window.pageYOffset||(document.documentElement||document.body.parentNode||document.body).scrollTop}
var __ez_fad_scrollint=setInterval(function(){var sy=__ez_fad_scroll();var isShortPage=__ez_fad_doc_ht<=(__ez_fad_vh+100);var bot=(__ez_fad_vp_ht+sy);var botThresh=bot+__ez_fad_vp_ht;for(var divid in __ez_fad_divpos){if(__ez_fad_fastdiv.indexOf(divid)!=-1){continue;}
var divPos=__ez_fad_divpos[divid];if(divPos>0&&divPos>sy&&divPos<(sy+200)){if(typeof __ez_fad_instaslots[divid]=='function'){__ez_fad_instaslots[divid]();}}else if(divPos>0&&divPos>sy&&divPos<(sy+600)){if(typeof __ez_fad_instaslots[divid]=='function'){__ez_fad_viewslots[divid]();}}}
__ez_fad_chkpos();if(ezslit_run[0]!==true){__ez_fad_load(0,0);}
if((sy>0||isShortPage)&&ezslit_run[1]!=true){__ez_fad_load(1,null);__ez_fad_load(5,null);}
if((sy>100||isShortPage)&&ezslit_run[2]!=true){__ez_fad_load(2,null);}
if(sy>(__ez_fad_vp_ht*.75)&&ezslit_run[3]!=true){__ez_fad_load(3,null);}
if(document.readyState==="complete"&&!__ez_fad_floatshowd&&typeof __ez_fad_floating!=='undefined'&&__ez_fad_floating.length>0&&__ez_fad_count===0){setTimeout(googletag.cmd.push(function(){__ez_fad_floatshow()}),500);}
if(ezslit_run[1]==true&&ezslit_run[2]==true&&ezslit_run[3]==true){clearInterval(__ez_fad_scrollint);}},500);function __ez_fad_chkpos(){if(typeof __ez_fad_divs[4]!='undefined'){for(var i=0;i<__ez_fad_divs[4].length;i++){var id=__ez_fad_divs[4][i];__ez_fad_divs[4][i]=null;__ez_fad_position([id]);}}}</script>
<script type="text/javascript">(function(f,a){function g(b,a,c){b.addEventListener?b.addEventListener(a,c):b.attachEvent("on"+a,function(){c.call(b)})}function k(b){b&&("string"==typeof b["class"]&&b["class"]&&a.getElementById("uglipop_popbox").setAttribute("class",b["class"]),b.keepLayout&&!b["class"]&&a.getElementById("uglipop_popbox").setAttribute("style","position:relative;height:300px;width:300px;background-color:white;opacity:1;"),"string"==typeof b.content&&b.content&&"html"==b.source&&(a.getElementById("uglipop_popbox").innerHTML=b.content),"string"==typeof b.content&&b.content&&"div"==b.source&&(a.getElementById("uglipop_popbox").innerHTML=a.getElementById(b.content).innerHTML));a.getElementById("uglipop_overlay_wrapper").style.display="";a.getElementById("uglipop_overlay").style.display="";a.getElementById("uglipop_content_fixed").style.display=""}function h(){a.getElementById("uglipop_overlay_wrapper").style.display="none";a.getElementById("uglipop_overlay").style.display="none";a.getElementById("uglipop_content_fixed").style.display="none"}g(a,"DOMContentLoaded",function(){var b=a.createElement("div"),e=a.createElement("div"),c=a.createElement("div"),d=a.createElement("div");e.id="uglipop_content_fixed";e.setAttribute("style","position:fixed;top: 50%;left: 50%;transform: translate(-50%, -50%);-webkit-transform: translate(-50%, -50%);-ms-transform: translate(-50%, -50%);opacity:1;z-index:10000000;");c.id="uglipop_popbox";d.id="uglipop_overlay_wrapper";d.setAttribute("style","position:absolute;top:0;bottom:0;left:0;right:0;display:none");b.id="uglipop_overlay";b.setAttribute("style","position:fixed;top:0;bottom:0;left:0;right:0;opacity:0.3;width:100%;height:100%;background-color:black;");d.appendChild(b);e.appendChild(c);a.body.appendChild(d);a.body.appendChild(e);a.getElementById("uglipop_overlay_wrapper").style.display="none";a.getElementById("uglipop_overlay").style.display="none";a.getElementById("uglipop_content_fixed").style.display="none";d.addEventListener("click",h);g(f,"keydown",function(a){27==a.keyCode&&h()});f.uglipop=k})})(window,document);var ezRBA=(function(){function init(){var reportAdsBtns=document.querySelectorAll('.ez-report-ad-button');for(var i=0;i<reportAdsBtns.length;i++){reportAdsBtns[i].addEventListener('click',function(e){var url='<iframe src="https://svc.ezoic.com/pub/reportads/reportads.html'+e.target.getAttribute('name')+'" width="400" height="500" style="border-radius: 10px; box-shadow: 2px 2px 30px 6px rgba(0,0,0,0.75); border: 1px solid black;"></iframe>'
uglipop({class:'none',source:'html',content:url,});});}
function bindEvent(element,eventName,eventHandler){if(element.addEventListener){element.addEventListener(eventName,eventHandler,false);}else if(element.attachEvent){element.attachEvent('on'+eventName,eventHandler);}}
bindEvent(window,'message',function(e){if(e.data==='close-report-ad-modal'){document.getElementById('uglipop_overlay_wrapper').style.display='none';document.getElementById('uglipop_overlay').style.display='none';document.getElementById('uglipop_content_fixed').style.display='none';}})}
return{init:init};})();ezRBA.init();</script>
<script type="text/javascript" data-cfasync="false"></script>
<script type="text/javascript" style='display:none;'>var __ez_dims = (function() {
		var setCookie = function( name, content, expiry ) {
			return document.cookie = name+'='+content+((expiry)?';expires='+(new Date(Math.floor(new Date().getTime()+expiry*1000)).toUTCString()):'')+';path=/';
		};
		var ffid = 1;
		var oh = window.screen.height;
		var ow = window.screen.width;
		var h = ffid === 1 ? oh : (oh > ow) ? oh : ow;
		var w = ffid === 1 ? ow : (oh > ow) ? ow : oh;
		var uh = window.innerHeight || document.documentElement.clientHeight || document.getElementsByTagName('body')[0].clientHeight;
		var uw = window.innerWidth || document.documentElement.clientWidth || document.getElementsByTagName('body')[0].clientWidth;
		setCookie('ezds', encodeURIComponent('ffid='+ffid+',w='+w+',h='+h), (31536e3*7));
		setCookie('ezohw', encodeURIComponent('w='+uw+',h='+uh), (31536e3*7));
	})();</script><script type='text/javascript' style='display:none;' async>
</script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6de337469c9981b8',m:'yU98ceMGiMBWYIDLGvQ_.u8A4RkV65.wjtL7OkE.xGg-1644977178-0-AeUP2YQsvnhbEj+dkJXw3eJMEdJ3hh5gt0kazg62bWxIBXKB75s554rD8GeCfr2Sh3nmiMs4ZULl7AV+MyTR/cVbLCfAdPXpMrOsGO0lR0nu5oyM4WnHSTrnmukrBx8Wag==',s:[0x39a62a719d,0xffe317d4d5],u:'/cdn-cgi/challenge-platform/h/b'}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"6de337469c9981b8","version":"2021.12.0","r":1,"token":"dbeedbcf02ac41dda836867ed5c5033a","si":100}' crossorigin="anonymous"></script>
</body></html><!--Cached using Nginx-Helper on 2022-02-15 14:47:17. It took 305 queries executed in 1.657 seconds.--><!--Visit http://wordpress.org/extend/plugins/nginx-helper/faq/ for more details-->