<!DOCTYPE html><html lang="en-US" prefix="og: https://ogp.me/ns#"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script>
<script>var __sellerid="16189183c417d6d7659948da9c312c5b";var __ez_nid ="1254144";</script>
<script>var ezasVars = {'cid':'','pid':''};</script>
<script>window.ezhbopt=true;</script>
<link rel='preload' as='script' href='//securepubads.g.doubleclick.net/tag/js/gpt.js'>
<link href="//ad.doubleclick.net" rel="dns-prefetch">
<link href="//pagead2.googlesyndication.com" rel="dns-prefetch">
<link href="//googleads.g.doubleclick.net" rel="dns-prefetch">
<link href="//tpc.googlesyndication.com" rel="dns-prefetch">
<link href="//adservice.google.com" rel="dns-prefetch">
<link href="//secureads.g.doubleclick.net" rel="dns-prefetch">
<link href="//www.googletagservices.com" rel="dns-prefetch">
<link rel='preload' as='script' href='//go.ezodn.com/hb/dall.js?b=amx,oftmedia,onemobile,onetag,pubmatic,pulsepoint,sharethrough&cb=195-0-28'>
<script type="text/javascript">
	var __banger_pmp_deals=function(){var d={17:{"DealId":17,"Floor":160},18:{"DealId":18,"Floor":25},19:{"DealId":19,"Floor":100},20:{"DealId":20,"Floor":300},601:{"DealId":601,"Floor":13},608:{"DealId":608,"Floor":213},619:{"DealId":619,"Floor":10},1428:{"DealId":1428,"Floor":25},7:{"DealId":7,"Floor":150},8:{"DealId":8,"Floor":200},9:{"DealId":9,"Floor":300},10:{"DealId":10,"Floor":400},11:{"DealId":11,"Floor":500},12:{"DealId":12,"Floor":600},13:{"DealId":13,"Floor":700},14:{"DealId":14,"Floor":800},916:{"DealId":916,"Floor":95},915:{"DealId":915,"Floor":150},874:{"DealId":874,"Floor":200},835:{"DealId":835,"Floor":200},15:{"DealId":15,"Floor":1000}};return[{"SlotName":"/1254144,22521319391/bytexd_com-mobile-leaderboard-2","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-box-2","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-large-leaderboard-2","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-leader-2","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-leader-3","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-large-mobile-banner-2","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-leader-4","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-mobile-leaderboard-1","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-box-3","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-medrectangle-2","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-banner-1","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-box-1","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[15],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-large-mobile-banner-1","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-large-leaderboard-1","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-leader-1","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]},{"SlotName":"/1254144,22521319391/bytexd_com-leader-1","Deals":[d[17],d[18],d[19],d[20],d[601],d[608],d[619],d[1428],d[7],d[8],d[9],d[10],d[11],d[12],d[13],d[14],d[916],d[915],d[874],d[835]]}]}();
</script>
<script type='text/javascript'>_ebcids=[138231308856,138231308940,138231308949,138231387842,138231421744,138231421759,138231421774,138231421783,138231421789,138231421792,138242067587,138242067590,138242067602,138242067605,138242067608,138242067614,138242229406,138242229415,138242229421,138242229430];</script>
<script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>ezobv=76;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>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</script><script type='text/javascript' data-ezscrex="false">var ezorbf = []; </script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.isEZABL=false;window.ezmadspc=300;window.ezoViewCheck=false;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.ezDisableInitialLoad=false;</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>window.googletag=window.googletag||{};googletag.cmd=googletag.cmd||[];</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>(function(){var gads=document.createElement('script');gads.async=true;gads.type='text/javascript';var useSSL='https:'==document.location.protocol;gads.src=(useSSL?'https:':'http:')+
'//securepubads.g.doubleclick.net/tag/js/gpt.js';var node=document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads,node);})();</script><script data-ezscrex="false" data-cfasync="false" data-pagespeed-no-defer type='text/javascript'>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</script>
<script type="text/javascript">(function(){function storageAvailable(type){var storage;try{storage=window[type];var x='__storage_test__';storage.setItem(x,x);storage.removeItem(x);return true;}
catch(e){return e instanceof DOMException&&(e.code===22||e.code===1014||e.name==='QuotaExceededError'||e.name==='NS_ERROR_DOM_QUOTA_REACHED')&&(storage&&storage.length!==0);}}
function remove_ama_config(){if(storageAvailable('localStorage')){localStorage.removeItem("google_ama_config");}}
remove_ama_config()})()</script>
<script type="text/javascript">var ezoicTestActive = true</script>
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">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</script><script data-ezscrex="false" data-pagespeed-no-defer data-cfasync="false" type="text/javascript">__ez.queue.addFile('banger.js', '/porpoiseant/banger.js?cb=195-0&bv=76&v=52&PageSpeed=off', true, [], true, false, false, true);</script>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.vep=(function(){var pixels=[],pxURL="/detroitchicago/grapefruit.gif";function AddPixel(vID,pixelData){if(__ez.dot.isDefined(vID)&&__ez.dot.isValid(pixelData)){pixels.push({type:'video',video_impression_id:vID,domain_id:__ez.dot.getDID(),t_epoch:__ez.dot.getEpoch(0),data:__ez.dot.dataToStr(pixelData)});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender"){return;}
if(__ez.dot.isDefined(pixels)&&pixels.length>0){while(pixels.length>0){var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(__ez.template.isOrig===true?1:0)+"&v="+btoa(JSON.stringify(pushPixels));__ez.dot.Fire(pixelURL);}}
pixels=[];}
return{Add:AddPixel,Fire:Fire};})();</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();</script>
	
	<meta name="viewport" content="width=device-width, initial-scale=1"/>
	<link rel="profile" href="https://gmpg.org/xfn/11"/>
	
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer="" type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="RXkib4zQQ3OMs4BhnpM0zLxzD_1u4PlHktSsr5hfm7g"/>

<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>Introduction to Ngrok: A Tutorial for Beginners - ByteXD</title>
<meta name="description" content="If you are into web development, at times, you might have wondered how people on a different network can access your locally hosted website. Say you are"/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://bytexd.com/ngrok-tutorial-for-beginners/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Introduction to Ngrok: A Tutorial for Beginners - ByteXD"/>
<meta property="og:description" content="If you are into web development, at times, you might have wondered how people on a different network can access your locally hosted website. Say you are"/>
<meta property="og:url" content="https://bytexd.com/ngrok-tutorial-for-beginners/"/>
<meta property="og:site_name" content="ByteXD"/>
<meta property="article:publisher" content="https://www.facebook.com/ByteXD/"/>
<meta property="article:section" content="Miscellaneous"/>
<meta property="og:updated_time" content="2021-09-22T11:58:52+00:00"/>
<meta property="og:image" content="https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-e1632075597504.jpg"/>
<meta property="og:image:secure_url" content="https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-e1632075597504.jpg"/>
<meta property="og:image:width" content="1000"/>
<meta property="og:image:height" content="563"/>
<meta property="og:image:alt" content="Introduction to Ngrok A Tutorial for Beginners"/>
<meta property="og:image:type" content="image/jpeg"/>
<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:title" content="Introduction to Ngrok: A Tutorial for Beginners - ByteXD"/>
<meta name="twitter:description" content="If you are into web development, at times, you might have wondered how people on a different network can access your locally hosted website. Say you are"/>
<meta name="twitter:site" content="@ByteXD"/>
<meta name="twitter:creator" content="@shwayguy"/>
<meta name="twitter:image" content="https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-e1632075597504.jpg"/>
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["Organization"],"@id":"https://bytexd.com/#organization","name":"ByteXD","url":"https://bytexd.com","logo":{"@type":"ImageObject","@id":"https://bytexd.com/#logo","url":"https://bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-Main.png","caption":"ByteXD","inLanguage":"en-US","width":"214","height":"72"},"openingHours":["Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday 09:00-17:00"]},{"@type":"WebSite","@id":"https://bytexd.com/#website","url":"https://bytexd.com","name":"ByteXD","publisher":{"@id":"https://bytexd.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-e1632075597504.jpg","url":"https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-e1632075597504.jpg","width":"1000","height":"563","caption":"Introduction to Ngrok A Tutorial for Beginners","inLanguage":"en-US"},{"@type":"Person","@id":"https://bytexd.com/author/edxd/","name":"EdXD","url":"https://bytexd.com/author/edxd/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/908729a6f7effb4a6f8c5b48c6855cd2?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/908729a6f7effb4a6f8c5b48c6855cd2?s=96&amp;d=mm&amp;r=g","caption":"EdXD","inLanguage":"en-US"},"sameAs":["https://twitter.com/https://twitter.com/shwayguy"],"worksFor":{"@id":"https://bytexd.com/#organization"}},{"@type":"WebPage","@id":"https://bytexd.com/ngrok-tutorial-for-beginners/#webpage","url":"https://bytexd.com/ngrok-tutorial-for-beginners/","name":"Introduction to Ngrok: A Tutorial for Beginners - ByteXD","datePublished":"2021-09-19T02:40:48+00:00","dateModified":"2021-09-22T11:58:52+00:00","author":{"@id":"https://bytexd.com/author/edxd/"},"isPartOf":{"@id":"https://bytexd.com/#website"},"primaryImageOfPage":{"@id":"https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-e1632075597504.jpg"},"inLanguage":"en-US"},{"@type":"BlogPosting","headline":"Introduction to Ngrok: A Tutorial for Beginners - ByteXD","datePublished":"2021-09-19T02:40:48+00:00","dateModified":"2021-09-22T11:58:52+00:00","author":{"@id":"https://bytexd.com/author/edxd/"},"publisher":{"@id":"https://bytexd.com/#organization"},"description":"If you are into web development, at times, you might have wondered how people on a different network can access your locally hosted website. Say you are","name":"Introduction to Ngrok: A Tutorial for Beginners - ByteXD","@id":"https://bytexd.com/ngrok-tutorial-for-beginners/#richSnippet","isPartOf":{"@id":"https://bytexd.com/ngrok-tutorial-for-beginners/#webpage"},"image":{"@id":"https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-e1632075597504.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://bytexd.com/ngrok-tutorial-for-beginners/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel="dns-prefetch" href="//s.w.org"/>
<link rel="alternate" type="application/rss+xml" title="ByteXD » Feed" href="https://bytexd.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="ByteXD » Comments Feed" href="https://bytexd.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="ByteXD » Introduction to Ngrok: A Tutorial for Beginners Comments Feed" href="https://bytexd.com/ngrok-tutorial-for-beginners/feed/"/>
			<link rel="preload" href="https://bytexd.com/wp-content/plugins/powerkit/assets/fonts/powerkit-icons.woff" as="font" type="font/woff" crossorigin=""/>
					<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/bytexd.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel="stylesheet" id="powerkit-css" href="https://bytexd.com/wp-content/plugins/powerkit/assets/css/powerkit.css?ver=2.5.7" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-block-library-css" href="https://bytexd.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1" type="text/css" media="all"/>
<style id="wp-block-library-inline-css" type="text/css">
.has-text-align-justify{text-align:justify;}
</style>
<link rel="stylesheet" id="mediaelement-css" href="https://bytexd.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16" type="text/css" media="all"/>
<link rel="stylesheet" id="wp-mediaelement-css" href="https://bytexd.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.8.1" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-author-box-css" href="https://bytexd.com/wp-content/plugins/powerkit/modules/author-box/public/css/public-powerkit-author-box.css?ver=2.5.7" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-basic-elements-css" href="https://bytexd.com/wp-content/plugins/powerkit/modules/basic-elements/public/css/public-powerkit-basic-elements.css?ver=2.5.7" type="text/css" media="screen"/>
<link rel="stylesheet" id="powerkit-content-formatting-css" href="https://bytexd.com/wp-content/plugins/powerkit/modules/content-formatting/public/css/public-powerkit-content-formatting.css?ver=2.5.7" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-lightbox-css" href="https://bytexd.com/wp-content/plugins/powerkit/modules/lightbox/public/css/public-powerkit-lightbox.css?ver=2.5.7" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-share-buttons-css" href="https://bytexd.com/wp-content/plugins/powerkit/modules/share-buttons/public/css/public-powerkit-share-buttons.css?ver=2.5.7" type="text/css" media="all"/>
<link rel="stylesheet" id="powerkit-table-of-contents-css" href="https://bytexd.com/wp-content/plugins/powerkit/modules/table-of-contents/public/css/public-powerkit-table-of-contents.css?ver=2.5.7" type="text/css" media="all"/>
<link rel="stylesheet" id="wpel-style-css" href="https://bytexd.com/wp-content/plugins/wp-external-links/public/css/wpel.css?ver=2.50" type="text/css" media="all"/>
<link rel="stylesheet" id="wpdiscuz-frontend-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/themes/default/style.css?ver=7.3.2" type="text/css" media="all"/>
<style id="wpdiscuz-frontend-css-inline-css" type="text/css">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</style>
<link rel="stylesheet" id="wpdiscuz-fa-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/font-awesome-5.13.0/css/fa.min.css?ver=7.3.2" type="text/css" media="all"/>
<link rel="stylesheet" id="quill-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/quill/quill.snow.min.css?ver=1.3.6" type="text/css" media="all"/>
<link rel="stylesheet" id="wmu-colorbox-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/colorbox/colorbox.min.css?ver=5.8.1" type="text/css" media="all"/>
<link rel="stylesheet" id="wpdiscuz-mu-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-mu-frontend.min.css?ver=5.8.1" type="text/css" media="all"/>
<link rel="stylesheet" id="wpdiscuz-user-content-css-css" href="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-user-content.min.css?ver=7.3.2" type="text/css" media="all"/>
<link rel="stylesheet" id="csco-styles-css" href="https://bytexd.com/wp-content/themes/squaretype/style.css?ver=2.0.3" type="text/css" media="all"/>
<style id="csco-styles-inline-css" type="text/css">
.searchwp-live-search-no-min-chars:after { content: "Continue typing" }
</style>
<link rel="stylesheet" id="searchwp-live-search-css" href="https://bytexd.com/wp-content/plugins/searchwp-live-ajax-search/assets/styles/style.css?ver=1.6.1" type="text/css" media="all"/>
<link rel="stylesheet" id="csco_child_css-css" href="https://bytexd.com/wp-content/themes/squaretype-child/style.css?ver=1.0.0" type="text/css" media="all"/>
<link rel="stylesheet" id="jetpack_css-css" href="https://bytexd.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.1" type="text/css" media="all"/>
<script type="text/javascript" id="jquery-core-js-extra">
/* <![CDATA[ */
var csco_mega_menu = {"rest_url":"https:\/\/bytexd.com\/wp-json\/csco\/v1\/menu-posts"};
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0" id="jquery-core-js"></script>
<script type="text/javascript" id="jquery-migrate-js" data-type="lazy" data-src="https://bytexd.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2"></script>
<link rel="https://api.w.org/" href="https://bytexd.com/wp-json/"/><link rel="alternate" type="application/json" href="https://bytexd.com/wp-json/wp/v2/posts/5339"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bytexd.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://bytexd.com/wp-includes/wlwmanifest.xml"/> 
<meta name="generator" content="WordPress 5.8.1"/>
<link rel="shortlink" href="https://bytexd.com/?p=5339"/>
<link rel="alternate" type="application/json+oembed" href="https://bytexd.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbytexd.com%2Fngrok-tutorial-for-beginners%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://bytexd.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbytexd.com%2Fngrok-tutorial-for-beginners%2F&amp;format=xml"/>

<link rel="dns-prefetch" href="https://cdn.statically.io/"/>
<link rel="preconnect" href="https://cdn.statically.io/" crossorigin=""/>
        <style>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</style>

<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer="" type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["miscellaneous","website-setup"],"pagePostAuthor":"EdXD"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KX8VTB3');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><style type="text/css">img#wpstats{display:none}</style>
		<link rel="icon" href="https://bytexd.com/wp-content/uploads/2020/06/cropped-ByteXD-Logo-_-Icon-2-32x32.png" sizes="32x32"/>
<link rel="icon" href="https://bytexd.com/wp-content/uploads/2020/06/cropped-ByteXD-Logo-_-Icon-2-192x192.png" sizes="192x192"/>
<link rel="apple-touch-icon" href="https://bytexd.com/wp-content/uploads/2020/06/cropped-ByteXD-Logo-_-Icon-2-180x180.png"/>
<meta name="msapplication-TileImage" content="https://bytexd.com/wp-content/uploads/2020/06/cropped-ByteXD-Logo-_-Icon-2-270x270.png"/>
<style id="kirki-inline-styles">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</style><style>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</style><script type="text/javascript">var ezouid = "1";</script><base href="https://bytexd.com/ngrok-tutorial-for-beginners/"><script type='text/javascript'>
var ezoTemplate = 'pub_site';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 283186;
var ezdomain = 'bytexd.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex='false' data-cfasync='false' type='text/javascript' style='display:none' defer>
__ez.queue.addFile('__ezf_ezosuigeneris', '//g.ezoic.net/ezosuigeneris.js', true, [], true, false, false, false);
var __ez_ezosuigenerisEvt = function() { if(typeof(ezosuigeneris) != 'undefined'){__ez.bit.AddAndFire(_ezaq['page_view_id'], [(new __ezDotData('universal_user_id', ezosuigeneris))]); }};
__ez.queue.addFunc('__ez_ezosuigenerisEvt', '__ez_ezosuigenerisEvt', null, false, ['__ezf_ezosuigeneris','/detroitchicago/minneapolis.js','/detroitchicago/memphis.js'], false, false, false, false);</script><script data-ezscrex='false' data-cfasync='false' type='text/javascript' style='display:none' defer>__ez.queue.addFile('__ezf_ezosuigenerisc', '//g.ezoic.net/ezosuigenerisc.js?nogen=1', true, ["/detroitchicago/boise.js"], true, false, false, false);</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_283186=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["ba929e66-cfbf-427d-57cc-eeea1d66d311", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script>
<script type="text/javascript">var _audins_dom="bytexd_com",_audins_did=283186;__ez.queue.addFile('/detroitchicago/cmbv2.js', '/detroitchicago/cmbv2.js?gcb=195-0&cb=04-1y02-4y06-12y07-1y0b-5y0d-14y13-3y17-4y1f-3y32-22y51-1y55-21&cmbcb=20&sj=x04x02x06x07x0bx0dx13x17x1fx32x51x55', true, [], true, false, true, false);</script>
<script type="text/javascript" defer>__ez.queue.addFile('/detroitchicago/cmbdv2.js', '/detroitchicago/cmbdv2.js?gcb=195-0&cb=03-4y0c-5y18-4y33-22y56-21&cmbcb=20&sj=x03x0cx18x33x56', true, ['/detroitchicago/cmbv2.js'], true, false, true, false);</script></head>

<body class="post-template-default single single-post postid-5339 single-format-standard wp-embed-responsive cs-page-layout-right header-compact navbar-width-fullwidth navbar-alignment-left navbar-sticky-enabled navbar-smart-enabled sticky-sidebar-enabled stick-to-bottom block-align-enabled">

	<div class="site-overlay"></div>

	<div class="offcanvas">

		<div class="offcanvas-header">

			
			<nav class="navbar navbar-offcanvas">

									<a class="navbar-brand" href="https://bytexd.com/" rel="home" data-wpel-link="internal">
						<img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="ByteXD" sizes="(max-width: 214px) 100vw, 214px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?w=214&amp;quality=100&amp;f=auto 214w,"/>					</a>
					
				<button type="button" class="toggle-offcanvas">
					<i class="cs-icon cs-icon-x"></i>
				</button>

			</nav>

			
		</div>

		<aside class="offcanvas-sidebar">
			<div class="offcanvas-inner widget-area">
				<div class="widget widget_nav_menu cs-d-lg-none"><div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-2624" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2624"><a href="#">Linux Tutorials</a>
<ul class="sub-menu">
	<li id="menu-item-5238" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5238"><a href="https://bytexd.com/category/linux-commands/" data-wpel-link="internal">Linux Commands</a></li>
	<li id="menu-item-2617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2617"><a href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal">Ubuntu</a></li>
	<li id="menu-item-2618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2618"><a href="https://bytexd.com/category/centos/" data-wpel-link="internal">CentOS</a></li>
	<li id="menu-item-5237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5237"><a href="https://bytexd.com/category/debian/" data-wpel-link="internal">Debian</a></li>
</ul>
</li>
<li id="menu-item-2625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2625"><a href="#">General Tutorials</a>
<ul class="sub-menu">
	<li id="menu-item-2620" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2620"><a href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal">Miscellaneous</a></li>
	<li id="menu-item-2621" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2621"><a href="https://bytexd.com/category/digital-marketing/" data-wpel-link="internal">Digital Marketing</a></li>
	<li id="menu-item-2622" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2622"><a href="https://bytexd.com/category/website-setup/" data-wpel-link="internal">Website Setup</a></li>
</ul>
</li>
</ul></div></div>
							</div>
		</aside>
	</div>

<div id="page" class="site">

	
	<div class="site-inner">

		
		<header id="masthead" class="site-header">
			


<nav class="navbar navbar-primary navbar-shadow-enabled">

	
	<div class="navbar-wrap">

		<div class="navbar-container">

			<div class="navbar-content">

				<div class="navbar-col">
							<button type="button" class="navbar-toggle-offcanvas toggle-offcanvas  cs-d-lg-none">
			<i class="cs-icon cs-icon-menu"></i>
		</button>
				<div class="navbar-brand">
							<a href="https://bytexd.com/" rel="home" data-wpel-link="internal">
					<img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="ByteXD" sizes="(max-width: 214px) 100vw, 214px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?w=214&amp;quality=100&amp;f=auto 214w,"/>				</a>
						</div>
		<ul id="menu-primary-1" class="navbar-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2624"><a href="#"><span>Linux Tutorials</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5238"><a href="https://bytexd.com/category/linux-commands/" data-wpel-link="internal">Linux Commands</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2617"><a href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal">Ubuntu</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2618"><a href="https://bytexd.com/category/centos/" data-wpel-link="internal">CentOS</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5237"><a href="https://bytexd.com/category/debian/" data-wpel-link="internal">Debian</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2625"><a href="#"><span>General Tutorials</span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2620"><a href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal">Miscellaneous</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2621"><a href="https://bytexd.com/category/digital-marketing/" data-wpel-link="internal">Digital Marketing</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2622"><a href="https://bytexd.com/category/website-setup/" data-wpel-link="internal">Website Setup</a></li>
</ul>
</li>
</ul>				</div>

				<div class="navbar-col">
									</div>

				<div class="navbar-col">
							<div class="navbar-social-links">
				<div class="pk-social-links-wrap  pk-social-links-template-nav pk-social-links-align-default pk-social-links-scheme-light pk-social-links-titles-disabled pk-social-links-counts-disabled pk-social-links-labels-disabled">
		<div class="pk-social-links-items">
								<div class="pk-social-links-item pk-social-links-facebook  pk-social-links-no-count" data-id="facebook">
						<a href="https://facebook.com/ByteXD" class="pk-social-links-link" target="_blank" rel="nofollow noopener" aria-label="Facebook" data-wpel-link="exclude">
							<i class="pk-social-links-icon pk-icon pk-icon-facebook"></i>
							
							
							
													</a>
					</div>
										<div class="pk-social-links-item pk-social-links-twitter  pk-social-links-no-count" data-id="twitter">
						<a href="https://twitter.com/ByteXD" class="pk-social-links-link" target="_blank" rel="nofollow noopener" aria-label="Twitter" data-wpel-link="exclude">
							<i class="pk-social-links-icon pk-icon pk-icon-twitter"></i>
							
							
							
													</a>
					</div>
										<div class="pk-social-links-item pk-social-links-mastodon  pk-social-links-no-count" data-id="mastodon">
						<a href="https://mastodon.online/@bytexd" class="pk-social-links-link" target="_blank" rel="nofollow noopener" aria-label="Mastodon" data-wpel-link="exclude">
							<i class="pk-social-links-icon pk-icon pk-icon-mastodon"></i>
							
							
							
													</a>
					</div>
							</div>
	</div>
			</div>
					<div class="navbar-follow navbar-follow-button">
				<a class="button navbar-follow-btn" href="https://www.instagram.com/byte.xd/" target="_blank" data-wpel-link="exclude">
					Follow <i class="pk-icon pk-icon-instagram"></i>				</a>
			</div>
					<button type="button" class="navbar-toggle-search toggle-search">
			<i class="cs-icon cs-icon-search"></i>
		</button>
						</div>

			</div><!-- .navbar-content -->

		</div><!-- .navbar-container -->

	</div><!-- .navbar-wrap -->

	
<div class="site-search-wrap" id="search">
	<div class="site-search">
		<div class="cs-container">
			<div class="search-form-wrap">
				
<form role="search" method="get" class="search-form" action="https://bytexd.com/">
	<label class="sr-only">Search for:</label>
	<div class="cs-input-group">
		<input type="search" value="" name="s" data-swplive="true" data-swpengine="default" data-swpconfig="default" class="search-field" placeholder="Enter your search topic" required=""/>
		<button type="submit" class="search-submit">Search</button>
	</div>
</form>
				<span class="search-close"></span>
			</div>
		</div>
	</div>
</div>

</nav><!-- .navbar -->
		<span id="ezoic-pub-ad-placeholder-123" class="ezoic-adpicker-ad"></span><span class="ezoic-ad box-2 box-2123 adtester-container adtester-container-123" data-ez-name="bytexd_com-box-2"><span id="div-gpt-ad-bytexd_com-box-2-0" ezaw="970" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:90px;min-width:970px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-box-2-0')};</script></span></span></header><!-- #masthead -->

		
		<div class="site-primary">

			
			<div class="site-content sidebar-enabled sidebar-right post-sidebar-enabled">

				
				<div class="cs-container">

					
					<div id="content" class="main-content">

						
	<div id="primary" class="content-area">

		
		<main id="main" class="site-main"><span id="ezoic-pub-ad-placeholder-124" class="ezoic-adpicker-ad"></span>

			
			
				
					
<article class="entry-preview entry post-5339 post type-post status-publish format-standard has-post-thumbnail category-miscellaneous category-website-setup">

	
	<!-- Full Post Layout -->
	
	
<section class="entry-header entry-header-standard entry-header-thumbnail">

	<div class="entry-header-inner">

		
		
					<div class="entry-inline-meta">
				<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal"><span style="background:#1B1B3A" class="char cs-bg-dark">M</span><span class="label">Miscellaneous</span></a></div>			</div>
		
					<h1 class="entry-title">Introduction to Ngrok: A Tutorial for Beginners</h1>		
		<ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">September 19, 2021</li><li class="meta-comments"><i class="cs-icon cs-icon-message-square"></i><a href="https://bytexd.com/ngrok-tutorial-for-beginners/#comments" class="comments-link" data-wpel-link="internal">One comment</a></li><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>6 minute read</li></ul>
					<div class="post-media">
				<figure>
					<a href="https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-e1632075597504.jpg" data-wpel-link="internal">
						<img width="800" height="500" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="pk-lazyload-disabled wp-post-image" alt="Introduction to Ngrok A Tutorial for Beginners" title="Introduction to Ngrok: A Tutorial for Beginners 1" sizes="(max-width: 800px) 100vw, 800px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-800x500.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-800x500.jpg?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-800x500.jpg?w=800&amp;quality=100&amp;f=auto 800w,"/>					</a>
									</figure>
			</div>
			
		
	</div>

</section><span id="ezoic-pub-ad-placeholder-108" class="ezoic-adpicker-ad"></span><span class="ezoic-ad box-3 box-3108 adtester-container adtester-container-108" data-ez-name="bytexd_com-box-3"><span id="div-gpt-ad-bytexd_com-box-3-0" ezaw="728" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:90px;min-width:728px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-box-3-0')};</script></span></span>
			<div class="entry-container">
											<div class="entry-sidebar-wrap">
								<div class="entry-sidebar">
									<div class="post-sidebar-shares">
										<div class="post-sidebar-inner">
													<div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-default pk-share-buttons-has-counts pk-share-buttons-has-total-counts pk-share-buttons-post_sidebar pk-share-buttons-mode-php pk-share-buttons-mode-rest" data-post-id="5339" data-share-url="https://bytexd.com/ngrok-tutorial-for-beginners/">

							<div class="pk-share-buttons-total">
							<div class="pk-share-buttons-caption">
			<div class="pk-share-buttons-count cs-font-primary"> 3</div>
			<div class="pk-share-buttons-label cs-font-secondary">Shares</div>
		</div>
						</div>
				
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">3</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=Introduction%20to%20Ngrok%3A%20A%20Tutorial%20for%20Beginners&amp;via=ByteXD&amp;url=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/ngrok-tutorial-for-beginners/&amp;media=https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-1024x576.jpg" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-mail pk-share-buttons-no-count" data-id="mail">

							<a href="/cdn-cgi/l/email-protection#96a9e5e3f4fcf3f5e2abdff8e2e4f9f2e3f5e2fff9f8b3a4a6e2f9b3a4a6d8f1e4f9fdb3a5d7b3a4a6d7b3a4a6c2e3e2f9e4fff7fab3a4a6f0f9e4b3a4a6d4f3f1fff8f8f3e4e5b0f7fbe6adf4f9f2efabdff8e2e4f9f2e3f5e2fff9f8b3a4a6e2f9b3a4a6d8f1e4f9fdb3a5d7b3a4a6d7b3a4a6c2e3e2f9e4fff7fab3a4a6f0f9e4b3a4a6d4f3f1fff8f8f3e4e5b3a4a6fee2e2e6e5acb9b9f4efe2f3eef2b8f5f9fbb9f8f1e4f9fdbbe2e3e2f9e4fff7fabbf0f9e4bbf4f3f1fff8f8f3e4e5b9" class="pk-share-buttons-link" target="_blank">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-mail"></i>
								
								
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
											</div>
									</div>
								</div>
							</div>
						
	<!-- Full Post Layout and Full Content -->
	<div class="entry-content-wrap">

		
		<div class="entry-content">

			<p>If you are into web development, at times, you might have wondered how people on a different network can access your locally hosted website. Say you are developing a website for a client on your PC, and you want them to view it and track the progress without you having to host it online. If so, Ngrok is the perfect solution for you to do that.</p>
<p>Ngrok is a dev tool to that allows you to expose a server running on your local machine to the internet. In this tutorial we’ll go through how to use the Ngrok utility from installation to deploying an HTML or a React JS website, on a Linux machine.</p>
			<div class="pk-toc">
									<h5 class="pk-title pk-toc-title pk-font-block">
						Table of Contents
											</h5>
				
				<ol><li><a href="#what-is-a-ngrok">What is a Ngrok?</a></li><li><a href="#why-use-ngrok">Why Use Ngrok</a><ol><li><a href="#validating-webhooks">Validating webhooks</a></li><li><a href="#demo-showcase-of-an-application-to-a-client">Demo/ showcase of an application to a client.</a></li><li><a href="#web-testing-where-all-browsers-are-not-locally-available">Web testing where all browsers are not locally available.</a></li></ol></li><li><a href="#how-to-install-ngrok">How to Install Ngrok</a></li><li><a href="#how-to-use-ngrok">How to use Ngrok</a><ol><li><a href="#1-host-a-react-app-with-ngrok">1. Host a React App With Ngrok</a></li><li><a href="#2-host-html-file-with-ngrok">2. Host HTML file with ngrok</a><ol><li><a href="#using-the-ngrok-bult-in-fileserver">Using the Ngrok Bult-in Fileserver</a></li><li><a href="#using-a-simple-python-server">Using a Simple Python Server</a></li></ol></li></ol></li><li><a href="#conclusion">Conclusion</a></li></ol>			</div><span id="ezoic-pub-ad-placeholder-104" class="ezoic-adpicker-ad"></span><span class="ezoic-ad banner-1 banner-1104 adtester-container adtester-container-104" data-ez-name="bytexd_com-banner-1"><span id="div-gpt-ad-bytexd_com-banner-1-0" ezaw="728" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:90px;min-width:728px;" class="ezoic-ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-banner-1-0')};</script></span></span>
		
<h2 id="what-is-a-ngrok">What is a Ngrok?</h2>
<p><strong>Ngrok </strong>is a powerful utility that allows users to locally share or access any locally hosted web application(s) through a publicly accessible web URL. This public URL is then exposed to the Ngrok.io domain and then tunnels the traffic that arrives at that endpoint through a specified localhost port.</p>
<p>Ngrok is available for Windows, macOS, Linux, and FreeBSD operating systems. Ngrok is available for free use, with limited features, and a paid account with enhanced features such as subdomains, whitelisting, support, etc. To sign-up, you can use an email or GitHub / Gmail account.</p>
<p>However, the free account is sufficient for practicals. In our case, we are going to use a free account.</p>
<h2 id="why-use-ngrok">Why Use Ngrok</h2>
<h3 id="validating-webhooks">Validating webhooks</h3>
<p>Let’s take a case where there has been an integration of a different system, and one of the systems relies on the external system to notify about a particular action. To validate whether this service has been completed successfully, it requires one to provoke the application to access a publicly accessible URL; This can be achieved using Ngrok.<span id="ezoic-pub-ad-placeholder-117" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-leaderboard-2 large-leaderboard-2117 adtester-container adtester-container-117" data-ez-name="bytexd_com-large-leaderboard-2"><span id="div-gpt-ad-bytexd_com-large-leaderboard-2-0" ezaw="336" ezah="280" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:280px;min-width:336px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-large-leaderboard-2-0')};</script></span></span></p>
<h3 id="demo-showcase-of-an-application-to-a-client">Demo/ showcase of an application to a client.</h3>
<p>Another important aspect where Ngrok can be helpful is in showcasing or demonstrating a locally hosted application to a client. Sometimes as a developer(s), you might want to present your web application to your end-users or client (s); to achieve this, you can generate a publicly accessible URL with the aid of Ngrok and then share it.</p>
<h3 id="web-testing-where-all-browsers-are-not-locally-available">Web testing where all browsers are not locally available.</h3>
<p>As a developer, sometimes, you might want to test your web application on a different browser. Let’s take the case of a web developer who has been developing a website in either mac and wants to test the application in the Internet Explorer browser. That can be achieved by using Ngrok through the generation of a public URL and sharing it.</p>
<h2 id="how-to-install-ngrok">How to Install Ngrok</h2>
<p>To install Ngrok, first, you will have to <a href="https://dashboard.ngrok.com/signup" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">create a Ngrok account<span class="wpel-icon wpel-image wpel-icon-7"></span></a> to get an authentication token (auth token) for your account. The auth token will enable you to start the tunnel for locally hosted applications.</p>
<p>Next, <a href="https://ngrok.com/download" rel="noopener external" data-wpel-link="external" target="_blank" class="wpel-icon-right">download the Ngrok package<span class="wpel-icon wpel-image wpel-icon-7"></span></a> library depending on your operating system. In our case, we will download Ngrok for Linux, in this case, since I’m using Ubuntu 20.04.<span id="ezoic-pub-ad-placeholder-125" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-1 leader-1125 adtester-container adtester-container-125 ezoic-ad-adaptive" data-ez-name="bytexd_com-leader-1"><span class="ezoic-ad leader-1 leader-1-multi-125 adtester-container adtester-container-125" data-ez-name="bytexd_com-leader-1"><span id="div-gpt-ad-bytexd_com-leader-1-0" ezaw="290" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:290px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-1-0')};</script></span></span><span class="ezoic-ad leader-1 leader-1-multi-125 adtester-container adtester-container-125" data-ez-name="bytexd_com-leader-1"><span id="div-gpt-ad-bytexd_com-leader-1-0_1" ezaw="290" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:250px;min-width:290px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-1-0_1')};</script></span></span><style> .leader-1-multi-125{border:none !important;display:block !important;float:none;line-height:0px;margin-bottom:15px !important;margin-left:0px !important;margin-right:0px !important;margin-top:15px !important;min-height:250px;min-width:250px;padding:0;text-align:center !important;}</style></span></p>
<p><img width="1134" height="720" class="wp-image-5340" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 1134px) 100vw, 1134px" alt="word image 20" title="Introduction to Ngrok: A Tutorial for Beginners 19" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-20.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-20.png?quality=100&amp;f=auto 1134w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-20-300x190.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-20-1024x650.png?quality=100&amp;f=auto 1024w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-20-768x488.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-20-380x241.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-20-800x508.png?quality=100&amp;f=auto 800w,"/></p>
<p>The file is downloaded as a zipped file. Next we’ll navigate to the directory where it was downloaded, and extract it:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">sudo unzip ngrok-stable-linux-amd64.zip</pre>
<p><img width="737" height="488" class="wp-image-5341" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 737px) 100vw, 737px" alt="word image 21" title="Introduction to Ngrok: A Tutorial for Beginners 20" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-21.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-21.png?quality=100&amp;f=auto 737w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-21-300x199.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-21-380x252.png?quality=100&amp;f=auto 380w,"/></p>
<p>When you run the <strong>ls</strong> command, you should see an executable file with the name <strong>ngrok</strong>.</p>
<p>Next we’ll need to connect our account. For this we’ll need our unique authentication token, which can be found in the Ngrok website dashboard, under Getting Started &gt; Setup &amp; Installation, and then at <strong>2. Connect your account</strong>.</p>
<p>Next we’ll run the following command, which you can also see is displayed in the official Ngrok tutorial, using our own authentication token. In my case, I’ll run:<span id="ezoic-pub-ad-placeholder-126" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-2 leader-2126 adtester-container adtester-container-126" data-ez-name="bytexd_com-leader-2"><span id="div-gpt-ad-bytexd_com-leader-2-0" ezaw="580" ezah="400" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-2-0')};</script></span></span></p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">./ngrok authtoken 1pxC7zO80wPh6x48MPrq3QQxWlb_whZvhLEUE7MKhFrKF9yM</pre>
<p><img width="735" height="489" class="wp-image-5342" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 735px) 100vw, 735px" alt="word image 22" title="Introduction to Ngrok: A Tutorial for Beginners 21" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-22.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-22.png?quality=100&amp;f=auto 735w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-22-300x200.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-22-380x253.png?quality=100&amp;f=auto 380w,"/></p>
<p>If your auth token update is completed successfully, you could now start a tunnel for your locally hosted applications.</p>
<h2 id="how-to-use-ngrok"><span id="ezoic-pub-ad-placeholder-105" class="ezoic-adpicker-ad"></span><span class="ezoic-ad mobile-leaderboard-2 mobile-leaderboard-2105 adtester-container adtester-container-105" data-ez-name="bytexd_com-mobile-leaderboard-2"><span id="div-gpt-ad-bytexd_com-mobile-leaderboard-2-0" ezaw="468" ezah="60" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:60px;min-width:468px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-mobile-leaderboard-2-0')};</script></span></span>How to use Ngrok</h2>
<p>To fire up Ngrok, run the following command in the terminal or command prompt.</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">./ngrok help</pre>
<p><img width="735" height="488" class="wp-image-5343" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 735px) 100vw, 735px" alt="word image 23" title="Introduction to Ngrok: A Tutorial for Beginners 22" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-23.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-23.png?quality=100&amp;f=auto 735w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-23-300x199.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-23-380x252.png?quality=100&amp;f=auto 380w,"/></p>
<p>To start an HTTP tunnel forwarding on your local port like port 80, run the command below:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">./ngrok http 80</pre>
<p><img width="737" height="488" class="wp-image-5344" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 737px) 100vw, 737px" alt="word image 24" title="Introduction to Ngrok: A Tutorial for Beginners 23" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-24.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-24.png?quality=100&amp;f=auto 737w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-24-300x199.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-24-380x252.png?quality=100&amp;f=auto 380w,"/></p>
<p>Let’s look at two practical examples:</p>
<ul>
<li>Host a React application with Ngrok</li>
<li>Host a basic HTML file with Ngrok</li>
</ul>
<h3 id="1-host-a-react-app-with-ngrok">1. Host a React App With Ngrok</h3>
<p>React JS is a free and open-source front-end Javascript library developed and maintained by Facebook. To get started, install nodejs and npm by executing the commands below on the Terminal.</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">sudo apt install nodejs
sudo apt install npm</pre>
<p>Once done, proceed to create your first React JS app with the command below:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">npx create-react-app {your_app_name}</pre>
<p>In my case I’ll run:</p><span id="ezoic-pub-ad-placeholder-107" class="ezoic-adpicker-ad"></span><span class="ezoic-ad mobile-leaderboard-1 mobile-leaderboard-1107 adtester-container adtester-container-107" data-ez-name="bytexd_com-mobile-leaderboard-1"><span id="div-gpt-ad-bytexd_com-mobile-leaderboard-1-0" ezaw="250" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:250px;min-width:250px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-mobile-leaderboard-1-0')};</script></span></span>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">npx create-react-app ngrok_test_app</pre>
<p><img width="735" height="489" class="wp-image-5345" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 735px) 100vw, 735px" alt="word image 25" title="Introduction to Ngrok: A Tutorial for Beginners 24" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-25.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-25.png?quality=100&amp;f=auto 735w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-25-300x200.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-25-380x253.png?quality=100&amp;f=auto 380w,"/></p>
<p>Navigate to the newly created React app directory using the cd command and execute the command below:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">npm start</pre>
<p>That will start your react app on the URL <code data-enlighter-language="raw" class="EnlighterJSRAW">localhost:3000</code>, as shown below.</p>
<p><img width="735" height="254" class="wp-image-5346 alignnone" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 735px) 100vw, 735px" alt="word image 26" title="Introduction to Ngrok: A Tutorial for Beginners 25" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-26.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-26.png?quality=100&amp;f=auto 735w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-26-300x104.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-26-380x131.png?quality=100&amp;f=auto 380w,"/></p>
<p>By typing the URL on the browser, you can see the default React app. It is simply a rotating logo and a welcome message.</p>
<p><img width="753" height="391" class="wp-image-5347" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 753px) 100vw, 753px" alt="word image 27" title="Introduction to Ngrok: A Tutorial for Beginners 26" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-27.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-27.png?quality=100&amp;f=auto 753w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-27-300x156.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-27-380x197.png?quality=100&amp;f=auto 380w,"/></p>
<p>That app is only accessible on our machine and any other device present on the same network. To access this app on another device on the network, we would type the URL <code data-enlighter-language="raw" class="EnlighterJSRAW">host_device_ip_address:3000</code>. E.g., <code data-enlighter-language="raw" class="EnlighterJSRAW">192.168.1.52:3000</code>.<span id="ezoic-pub-ad-placeholder-127" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-4 leader-4127 adtester-container adtester-container-127" data-ez-name="bytexd_com-leader-4"><span id="div-gpt-ad-bytexd_com-leader-4-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-4-0')};</script></span></span></p>
<p>Unfortunately, that would not work for a device on a different network.</p>
<p>Think of a situation where you are in New York, you just created a local webserver on your home computer, but you want somebody in New Delhi to access your local app.</p>
<p>That’s where Ngrok comes in handy.</p>
<p>Already, we know our application is running on <strong>port 3000</strong>. We can tunnel this port by executing the command below, in a separate terminal, and in the directory where the <strong>ngrok</strong> executable from earlier is located:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">./ngrok http 3000</pre>
<p>The output will show you the running session and the URL you will use to access the local application remotely. You will have both the http and https URLs, which are next to the <strong>Forwarding</strong> value, as shown below:</p>
<p><img width="826" height="457" class="wp-image-5348" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 826px) 100vw, 826px" alt="word image 28" title="Introduction to Ngrok: A Tutorial for Beginners 27" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-28.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-28.png?quality=100&amp;f=auto 826w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-28-300x166.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-28-768x425.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-28-380x210.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-28-800x443.png?quality=100&amp;f=auto 800w,"/></p>
<p>Now you can send this URL to the person you want to access the local app remotely. In our case, we will use:</p>
<pre class="EnlighterJSRAW" data-enlighter-language="raw">http://e2c8-5-12-194-229.ngrok.io
https://e2c8-5-12-194-229.ngrok.io</pre>
<p><img class="wp-image-5349" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" width="735" height="595" sizes="(max-width: 735px) 100vw, 735px" alt="word image 29" title="Introduction to Ngrok: A Tutorial for Beginners 28" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-29.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-29.png?quality=100&amp;f=auto 723w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-29-300x243.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-29-380x307.png?quality=100&amp;f=auto 380w,"/></p>
<p>The image above shows that our local app is now available on the internet and can be accessed remotely from any machine with an active internet connection.</p>
<h3 id="2-host-html-file-with-ngrok">2. Host HTML file with ngrok</h3>
<p>Hosting a React application can be pretty easy since NodeJS will automatically bind a port (mostly 3000 and above) to the localhost server, making it accessible on the web browser. Now, what about a simple HTML web page? Let’s see how we can do this practically.<span id="ezoic-pub-ad-placeholder-128" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-mobile-banner-2 large-mobile-banner-2128 adtester-container adtester-container-128" data-ez-name="bytexd_com-large-mobile-banner-2"><span id="div-gpt-ad-bytexd_com-large-mobile-banner-2-0" ezaw="250" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:250px;min-width:250px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-large-mobile-banner-2-0')};</script></span></span></p>
<p>Create a file called <strong>index.html</strong> and paste the contents below:</p>
<pre class="EnlighterJSRAW" data-enlighter-language="raw">&lt;!DOCTYPE html&gt;
&lt;html&gt;
&lt;body&gt;
&lt;hr /&gt;

&lt;h1&gt;WELCOME TO OUR NGROK TEST WEB APP&lt;/h1&gt;

&lt;hr /&gt;

&lt;h3&gt;This is our Test Ngrok Web Page&lt;/h3&gt;
&lt;/body&gt;
&lt;/html&gt;</pre>
<p>When you open the file on your browser, you should see something similar to the image below.</p>
<p><img width="753" height="399" class="wp-image-5350" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 753px) 100vw, 753px" alt="word image 30" title="Introduction to Ngrok: A Tutorial for Beginners 29" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-30.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-30.png?quality=100&amp;f=auto 753w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-30-300x159.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-30-380x201.png?quality=100&amp;f=auto 380w,"/></p>
<h4 id="using-the-ngrok-bult-in-fileserver">Using the Ngrok Bult-in Fileserver</h4>
<p>With recent updates, Ngrok now has a built-in fileserver. Use the syntax below to serve the directory containing your HTML file using Ngrok.</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">./ngrok http &#34;file:{path_to_directory}&#34;</pre>
<p>In my case, I’ll run:</p><span id="ezoic-pub-ad-placeholder-112" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-mobile-banner-1 large-mobile-banner-1112 adtester-container adtester-container-112" data-ez-name="bytexd_com-large-mobile-banner-1"><span id="div-gpt-ad-bytexd_com-large-mobile-banner-1-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-large-mobile-banner-1-0')};</script></span></span>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">./ngrok http &#34;file:/home/edxd/ngrok_test_html&#34;</pre>
<p><img width="934" height="416" class="wp-image-5353" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 934px) 100vw, 934px" alt="word image 33" title="Introduction to Ngrok: A Tutorial for Beginners 30" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-33.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-33.png?quality=100&amp;f=auto 934w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-33-300x134.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-33-768x342.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-33-380x169.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-33-800x356.png?quality=100&amp;f=auto 800w,"/></p>
<p>For security purposes, we can also make the file accessible only by using the username and password that we set, using a command such as the following:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">./ngrok http -auth=&#34;username:password&#34; &#34;file:{path_to_directory}&#34;</pre>
<p>In my case, I’ll run:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">./ngrok http -auth=&#34;edxd:r#<a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="692d235f022958083d051a">[email&#160;protected]</a>&#34; &#34;/home/edxd/ngrok_test_html&#34;</pre>
<p><img width="934" height="416" class="wp-image-5354" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 934px) 100vw, 934px" alt="word image 34" title="Introduction to Ngrok: A Tutorial for Beginners 31" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-34.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-34.png?quality=100&amp;f=auto 934w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-34-300x134.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-34-768x342.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-34-380x169.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-34-800x356.png?quality=100&amp;f=auto 800w,"/></p>
<p>When we visit the webpage using either of the two links provided, you will be prompted to enter the username and password as shown below.</p>
<p><img width="806" height="341" class="wp-image-5355" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 806px) 100vw, 806px" alt="word image 35" title="Introduction to Ngrok: A Tutorial for Beginners 32" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-35.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-35.png?quality=100&amp;f=auto 806w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-35-300x127.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-35-768x325.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-35-380x161.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-35-800x338.png?quality=100&amp;f=auto 800w,"/></p>
<p>After a successful sign-in, you should see the HTML file we created, as shown below.</p>
<p><img width="806" height="341" class="wp-image-5356" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 806px) 100vw, 806px" alt="word image 36" title="Introduction to Ngrok: A Tutorial for Beginners 33" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-36.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-36.png?quality=100&amp;f=auto 806w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-36-300x127.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-36-768x325.png?quality=100&amp;f=auto 768w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-36-380x161.png?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-36-800x338.png?quality=100&amp;f=auto 800w,"/></p>
<h4 id="using-a-simple-python-server">Using a Simple Python Server</h4>
<p>Formerly, Ngrok only tunneled traffic and couldn’t serve an HTML file, as it didn’t come with the above mentioned built-in fileserver. A simple workaround to this was to create a server with Python by using the <strong>http.server</strong> module.</p>
<p>We’re also mentioning this method since it has been a popular workaround when the built-in fileserver wasn’t available.</p>
<div class="analogy">We used to use the <strong>SimpleHTTPServer</strong> module, however it has been merged into <strong>http.server</strong> in Python 3.</div>
<p>Execute the command below:</p>
<pre class="EnlighterJSRAW prompt" data-enlighter-language="raw">python3 -m http.server</pre>
<p><img width="646" height="326" class="wp-image-5351 alignnone" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 646px) 100vw, 646px" alt="word image 31" title="Introduction to Ngrok: A Tutorial for Beginners 34" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-31.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-31.png?quality=100&amp;f=auto 646w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-31-300x151.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-31-380x192.png?quality=100&amp;f=auto 380w,"/></p>
<p>That will start a localhost server on port <strong>8000</strong>.</p>
<p>Now, if we visit <code data-enlighter-language="raw" class="EnlighterJSRAW">http://localhost:8000</code> we can see <strong>index.html</strong> is served:</p>
<p><img width="753" height="319" class="wp-image-5352" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" sizes="(max-width: 753px) 100vw, 753px" alt="word image 32" title="Introduction to Ngrok: A Tutorial for Beginners 35" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-32.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-32.png?quality=100&amp;f=auto 753w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-32-300x127.png?quality=100&amp;f=auto 300w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/word-image-32-380x161.png?quality=100&amp;f=auto 380w,"/></p>
<p> </p>
<h2 id="conclusion">Conclusion</h2>
<p>I believe you now have a basic understanding of Ngrok and how it works.</p>
<p>It can be an excellent utility for web developers, especially if you are developing a website for a client, collaborating on a project with colleagues, or many other instances where you need to expose the server running on your local machine to the internet.</p>

		</div>
				<div class="pk-share-buttons-wrap pk-share-buttons-layout-default pk-share-buttons-scheme-bold-bg pk-share-buttons-has-counts pk-share-buttons-has-total-counts pk-share-buttons-after-post pk-share-buttons-mode-php pk-share-buttons-mode-rest" data-post-id="5339" data-share-url="https://bytexd.com/ngrok-tutorial-for-beginners/">

							<div class="pk-share-buttons-total">
							<div class="pk-share-buttons-count cs-font-primary">3 Shares:</div>
						</div>
				
			<div class="pk-share-buttons-items">

										<div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-item-count" data-id="facebook">

							<a href="https://www.facebook.com/sharer.php?u=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">3</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter">

							<a href="https://twitter.com/share?&amp;text=Introduction%20to%20Ngrok%3A%20A%20Tutorial%20for%20Beginners&amp;via=ByteXD&amp;url=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Tweet</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-pinterest pk-share-buttons-no-count" data-id="pinterest">

							<a href="https://pinterest.com/pin/create/bookmarklet/?url=https://bytexd.com/ngrok-tutorial-for-beginners/&amp;media=https://bytexd.com/wp-content/uploads/2021/09/Introduction-to-Ngrok-A-Tutorial-for-Beginners-1024x576.jpg" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-pinterest"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Pin it</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-whatsapp pk-share-buttons-no-count" data-id="whatsapp">

							<a href="whatsapp://send?text=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="internal">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-whatsapp"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-fb-messenger pk-share-buttons-no-count" data-id="fb-messenger">

							<a href="fb-messenger://share/?link=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="internal">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-fb-messenger"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
											<div class="pk-share-buttons-item pk-share-buttons-reddit pk-share-buttons-no-count" data-id="reddit">

							<a href="https://www.reddit.com/submit?url=https://bytexd.com/ngrok-tutorial-for-beginners/" class="pk-share-buttons-link" target="_blank" data-wpel-link="exclude">

																	<i class="pk-share-buttons-icon pk-icon pk-icon-reddit"></i>
								
								
																	<span class="pk-share-buttons-label pk-font-primary">Share</span>
								
																	<span class="pk-share-buttons-count pk-font-secondary">0</span>
															</a>

							
							
													</div>
								</div>
		</div>
	

<section class="post-author">

	<div class="authors-compact">

			<div class="author-wrap">
			<div class="author">
				<div class="author-avatar">
					<a href="https://bytexd.com/author/edxd/" rel="author" data-wpel-link="internal">
						<img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="avatar avatar-120 photo" height="120" width="120" data-loading="lazy" data-src="https://secure.gravatar.com/avatar/908729a6f7effb4a6f8c5b48c6855cd2?s=120&amp;d=mm&amp;r=g&amp;quality=100" data-srcset=""/>					</a>
				</div>
				<div class="author-description">
					<h5 class="title-author">
						<span class="fn">
							<a href="https://bytexd.com/author/edxd/" rel="author" data-wpel-link="internal">
								EdXD							</a>
						</span>
					</h5>
					<p class="note"></p>
							<div class="pk-author-social-links pk-social-links-wrap pk-social-links-template-default">
			<div class="pk-social-links-items">
										<div class="pk-social-links-item pk-social-links-twitter">
							<a href="https://twitter.com/shwayguy" class="pk-social-links-link" target="_blank" rel="nofollow" data-wpel-link="exclude">
								<i class="pk-icon pk-icon-twitter"></i>
															</a>
						</div>
								</div>
		</div>
						</div>
			</div>
		</div>
	
	</div>

</section>

    <div class="wpdiscuz_top_clearing"></div>
    <div id="comments" class="comments-area"><div id="respond" style="width: 0;height: 0;clear: both;margin: 0;padding: 0;"></div>    <div id="wpdcom" class="wpdiscuz_unauth wpd-default wpd-layout-1 wpd-comments-open">
                    <div class="wc_social_plugin_wrapper">
                            </div>
            <div class="wpd-form-wrap">
                <div class="wpd-form-head">
                                            <div class="wpd-sbs-toggle">
                            <i class="far fa-envelope"></i> <span class="wpd-sbs-title">Subscribe</span> <i class="fas fa-caret-down"></i>
                        </div>
                                            <div class="wpd-auth">
                                                <div class="wpd-login">
                            <a rel="nofollow" href="https://bytexd.com/wp-login.php?redirect_to=https%3A%2F%2Fbytexd.com%2Fngrok-tutorial-for-beginners%2F" data-wpel-link="internal"><i class="fas fa-sign-in-alt"></i> Login</a>                        </div>
                    </div>
                </div>
                                                    <div class="wpdiscuz-subscribe-bar wpdiscuz-hidden">
                                                    <form action="https://bytexd.com/wp-admin/admin-ajax.php?action=wpdAddSubscription" method="post" id="wpdiscuz-subscribe-form">
                                <div class="wpdiscuz-subscribe-form-intro">Notify of </div>
                                <div class="wpdiscuz-subscribe-form-option" style="width:40%;">
                                    <select class="wpdiscuz_select" name="wpdiscuzSubscriptionType">
                                                                                    <option value="post">new follow-up comments</option>
                                                                                                                                <option value="all_comment">new replies to my comments</option>
                                                                                </select>
                                </div>
                                                                    <div class="wpdiscuz-item wpdiscuz-subscribe-form-email">
                                        <input class="email" type="email" name="wpdiscuzSubscriptionEmail" required="required" value="" placeholder="Email"/>
                                    </div>
                                                                    <div class="wpdiscuz-subscribe-form-button">
                                    <input id="wpdiscuz_subscription_button" class="wpd-prim-button" type="submit" value="›" name="wpdiscuz_subscription_button"/>
                                </div> 
                                <input type="hidden" id="wpdiscuz_subscribe_form_nonce" name="wpdiscuz_subscribe_form_nonce" value="d6864663eb"/><input type="hidden" name="_wp_http_referer" value="/ngrok-tutorial-for-beginners/"/>                            </form>
                                                </div>
                            <div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id="wpd-main-form-wrapper-0_0">
                                        <form class="wpd_comm_form wpd_main_comm_form" method="post" enctype="multipart/form-data">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap">
                                                                                                        <div class="wpd-avatar">
                                        <img alt="guest" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="avatar avatar-56 photo avatar-default" height="56" width="56" data-loading="lazy" data-src="https://secure.gravatar.com/avatar/?s=56&amp;d=mm&amp;r=g&amp;quality=100" data-srcset=""/>                                    </div>
                                                <div id="wpd-editor-wraper-0_0" style="display: none;">
                <div id="wpd-editor-char-counter-0_0" class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-0_0">Label</label>
                <textarea id="wc-textarea-0_0" required="" name="wc_comment" class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-0_0"></div>
                    <div id="wpd-editor-toolbar-0_0">
                            <button title="Bold" class="ql-bold"></button>
                                <button title="Italic" class="ql-italic"></button>
                                <button title="Underline" class="ql-underline"></button>
                                <button title="Strike" class="ql-strike"></button>
                                <button title="Ordered List" class="ql-list" value="ordered"></button>
                                <button title="Unordered List" class="ql-list" value="bullet"></button>
                                <button title="Blockquote" class="ql-blockquote"></button>
                                <button title="Code Block" class="ql-code-block"></button>
                                <button title="Link" class="ql-link"></button>
                                <button title="Source Code" class="ql-sourcecode" data-wpde_button_name="sourcecode">{}</button>
                                <button title="Spoiler" class="ql-spoiler" data-wpde_button_name="spoiler">[+]</button>
                            <div class="wpd-editor-buttons-right">
                <span class="wmu-upload-wrap" wpd-tooltip="Attach an image to this comment" wpd-tooltip-position="left"><label class="wmu-add"><i class="far fa-image"></i><input style="display:none;" class="wmu-add-files" type="file" name="wmu_files[]" accept="image/*"/></label></span>            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot">
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"><div class="wmu-action-wrap"><div class="wmu-tabs wmu-images-tab wmu-hide"></div></div></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                    <input id="wc_name-0_0" value="" required="required" aria-required="true" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title=""/>
                <label for="wc_name-0_0" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                    <input id="wc_email-0_0" value="" required="required" aria-required="true" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*"/>
                <label for="wc_email-0_0" class="wpdlb">Email*</label>
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input id="wc_website-0_0" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website"/>
                    <label for="wc_website-0_0" class="wpdlb">Website</label>
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-0_0" class="wc_notification_new_comment-0_0 wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-0_0" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment"/>
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="0_0" name="wpdiscuz_unique_id"/>
                </form>
                        </div>
                <div id="wpdiscuz_hidden_secondary_form" style="display: none;">
                    <div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id="wpd-secondary-form-wrapper-wpdiscuzuniqueid" style="display: none;">
                            <div class="wpd-secondary-forms-social-content"></div><div class="clearfix"></div>
                                        <form class="wpd_comm_form wpd-secondary-form-wrapper" method="post" enctype="multipart/form-data">
                    <div class="wpd-field-comment">
                        <div class="wpdiscuz-item wc-field-textarea">
                            <div class="wpdiscuz-textarea-wrap">
                                                                                                        <div class="wpd-avatar">
                                        <img alt="guest" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="avatar avatar-56 photo avatar-default" height="56" width="56" data-loading="lazy" data-src="https://secure.gravatar.com/avatar/?s=56&amp;d=mm&amp;r=g&amp;quality=100" data-srcset=""/>                                    </div>
                                                <div id="wpd-editor-wraper-wpdiscuzuniqueid" style="display: none;">
                <div id="wpd-editor-char-counter-wpdiscuzuniqueid" class="wpd-editor-char-counter"></div>
                <label style="display: none;" for="wc-textarea-wpdiscuzuniqueid">Label</label>
                <textarea id="wc-textarea-wpdiscuzuniqueid" required="" name="wc_comment" class="wc_comment wpd-field"></textarea>
                <div id="wpd-editor-wpdiscuzuniqueid"></div>
                    <div id="wpd-editor-toolbar-wpdiscuzuniqueid">
                            <button title="Bold" class="ql-bold"></button>
                                <button title="Italic" class="ql-italic"></button>
                                <button title="Underline" class="ql-underline"></button>
                                <button title="Strike" class="ql-strike"></button>
                                <button title="Ordered List" class="ql-list" value="ordered"></button>
                                <button title="Unordered List" class="ql-list" value="bullet"></button>
                                <button title="Blockquote" class="ql-blockquote"></button>
                                <button title="Code Block" class="ql-code-block"></button>
                                <button title="Link" class="ql-link"></button>
                                <button title="Source Code" class="ql-sourcecode" data-wpde_button_name="sourcecode">{}</button>
                                <button title="Spoiler" class="ql-spoiler" data-wpde_button_name="spoiler">[+]</button>
                            <div class="wpd-editor-buttons-right">
                <span class="wmu-upload-wrap" wpd-tooltip="Attach an image to this comment" wpd-tooltip-position="left"><label class="wmu-add"><i class="far fa-image"></i><input style="display:none;" class="wmu-add-files" type="file" name="wmu_files[]" accept="image/*"/></label></span>            </div>
        </div>
                    </div>
                                        </div>
                        </div>
                    </div>
                    <div class="wpd-form-foot">
                        <div class="wpdiscuz-textarea-foot">
                                                        <div class="wpdiscuz-button-actions"><div class="wmu-action-wrap"><div class="wmu-tabs wmu-images-tab wmu-hide"></div></div></div>
                        </div>
                                <div class="wpd-form-row">
                    <div class="wpd-form-col-left">
                        <div class="wpdiscuz-item wc_name-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-user"></i></div>
                                    <input id="wc_name-wpdiscuzuniqueid" value="" required="required" aria-required="true" class="wc_name wpd-field" type="text" name="wc_name" placeholder="Name*" maxlength="50" pattern=".{3,50}" title=""/>
                <label for="wc_name-wpdiscuzuniqueid" class="wpdlb">Name*</label>
                            </div>
                        <div class="wpdiscuz-item wc_email-wrapper wpd-has-icon">
                                    <div class="wpd-field-icon"><i class="fas fa-at"></i></div>
                                    <input id="wc_email-wpdiscuzuniqueid" value="" required="required" aria-required="true" class="wc_email wpd-field" type="email" name="wc_email" placeholder="Email*"/>
                <label for="wc_email-wpdiscuzuniqueid" class="wpdlb">Email*</label>
                            </div>
                            <div class="wpdiscuz-item wc_website-wrapper wpd-has-icon">
                                            <div class="wpd-field-icon"><i class="fas fa-link"></i></div>
                                        <input id="wc_website-wpdiscuzuniqueid" value="" class="wc_website wpd-field" type="text" name="wc_website" placeholder="Website"/>
                    <label for="wc_website-wpdiscuzuniqueid" class="wpdlb">Website</label>
                                    </div>
                        </div>
                <div class="wpd-form-col-right">
                    <div class="wc-field-submit">
                                            
                                            <label class="wpd_label" wpd-tooltip="Notify of new replies to this comment">
                            <input id="wc_notification_new_comment-wpdiscuzuniqueid" class="wc_notification_new_comment-wpdiscuzuniqueid wpd_label__checkbox" value="comment" type="checkbox" name="wpdiscuz_notification_type"/>
                            <span class="wpd_label__text">
                                <span class="wpd_label__check">
                                    <i class="fas fa-bell wpdicon wpdicon-on"></i>
                                    <i class="fas fa-bell-slash wpdicon wpdicon-off"></i>
                                </span>
                            </span>
                        </label>
                                                                <input id="wpd-field-submit-wpdiscuzuniqueid" class="wc_comm_submit wpd_not_clicked wpd-prim-button" type="submit" name="submit" value="Post Comment"/>
        </div>
                </div>
                    <div class="clearfix"></div>
        </div>
                            </div>
                                        <input type="hidden" class="wpdiscuz_unique_id" value="wpdiscuzuniqueid" name="wpdiscuz_unique_id"/>
                </form>
                        </div>
                </div>
                    </div>
                        <div id="wpd-threads" class="wpd-thread-wrapper">
                <div class="wpd-thread-head">
                    <div class="wpd-thread-info" data-comments-count="1">
                        <span class="wpdtc" title="1">1</span> Comment                    </div>
                                        <div class="wpd-space"></div>
                    <div class="wpd-thread-filter">
                                                    <div class="wpd-filter wpdf-reacted wpd_not_clicked" wpd-tooltip="Most reacted comment"><i class="fas fa-bolt"></i></div>
                                                        <div class="wpd-filter wpdf-hottest wpd_not_clicked" wpd-tooltip="Hottest comment thread"><i class="fas fa-fire"></i></div>
                                                        <div class="wpd-filter wpdf-sorting">
                                                                        <span class="wpdiscuz-sort-button wpdiscuz-date-sort-asc wpdiscuz-sort-button-active" data-sorting="oldest">Oldest</span>
                                                                        <i class="fas fa-sort-down"></i>
                                <div class="wpdiscuz-sort-buttons">
                                                                            <span class="wpdiscuz-sort-button wpdiscuz-date-sort-desc" data-sorting="newest">Newest</span>
                                                                                <span class="wpdiscuz-sort-button wpdiscuz-vote-sort-up" data-sorting="by_vote">Most Voted</span>
                                                                        </div>
                            </div>
                                                </div>
                </div>
                <div class="wpd-comment-info-bar">
                    <div class="wpd-current-view"><i class="fas fa-quote-left"></i> Inline Feedbacks</div>
                    <div class="wpd-filter-view-all">View all comments</div>
                </div>
                                <div class="wpd-thread-list">
                    <div id="wpd-comm-1782_0" class="wpd-comment wpd_comment_level-1"><div class="wpd-comment-wrap wpd-blog-guest">
    <div class="wpd-comment-left">
    <div class="wpd-avatar">
    <img alt="Faisal" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="avatar avatar-64 photo" height="64" width="64" data-loading="lazy" data-src="https://secure.gravatar.com/avatar/beb21939f6a5a1e3b48faa2d5eed358a?s=64&amp;d=mm&amp;r=g&amp;quality=100" data-srcset=""/>
</div>
    
    
</div>
    <div id="comment-1782" class="wpd-comment-right">
    <div class="wpd-comment-header">
    <div class="wpd-comment-author">
    <a href="http://example.com" rel="noreferrer ugc nofollow external noopener" target="_blank" data-wpel-link="external" class="wpel-icon-right">Faisal<span class="wpel-icon wpel-image wpel-icon-7"></span></a>
</div>
    <div class="wpd-comment-date" title="September 22, 2021 9:39 am">
    <i class="far fa-clock" aria-hidden="true"></i>
    3 days ago
</div>
    
    <div class="wpd-comment-share wpd-hidden wpd-tooltip wpd-top">
    <i class="fas fa-share-alt" aria-hidden="true"></i>
    <div class="wpd-tooltip-content">
        <a class="wc_tw" rel="noreferrer" target="_blank" href="https://twitter.com/intent/tweet?text=Thanks! Informative.&amp;url=https%3A%2F%2Fbytexd.com%2Fngrok-tutorial-for-beginners%2F%23comment-1782" title="Share On Twitter" data-wpel-link="exclude"><i class="fab fa-twitter wpf-cta" aria-hidden="true"></i></a><a class="wc_vk wpel-icon-right" rel="noreferrer external noopener" target="_blank" href="https://vk.com/share.php?url=https://bytexd.com/ngrok-tutorial-for-beginners/" title="Share On VKontakte" data-wpel-link="external"><i class="fab fa-vk wpf-cta" aria-hidden="true"></i><span class="wpel-icon wpel-image wpel-icon-7"></span></a><a class="wc_ok wpel-icon-right" rel="noreferrer external noopener" target="_blank" href="https://connect.ok.ru/offer?url=https://bytexd.com/ngrok-tutorial-for-beginners/" title="Share On Odnoklassniki" data-wpel-link="external"><i class="fab fa-odnoklassniki wpf-cta" aria-hidden="true"></i><span class="wpel-icon wpel-image wpel-icon-7"></span></a>
    </div>
</div>
    <div class="wpd-space"></div>
    <div class="wpd-comment-link wpd-hidden">
    <span wpd-tooltip="Comment Link" wpd-tooltip-position="left"><i class="fas fa-link" aria-hidden="true" data-comment-url="https://bytexd.com/ngrok-tutorial-for-beginners/#comment-1782"></i></span>
</div>
</div>
    
    <div class="wpd-comment-text">
    <p>Thanks! Informative.</p>

</div>
    <div class="wpd-comment-footer">
    <div class="wpd-vote">
    <div class="wpd-vote-up wpd_not_clicked">
        <svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="chevron-up" class="svg-inline--fa fa-chevron-up fa-w-14" role="img" xmlns="https://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M240.971 130.524l194.343 194.343c9.373 9.373 9.373 24.569 0 33.941l-22.667 22.667c-9.357 9.357-24.522 9.375-33.901.04L224 227.495 69.255 381.516c-9.379 9.335-24.544 9.317-33.901-.04l-22.667-22.667c-9.373-9.373-9.373-24.569 0-33.941L207.03 130.525c9.372-9.373 24.568-9.373 33.941-.001z"></path></svg>
    </div>
    <div class="wpd-vote-result" title="0">0</div>
    <div class="wpd-vote-down wpd_not_clicked">
        <svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="chevron-down" class="svg-inline--fa fa-chevron-down fa-w-14" role="img" xmlns="https://www.w3.org/2000/svg" viewBox="0 0 448 512"><path d="M207.029 381.476L12.686 187.132c-9.373-9.373-9.373-24.569 0-33.941l22.667-22.667c9.357-9.357 24.522-9.375 33.901-.04L224 284.505l154.745-154.021c9.379-9.335 24.544-9.317 33.901.04l22.667 22.667c9.373 9.373 9.373 24.569 0 33.941L240.971 381.476c-9.373 9.372-24.569 9.372-33.942 0z"></path></svg>
    </div>
</div>
    <div class="wpd-reply-button">
    <svg xmlns="https://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>
    <span>Reply</span>
</div>
    <div class="wpd-space"></div>
    
    
</div>
</div>
</div><div id="wpdiscuz_form_anchor-1782_0"></div></div>                    <div class="wpdiscuz-comment-pagination">
                                            </div>
                </div>
            </div>
                </div>
        </div>
    <div id="wpdiscuz-loading-bar" class="wpdiscuz-loading-bar-unauth"></div>
    <div id="wpdiscuz-comment-message" class="wpdiscuz-comment-message-unauth"></div>
    	</div>

				</div>
			
	
</article><span id="ezoic-pub-ad-placeholder-106" class="ezoic-adpicker-ad"></span><span class="ezoic-ad leader-3 leader-3106 adtester-container adtester-container-106" data-ez-name="bytexd_com-leader-3"><span id="div-gpt-ad-bytexd_com-leader-3-0" ezaw="580" ezah="400" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:400px;min-width:580px;" class="ezoic-ad"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-leader-3-0')};</script></span></span>

					<div class="post-prev-next">
						<a class="link-item prev-link" href="https://bytexd.com/clear-apt-cache/" data-wpel-link="internal">
					<div class="link-content">
						<div class="link-label">
							<span class="link-arrow"></span><span class="link-text"> — Previous article</span>
						</div>

						<h2 class="entry-title">
							Clear APT Cache Using the Apt Clean Command						</h2>
					</div>
				</a>
							<a class="link-item next-link" href="https://bytexd.com/rm-command-in-linux/" data-wpel-link="internal">
					<div class="link-content">
						<div class="link-label">
							<span class="link-text">Next article — </span><span class="link-arrow"></span>
						</div>

						<h2 class="entry-title">
							Rm Command in Linux						</h2>
					</div>
				</a>
				</div>
		<section class="post-archive archive-related">

			<div class="archive-wrap">

				
				<div class="title-block-wrap">
					<h5 class="title-block">
						You May Also Like					</h5>
				</div>

				<div class="archive-main archive-list  archive-heading-medium archive-borders-disabled archive-shadow-enabled archive-scale-disabled">

					
<article class="entry-preview post-2535 post type-post status-publish format-standard has-post-thumbnail category-miscellaneous tag-email tag-gmail tag-google">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="How to Enable Less Secure Apps in Gmail_G-Suite" sizes="(max-width: 380px) 100vw, 380px" title="How to Enable Less Secure Apps in Gmail/G Suite 36" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/How-to-Enable-Less-Secure-Apps-in-Gmail_G-Suite-380x220.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/How-to-Enable-Less-Secure-Apps-in-Gmail_G-Suite-380x220.jpg?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/How-to-Enable-Less-Secure-Apps-in-Gmail_G-Suite-80x46.jpg?quality=100&amp;f=auto 80w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>3 minute read</li></ul>											</div>
					<a href="https://bytexd.com/less-secure-apps-gmail/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal"><span style="background:#1B1B3A" class="char cs-bg-dark">M</span><span class="label">Miscellaneous</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/less-secure-apps-gmail/" rel="bookmark" data-wpel-link="internal">How to Enable Less Secure Apps in Gmail/G Suite</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">June 25, 2020</li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							Google often blocks sign-in attempts from some applications indicating that they’re less secure. It can be quite annoying…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-2871 post type-post status-publish format-standard has-post-thumbnail category-wordpress category-ubuntu category-website-setup">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="How to Install WordPress with WordOps on Ubuntu 20.04" sizes="(max-width: 380px) 100vw, 380px" title="Using WordOps to Install WordPress Automatically on Ubuntu 20.04 37" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/How-to-Install-WordPress-with-WordOps-on-Ubuntu-20.04-380x220.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/How-to-Install-WordPress-with-WordOps-on-Ubuntu-20.04-380x220.jpg?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/03/How-to-Install-WordPress-with-WordOps-on-Ubuntu-20.04-80x46.jpg?quality=100&amp;f=auto 80w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>9 minute read</li></ul>											</div>
					<a href="https://bytexd.com/wordops-ubuntu/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/ubuntu/" data-wpel-link="internal"><span style="background:#e95420" class="char cs-bg-dark">U</span><span class="label">Ubuntu</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/wordops-ubuntu/" rel="bookmark" data-wpel-link="internal">Using WordOps to Install WordPress Automatically on Ubuntu 20.04</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">March 4, 2021</li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							WordOps is a simple tool that provides the ability to deploy WordPress sites from the command line using…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-2563 post type-post status-publish format-standard has-post-thumbnail category-digital-marketing category-website-setup tag-free-stuff">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="How to Get a Domain Name for Free" sizes="(max-width: 380px) 100vw, 380px" title="How to Get a Domain Name for Free 41" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/How-to-Get-a-Domain-Name-for-Free-380x220.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/How-to-Get-a-Domain-Name-for-Free-380x220.jpg?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/How-to-Get-a-Domain-Name-for-Free-80x46.jpg?quality=100&amp;f=auto 80w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>12 minute read</li></ul>											</div>
					<a href="https://bytexd.com/free-domain-name/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/digital-marketing/" data-wpel-link="internal"><span style="background:#000000" class="char cs-bg-dark">D</span><span class="label">Digital Marketing</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/free-domain-name/" rel="bookmark" data-wpel-link="internal">How to Get a Domain Name for Free</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">June 27, 2020</li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							You’re most likely here because you’ve searched for something like “how to get a free domain” and most…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-4752 post type-post status-publish format-standard has-post-thumbnail category-miscellaneous category-ubuntu tag-kali-linux tag-security">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="How to Install DVWA on Kali Linux" title="How to Install DVWA on Kali Linux for Pentesting Practice 51" sizes="(max-width: 380px) 100vw, 380px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/07/How-to-Install-DVWA-on-Kali-Linux-380x220.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/07/How-to-Install-DVWA-on-Kali-Linux-380x220.jpg?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/07/How-to-Install-DVWA-on-Kali-Linux-380x220.jpg?w=380&amp;quality=100&amp;f=auto 380w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>6 minute read</li></ul>											</div>
					<a href="https://bytexd.com/how-to-install-dvwa/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal"><span style="background:#1B1B3A" class="char cs-bg-dark">M</span><span class="label">Miscellaneous</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/how-to-install-dvwa/" rel="bookmark" data-wpel-link="internal">How to Install DVWA on Kali Linux for Pentesting Practice</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">July 26, 2021</li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							Anybody who wants to get started with Ethical hacking or wants to advance their skills in penetration testing…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-2742 post type-post status-publish format-standard has-post-thumbnail category-miscellaneous">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="Look Up Unknown Phone Numbers using Facebook Reset Password and WhatsApp" sizes="(max-width: 380px) 100vw, 380px" title="Look Up Unknown Phone Numbers using Social Media 56" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/12/Look-Up-Unknown-Phone-Numbers-using-Facebook-Reset-Password-and-WhatsApp-380x220.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/12/Look-Up-Unknown-Phone-Numbers-using-Facebook-Reset-Password-and-WhatsApp-380x220.jpg?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/12/Look-Up-Unknown-Phone-Numbers-using-Facebook-Reset-Password-and-WhatsApp-80x46.jpg?quality=100&amp;f=auto 80w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>6 minute read</li></ul>											</div>
					<a href="https://bytexd.com/look-up-unknown-phone-numbers/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal"><span style="background:#1B1B3A" class="char cs-bg-dark">M</span><span class="label">Miscellaneous</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/look-up-unknown-phone-numbers/" rel="bookmark" data-wpel-link="internal">Look Up Unknown Phone Numbers using Social Media</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">December 29, 2020</li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							This tutorial is meant to help find clues as to who is calling you when you’re receiving calls…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>

<article class="entry-preview post-4022 post type-post status-publish format-standard has-post-thumbnail category-miscellaneous tag-virtualization tag-windows-10">
	<div class="post-outer">
		
				<div class="post-inner">
			<div class="entry-thumbnail">
				<div class="cs-overlay cs-overlay-hover  cs-bg-dark cs-overlay-ratio cs-ratio-landscape">
					<div class="cs-overlay-background">
						<img width="380" height="220" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-thumbnail size-csco-thumbnail wp-post-image" alt="How to Install WSL2 (Windows Subsystem for Linux) on Windows 10" sizes="(max-width: 380px) 100vw, 380px" title="How to Install WSL 2 (Windows Subsystem for Linux) on Windows 10 67" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/05/How-to-Install-WSL2-Windows-Subsystem-for-Linux-on-Windows-10-380x220.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/05/How-to-Install-WSL2-Windows-Subsystem-for-Linux-on-Windows-10-380x220.jpg?quality=100&amp;f=auto 380w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/05/How-to-Install-WSL2-Windows-Subsystem-for-Linux-on-Windows-10-80x46.jpg?quality=100&amp;f=auto 80w,"/>											</div>
					<div class="cs-overlay-content">
						<span class="read-more">Read More</span>
						<ul class="post-meta"><li class="meta-reading-time"><i class="cs-icon cs-icon-clock"></i>3 minute read</li></ul>											</div>
					<a href="https://bytexd.com/how-to-install-wsl2-on-windows-10/" class="cs-overlay-link" data-wpel-link="internal"></a>
				</div>
			</div>
		</div>
		
		<div class="post-inner">
			<div class="meta-category"><a class="category-style" href="https://bytexd.com/category/miscellaneous/" data-wpel-link="internal"><span style="background:#1B1B3A" class="char cs-bg-dark">M</span><span class="label">Miscellaneous</span></a></div>			<header class="entry-header">
				<h2 class="entry-title"><a href="https://bytexd.com/how-to-install-wsl2-on-windows-10/" rel="bookmark" data-wpel-link="internal">How to Install WSL 2 (Windows Subsystem for Linux) on Windows 10</a></h2><ul class="post-meta"><li class="meta-author"><span class="by">by</span><span class="author"><a class="url fn n" href="https://bytexd.com/author/edxd/" title="View all posts by EdXD" data-wpel-link="internal">EdXD</a></span></li><li class="meta-date">May 21, 2021</li></ul>			</header>

							<div class="entry-details">
											<div class="entry-excerpt">
							In 2017, Microsoft released the first version of WSL enabling users to run Linux commands on their Windows…						</div>
					
									</div>
			
		</div><!-- .post-inner -->

	</div><!-- .post-outer -->
</article>
				</div>

			</div>

		</section>
	
	

			
			
		</main>

		
	</div><!-- .content-area -->


	<aside id="secondary" class="widget-area sidebar-area">
		<div class="sidebar sidebar-1"><span id="ezoic-pub-ad-placeholder-130" class="ezoic-adpicker-ad"></span><span class="ezoic-ad box-1 box-1130 adtester-container adtester-container-130" data-ez-name="bytexd_com-box-1"><span id="div-gpt-ad-bytexd_com-box-1-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-box-1-0')};</script></span><span style="width:300px;display:block;height:14px;margin:auto" class="reportline"><span style="text-align:center;font-size: smaller;float:left;line-height:normal;"><a href="https://www.ezoic.com/what-is-ezoic/" target="_blank" rel="noopener noreferrer nofollow" style="cursor:pointer"><img src="https://go.ezoic.net/utilcave_com/img/ezoic.png" alt="Ezoic" loading="lazy" style="height:12px !important; padding:2px !important; border:0px !important; cursor:pointer !important; width: 58px !important; margin:0 !important; box-sizing: content-box !important;"/></a></span><span class="ez-report-ad-button" name="?pageview_id=ba929e66-cfbf-427d-57cc-eeea1d66d311&amp;ad_position_id=130&amp;impression_group_id=bytexd_com-box-1/2021-09-26/7555785681577724&amp;ad_size=300x250&amp;domain_id=283186&amp;url=https://bytexd.com/ngrok-tutorial-for-beginners/" style="cursor: pointer!important; font-size:12px !important;color: #a5a5a5 ;float:right;text-decoration:none !important;font-family:arial !important;line-height:normal;">report this ad</span></span></span>
						<div class="widget categories-2 widget_categories"><div class="title-block-wrap"><h5 class="title-block title-widget">Categories</h5></div><form action="https://bytexd.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select name="cat" id="cat" class="postform">
	<option value="-1">Select Category</option>
	<option class="level-0" value="16">CentOS  (4)</option>
	<option class="level-0" value="34">Debian  (7)</option>
	<option class="level-0" value="19">Digital Marketing  (1)</option>
	<option class="level-0" value="32">Linux  (36)</option>
	<option class="level-0" value="38">Linux Commands  (25)</option>
	<option class="level-0" value="1">Miscellaneous  (6)</option>
	<option class="level-0" value="10">Ubuntu  (12)</option>
	<option class="level-0" value="29">Website Setup  (4)</option>
	<option class="level-0" value="33">WordPress  (3)</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</div><div class="widget powerkit_widget_posts-1 powerkit_widget_posts"><span id="ezoic-pub-ad-placeholder-101" class="ezoic-adpicker-ad"></span><div class="title-block-wrap"><span id="ezoic-pub-ad-placeholder-110" class="ezoic-adpicker-ad"></span><h5 class="title-block title-widget">Featured Posts</h5></div>
			<div class="widget-body pk-widget-posts pk-widget-posts-template-default pk-widget-posts-template-numbered posts-per-page-4">
				<ul>
											<li class="pk-post-item">
									<article class="pk-preview-enabled post-5454 post type-post status-publish format-standard has-post-thumbnail category-linux-commands category-linux">
			<div class="pk-post-outer">
									<div class="pk-post-inner pk-post-thumbnail">
						<a href="https://bytexd.com/how-to-rename-files-in-linux/" class="post-thumbnail" data-wpel-link="internal">
							<img width="80" height="80" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-small size-csco-small wp-post-image" alt="How to Rename Files in Linux (mv and rename)" sizes="(max-width: 80px) 100vw, 80px" title="How to Rename Files in Linux (mv and rename Commands) 76" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/How-to-Rename-Files-in-Linux-mv-and-rename-1-80x80.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/How-to-Rename-Files-in-Linux-mv-and-rename-1-80x80.png?quality=100&amp;f=auto 80w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/How-to-Rename-Files-in-Linux-mv-and-rename-1-150x150.png?quality=100&amp;f=auto 150w,"/>						</a>
					</div>
				
				<div class="pk-post-inner pk-post-data">
										<h5 class="entry-title">
						<a href="https://bytexd.com/how-to-rename-files-in-linux/" data-wpel-link="internal">How to Rename Files in Linux (mv and rename Commands)</a>
					</h5>
					<ul class="post-meta"><li class="meta-date">September 24, 2021</li></ul>				</div>
			</div>
		</article>
							</li>
											<li class="pk-post-item">
									<article class="pk-preview-enabled post-5417 post type-post status-publish format-standard has-post-thumbnail category-linux-commands category-linux">
			<div class="pk-post-outer">
									<div class="pk-post-inner pk-post-thumbnail">
						<a href="https://bytexd.com/what-does-chmod-777-mean/" class="post-thumbnail" data-wpel-link="internal">
							<img width="80" height="80" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-small size-csco-small wp-post-image" alt="What Does chmod 777 Mean" sizes="(max-width: 80px) 100vw, 80px" title="What Does chmod 777 Mean 77" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/What-Does-chmod-777-Mean-80x80.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/What-Does-chmod-777-Mean-80x80.png?quality=100&amp;f=auto 80w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/What-Does-chmod-777-Mean-150x150.png?quality=100&amp;f=auto 150w,"/>						</a>
					</div>
				
				<div class="pk-post-inner pk-post-data">
										<h5 class="entry-title">
						<a href="https://bytexd.com/what-does-chmod-777-mean/" data-wpel-link="internal">What Does chmod 777 Mean</a>
					</h5>
					<ul class="post-meta"><li class="meta-date">September 23, 2021</li></ul>				</div>
			</div>
		</article>
							</li>
											<li class="pk-post-item">
									<article class="pk-preview-enabled post-5399 post type-post status-publish format-standard has-post-thumbnail category-linux-commands category-linux">
			<div class="pk-post-outer">
									<div class="pk-post-inner pk-post-thumbnail">
						<a href="https://bytexd.com/how-to-run-cron-jobs-every-5-10-15-or-30-minutes/" class="post-thumbnail" data-wpel-link="internal">
							<img width="80" height="80" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-small size-csco-small wp-post-image" alt="How To Run Cron Jobs Every 5, 10, 15, or 30 Minutes" sizes="(max-width: 80px) 100vw, 80px" title="How To Run Cron Jobs Every 5, 10, 15, or 30 Minutes 78" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/How-To-Run-Cron-Jobs-Every-5-10-15-or-30-Minutes-80x80.jpg?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/How-To-Run-Cron-Jobs-Every-5-10-15-or-30-Minutes-80x80.jpg?quality=100&amp;f=auto 80w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/How-To-Run-Cron-Jobs-Every-5-10-15-or-30-Minutes-150x150.jpg?quality=100&amp;f=auto 150w,"/>						</a>
					</div>
				
				<div class="pk-post-inner pk-post-data">
										<h5 class="entry-title">
						<a href="https://bytexd.com/how-to-run-cron-jobs-every-5-10-15-or-30-minutes/" data-wpel-link="internal">How To Run Cron Jobs Every 5, 10, 15, or 30 Minutes</a>
					</h5>
					<ul class="post-meta"><li class="meta-date">September 22, 2021</li></ul>				</div>
			</div>
		</article>
							</li>
											<li class="pk-post-item">
									<article class="pk-preview-enabled post-5378 post type-post status-publish format-standard has-post-thumbnail category-linux-commands category-linux">
			<div class="pk-post-outer">
									<div class="pk-post-inner pk-post-thumbnail">
						<a href="https://bytexd.com/rm-command-in-linux/" class="post-thumbnail" data-wpel-link="internal">
							<img width="80" height="80" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" class="attachment-csco-small size-csco-small wp-post-image" alt="Rm Command in Linux" sizes="(max-width: 80px) 100vw, 80px" title="Rm Command in Linux 79" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Rm-Command-in-Linux-80x80.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Rm-Command-in-Linux-80x80.png?quality=100&amp;f=auto 80w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/09/Rm-Command-in-Linux-150x150.png?quality=100&amp;f=auto 150w,"/>						</a>
					</div>
				
				<div class="pk-post-inner pk-post-data">
										<h5 class="entry-title">
						<a href="https://bytexd.com/rm-command-in-linux/" data-wpel-link="internal">Rm Command in Linux</a>
					</h5>
					<ul class="post-meta"><li class="meta-date">September 20, 2021</li></ul>				</div>
			</div>
		</article>
							</li>
									</ul>
			</div>

			</div><div class="widget_text widget custom_html-2 widget_custom_html"><div class="textwidget custom-html-widget"><span id="ezoic-pub-ad-placeholder-102" class="ezoic-adpicker-ad"></span><span class="ezoic-ad large-leaderboard-1 large-leaderboard-1102 adtester-container adtester-container-102" data-ez-name="bytexd_com-large-leaderboard-1"><span id="div-gpt-ad-bytexd_com-large-leaderboard-1-0" ezaw="300" ezah="250" style="position:relative;z-index:0;display:inline-block;padding:0;width:100%;max-width:1200px;margin-left:auto !important;margin-right:auto !important;min-height:250px;min-width:300px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-large-leaderboard-1-0')};</script></span><span style="width:300px;display:block;height:14px;margin:auto" class="reportline"><span style="text-align:center;font-size: smaller;float:left;line-height:normal;"><a href="https://www.ezoic.com/what-is-ezoic/" target="_blank" rel="noopener noreferrer nofollow" style="cursor:pointer"><img src="https://go.ezoic.net/utilcave_com/img/ezoic.png" alt="Ezoic" loading="lazy" style="height:12px !important; padding:2px !important; border:0px !important; cursor:pointer !important; width: 58px !important; margin:0 !important; box-sizing: content-box !important;"/></a></span><span class="ez-report-ad-button" name="?pageview_id=ba929e66-cfbf-427d-57cc-eeea1d66d311&amp;ad_position_id=102&amp;impression_group_id=bytexd_com-large-leaderboard-1/2021-09-26/1013121529557445&amp;ad_size=300x250&amp;domain_id=283186&amp;url=https://bytexd.com/ngrok-tutorial-for-beginners/" style="cursor: pointer!important; font-size:12px !important;color: #a5a5a5 ;float:right;text-decoration:none !important;font-family:arial !important;line-height:normal;">report this ad</span></span></span><a href="https://draculaservers.com/freeradius.php" target="_blank" rel="noopener external" data-wpel-link="external"><img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="automatic-freeradius-servers" sizes="(max-width: 300px) 100vw, 300px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/04/freeradius-servers.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/04/freeradius-servers.png?w=214&amp;quality=100&amp;f=auto 214w,https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2021/04/freeradius-servers.png?w=300&amp;quality=100&amp;f=auto 300w,"/></a></div></div>					</div>
		<div class="sidebar sidebar-2"></div>
	</aside><!-- .widget-area -->


						
					</div><!-- .main-content -->

					
				</div><!-- .cs-container -->

				
			</div><!-- .site-content -->

			
			
			<footer id="colophon" class="site-footer">
				
				
				<div class="footer-info">

					<div class="cs-container">

						<div class="site-info">

							<div class="footer-col-info">
																	<span class="site-title footer-title" href="https://bytexd.com/" rel="home">
										<img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="ByteXD" sizes="(max-width: 214px) 100vw, 214px" data-loading="lazy" data-src="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?quality=100&amp;f=auto" data-srcset="https://cdn.statically.io/img/bytexd.com/wp-content/uploads/2020/06/ByteXD-Logo-v2.png?w=214&amp;quality=100&amp;f=auto 214w,"/>									</span>
																										<div class="footer-copyright">
										© 2021 ByteXD.com									</div>
																</div>

							
															<div class="footer-col-nav footer-col-nav-full">
									<nav class="navbar-footer"><ul id="menu-footer-menu" class="navbar-nav"><li id="menu-item-2508" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2508"><a href="https://bytexd.com/contact/" data-wpel-link="internal">Contact</a></li>
<li id="menu-item-2510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2510"><a href="https://bytexd.com/privacy-policy/" data-wpel-link="internal">Privacy Policy</a></li>
<li id="menu-item-2509" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2509"><a href="https://bytexd.com/terms-and-conditions/" data-wpel-link="internal">Terms and Conditions</a></li>
</ul></nav>								</div>
								
						</div>

					</div>

				</div>

			</footer>

			
		</div>

	</div><!-- .site-inner -->

	
</div><!-- .site -->


			<div class="pk-mobile-share-overlay">
							</div>
			<a href="javascript:void(0);" id="wpdUserContentInfoAnchor" style="display:none;" rel="#wpdUserContentInfo" data-wpd-lity="" data-wpel-link="internal">wpDiscuz</a><div id="wpdUserContentInfo" style="overflow:auto;background:#FDFDF6;padding:20px;width:600px;max-width:100%;border-radius:6px;" class="lity-hide"></div><div id="wpd-editor-source-code-wrapper-bg"></div><div id="wpd-editor-source-code-wrapper"><textarea id="wpd-editor-source-code"></textarea><button id="wpd-insert-source-code">Insert</button><input type="hidden" id="wpd-editor-uid"/></div>
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KX8VTB3"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->			<script>
			var _SEARCHWP_LIVE_AJAX_SEARCH_BLOCKS = true;
			var _SEARCHWP_LIVE_AJAX_SEARCH_ENGINE = 'default';
			var _SEARCHWP_LIVE_AJAX_SEARCH_CONFIG = 'default';
			</script>
			<script type="text/javascript">/* <![CDATA[ */!function(e,n){var r={"selectors":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"options":{"indent":4,"ampersandCleanup":true,"linehover":true,"rawcodeDbclick":false,"textOverflow":"break","linenumbers":false,"theme":"wpcustom","language":"generic","retainCssClasses":true,"collapse":false,"toolbarOuter":"","toolbarTop":"{BTN_RAW}{BTN_COPY}{BTN_WINDOW}{BTN_WEBSITE}","toolbarBottom":""},"resources":["https:\/\/bytexd.com\/wp-content\/plugins\/enlighter\/cache\/enlighterjs.min.css?WtqZIEvPDriaoRi","https:\/\/bytexd.com\/wp-content\/plugins\/enlighter\/resources\/enlighterjs\/enlighterjs.min.js"]},o=document.getElementsByTagName("head")[0],t=n&&(n.error||n.log)||function(){};e.EnlighterJSINIT=function(){!function(e,n){var r=0,l=null;function c(o){l=o,++r==e.length&&(!0,n(l))}e.forEach(function(e){switch(e.match(/\.([a-z]+)(?:[#?].*)?$/)[1]){case"js":var n=document.createElement("script");n.onload=function(){c(null)},n.onerror=c,n.src=e,n.async=!0,o.appendChild(n);break;case"css":var r=document.createElement("link");r.onload=function(){c(null)},r.onerror=c,r.rel="stylesheet",r.type="text/css",r.href=e,r.media="all",o.appendChild(r);break;default:t("Error: invalid file extension",e)}})}(r.resources,function(e){e?t("Error: failed to dynamically load EnlighterJS resources!",e):"undefined"!=typeof EnlighterJS?EnlighterJS.init(r.selectors.block,r.selectors.inline,r.options):t("Error: EnlighterJS resources not loaded yet!")})},(document.querySelector(r.selectors.block)||document.querySelector(r.selectors.inline))&&e.EnlighterJSINIT()}(window,console); /* ]]> */</script><script type="text/javascript" data-cfasync="false">var bU="https://bytexd.com/wp-content/plugins/wp-youtube-lyte/lyte/";var mOs=null;style = document.createElement("style");style.type = "text/css";rules = document.createTextNode(".lyte-wrapper-audio div, .lyte-wrapper div {margin:0px; overflow:hidden;} .lyte,.lyMe{position:relative;padding-bottom:56.25%;height:0;overflow:hidden;background-color:#777;} .fourthree .lyMe, .fourthree .lyte {padding-bottom:75%;} .lidget{margin-bottom:5px;} .lidget .lyte, .widget .lyMe {padding-bottom:0!important;height:100%!important;} .lyte-wrapper-audio .lyte{height:38px!important;overflow:hidden;padding:0!important} .lyMe iframe, .lyte iframe,.lyte .pL{position:absolute !important;top:0;left:0;width:100%;height:100%!important;background:no-repeat scroll center #000;background-size:cover;cursor:pointer} .tC{left:0;position:absolute;top:0;width:100%} .tC{background-image:linear-gradient(to bottom,rgba(0,0,0,0.6),rgba(0,0,0,0))} .tT{color:#FFF;font-family:Roboto,sans-serif;font-size:16px;height:auto;text-align:left;padding:5px 10px 50px 10px} .play{background:no-repeat scroll 0 0 transparent;width:88px;height:63px;position:absolute;left:43%;left:calc(50% - 44px);left:-webkit-calc(50% - 44px);top:38%;top:calc(50% - 31px);top:-webkit-calc(50% - 31px);} .widget .play {top:30%;top:calc(45% - 31px);top:-webkit-calc(45% - 31px);transform:scale(0.6);-webkit-transform:scale(0.6);-ms-transform:scale(0.6);} .lyte:hover .play{background-position:0 -65px;} .lyte-audio .pL{max-height:38px!important} .lyte-audio iframe{height:438px!important} .ctrl{background:repeat scroll 0 -220px rgba(0,0,0,0.3);width:100%;height:40px;bottom:0px;left:0;position:absolute;} .lyte-wrapper .ctrl{display:none}.Lctrl{background:no-repeat scroll 0 -137px transparent;width:158px;height:40px;bottom:0;left:0;position:absolute} .Rctrl{background:no-repeat scroll -42px -179px transparent;width:117px;height:40px;bottom:0;right:0;position:absolute;padding-right:10px;}.lyte-audio .play{display:none}.lyte-audio .ctrl{background-color:rgba(0,0,0,1)}.lyte .hidden{display:none}");if(style.styleSheet) { style.styleSheet.cssText = rules.nodeValue;} else {style.appendChild(rules);}document.getElementsByTagName("head")[0].appendChild(style);</script><script type="text/javascript" data-cfasync="false" async="" src="https://bytexd.com/wp-content/plugins/wp-youtube-lyte/lyte/lyte-min.js?wyl_version=1.7.16"></script><script type="text/javascript" src="https://bytexd.com/wp-content/plugins/powerkit/modules/basic-elements/public/js/public-powerkit-basic-elements.js?ver=4.0.0" id="powerkit-basic-elements-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4" id="imagesloaded-js"></script>
<script type="text/javascript" id="powerkit-lightbox-js-extra">
/* <![CDATA[ */
var powerkit_lightbox_localize = {"text_previous":"Previous","text_next":"Next","text_close":"Close","text_loading":"Loading","text_counter":"of","single_image_selectors":".entry-content img,.single .post-media img","gallery_selectors":".wp-block-gallery, .gallery","exclude_selectors":"","zoom_icon":"true"};
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/powerkit/modules/lightbox/public/js/public-powerkit-lightbox.js?ver=2.5.7" id="powerkit-lightbox-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/powerkit/modules/share-buttons/public/js/public-powerkit-share-buttons.js?ver=2.5.7" id="powerkit-share-buttons-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/powerkit/modules/table-of-contents/public/js/public-powerkit-table-of-contents.js?ver=2.5.7" id="powerkit-table-of-contents-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/wpdccjs/wpdcc.js?ver=7.3.2" id="wpdiscuz-cookie-js-js"></script>
<script type="text/javascript" id="quill-js-before">
        var wpdiscuzEditorOptions = {
        modules: {
        toolbar: "",
        counter: {
        uniqueID: "",
        commentmaxcount : 0,
        replymaxcount : 0,
        commentmincount : 1,
        replymincount : 1,
        },
		        },
        wc_be_the_first_text: "Be the First to Comment!",
        wc_comment_join_text: "Join the discussion",
        theme: 'snow',
        debug: 'error'
        };
		
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/quill/quill.min.js?ver=1.3.6" id="quill-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/js/wpd-editor.min.js?ver=1.3.6" id="wpd-editor-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js?ver=1.3.6" id="autogrowtextarea-js-js"></script>
<script type="text/javascript" id="wpdiscuz-ajax-js-js-extra">
/* <![CDATA[ */
var wpdiscuzAjaxObj = {"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment is no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"Spoiler Title","wc_cannot_rate_again":"You cannot rate again","wc_not_allowed_to_rate":"You're not allowed to rate here","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"30","liveUpdateGuests":"0","wordpressThreadCommentsDepth":"5","wordpressIsPaginate":"0","commentTextMaxLength":"0","replyTextMaxLength":"0","commentTextMinLength":"1","replyTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"1","enableFbLogin":"0","fbUseOAuth2":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"18ed1fa9b0f8840218f1271c4263aeba","isLoadOnlyParentComments":"0","scrollToComment":"1","commentFormView":"expanded","enableDropAnimation":"1","isNativeAjaxEnabled":"1","enableBubble":"0","bubbleLiveUpdate":"0","bubbleHintTimeout":"45","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"1","bubbleLocation":"content_left","firstLoadWithAjax":"0","wc_copied_to_clipboard":"Copied to clipboard!","inlineFeedbackAttractionType":"blink","loadRichEditor":"1","wpDiscuzReCaptchaSK":"","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"1","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"2097152","wmuPostMaxSize":"104857600","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"Are you sure you want to delete this attachment?","wmuPhraseNotAllowedFile":"Not allowed file type","wmuPhraseMaxFileCount":"Maximum number of uploaded files is 1","wmuPhraseMaxFileSize":"Maximum upload file size is 2MB","wmuPhrasePostMaxSize":"Maximum post size is 100MB","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuSecurity":"9a70853373","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.3.2","wc_post_id":"5339","isCookiesEnabled":"1","loadLastCommentId":"0","dataFilterCallbacks":[],"phraseFilters":[],"scrollSize":"32","is_email_field_required":"1","url":"https:\/\/bytexd.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/bytexd.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/bytexd.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"eafc5bb8dd"};
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.min.js?ver=7.3.2" id="wpdiscuz-ajax-js-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/colorbox/jquery.colorbox.min.js?ver=7.3.2" id="wmu-colorbox-js-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-mu-frontend.min.js?ver=7.3.2" id="wpdiscuz-mu-js-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/third-party/lity/lity.min.js?ver=7.3.2" id="wpdiscuz-lity-js-js"></script>
<script type="text/javascript" id="wpdiscuz-user-content-js-js-extra">
/* <![CDATA[ */
var wpdiscuzUCObj = {"msgConfirmDeleteComment":"Are you sure you want to delete this comment?","msgConfirmCancelSubscription":"Are you sure you want to cancel this subscription?","msgConfirmCancelFollow":"Are you sure you want to cancel this follow?","additionalTab":"0"};
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz-user-content.min.js?ver=7.3.2" id="wpdiscuz-user-content-js-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/themes/squaretype/js/colcade.js?ver=0.2.0" id="colcade-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/themes/squaretype/js/ofi.min.js?ver=3.2.3" id="object-fit-images-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-content/themes/squaretype/js/scripts.js?ver=2.0.3" id="csco-scripts-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-includes/js/comment-reply.min.js?ver=5.8.1" id="comment-reply-js"></script>
<script type="text/javascript" id="swp-live-search-client-js-extra">
/* <![CDATA[ */
var searchwp_live_search_params = [];
searchwp_live_search_params = {"ajaxurl":"https:\/\/bytexd.com\/wp-admin\/admin-ajax.php","origin_id":5339,"config":{"default":{"engine":"default","input":{"delay":300,"min_chars":3},"results":{"position":"bottom","width":"auto","offset":{"x":0,"y":5}},"spinner":{"lines":12,"length":8,"width":3,"radius":8,"scale":1,"corners":1,"color":"#424242","fadeColor":"transparent","speed":1,"rotate":0,"animation":"searchwp-spinner-line-fade-quick","direction":1,"zIndex":2000000000,"className":"spinner","top":"50%","left":"50%","shadow":"0 0 1px transparent","position":"absolute"}}},"msg_no_config_found":"No valid SearchWP Live Search configuration found!","aria_instructions":"When autocomplete results are available use up and down arrows to review and enter to go to the desired page. Touch device users, explore by touch or with swipe gestures."};;
/* ]]> */
</script>
<script type="text/javascript" src="https://bytexd.com/wp-content/plugins/searchwp-live-ajax-search/assets/javascript/dist/script.min.js?ver=1.6.1" id="swp-live-search-client-js"></script>
<script type="text/javascript" src="https://bytexd.com/wp-includes/js/wp-embed.min.js?ver=5.8.1" id="wp-embed-js"></script>
<script>window.GA_ID='UA-137868766-3';</script><script src="https://bytexd.com/wp-content/plugins/flying-analytics/js/minimal-analytics.js" defer=""></script><script type="text/javascript" id="flying-scripts">const loadScriptsTimer=setTimeout(loadScripts,5*1000);const userInteractionEvents=["mouseover","keydown","touchstart","touchmove","wheel"];userInteractionEvents.forEach(function(event){window.addEventListener(event,triggerScriptLoader,{passive:!0})});function triggerScriptLoader(){loadScripts();clearTimeout(loadScriptsTimer);userInteractionEvents.forEach(function(event){window.removeEventListener(event,triggerScriptLoader,{passive:!0})})}
function loadScripts(){document.querySelectorAll("script[data-type='lazy']").forEach(function(elem){elem.setAttribute("src",elem.getAttribute("data-src"))})}</script>
    <script type="text/javascript" id="flying-images">"use strict";window.FIConfig={lazyMethod:"javascript",lazyMargin:500};var flyingImages=function(){var a=document.querySelectorAll("[data-loading=\"lazy\"]");if(window.FIConfig.lazyMethod.includes("native")&&"loading"in HTMLImageElement.prototype)a.forEach(function(a){a.removeAttribute("data-loading"),a.setAttribute("loading","lazy"),a.dataset.srcset&&(a.srcset=a.dataset.srcset),a.src=a.dataset.src});else if(window.IntersectionObserver){var b=new IntersectionObserver(function(a){a.forEach(function(a){a.isIntersecting&&(b.unobserve(a.target),a.target.dataset.srcset&&(a.target.srcset=a.target.dataset.srcset),a.target.src=a.target.dataset.src,a.target.classList.add("lazyloaded"),a.target.removeAttribute("data-loading"))})},{rootMargin:window.FIConfig.lazyMargin+"px"});a.forEach(function(a){b.observe(a)})}else for(var c=0;c<a.length;c++)a[c].dataset.srcset&&(a[c].srcset=a[c].dataset.srcset),a[c].src=a[c].dataset.src};flyingImages();function throttle(a,b){var c=!1;return function(){c||(a.apply(null,arguments),c=!0,setTimeout(function(){c=!1},b))}}var dynamicContentObserver=new MutationObserver(throttle(flyingImages,125));dynamicContentObserver.observe(document.body,{attributes:!0,childList:!0,subtree:!0}),function(){var a=document.querySelectorAll("[data-loading=\"lazy-background\"]");if(window.IntersectionObserver){var d=new IntersectionObserver(function(a){a.forEach(function(a){if(a.isIntersecting){d.unobserve(a.target);var b=a.target.getAttribute("style"),c=b.replace("background:none;","");a.target.setAttribute("style",c),a.target.removeAttribute("data-loading")}})},{rootMargin:window.FIConfig.lazyMargin+"px"});a.forEach(function(a){d.observe(a)})}else for(var e=0;e<a.length;e++){var b=a[e].target.getAttribute("style"),c=b.replace("background:none;","");a[e].target.setAttribute("style",c),a[e].target.removeAttribute("data-loading")}}();</script>
    	<script type="text/javascript">
		"use strict";

		(function($) {

			$( window ).on( 'load', function() {

				// Each All Share boxes.
				$( '.pk-share-buttons-mode-rest' ).each( function() {

					var powerkitButtonsIds = [],
						powerkitButtonsBox = $( this );

					// Check Counts.
					if ( ! powerkitButtonsBox.hasClass( 'pk-share-buttons-has-counts' ) && ! powerkitButtonsBox.hasClass( 'pk-share-buttons-has-total-counts' ) ) {
						return;
					}

					powerkitButtonsBox.find( '.pk-share-buttons-item' ).each( function() {
						if ( $( this ).attr( 'data-id' ).length > 0 ) {
							powerkitButtonsIds.push( $( this ).attr( 'data-id' ) );
						}
					});

					// Generate accounts data.
					var powerkitButtonsData = {};

					if( powerkitButtonsIds.length > 0 ) {
						powerkitButtonsData = {
							'ids'     : powerkitButtonsIds.join(),
							'post_id' : powerkitButtonsBox.attr( 'data-post-id' ),
							'url'     : powerkitButtonsBox.attr( 'data-share-url' ),
						};
					}

					// Get results by REST API.
					$.ajax({
						type: 'GET',
						url: 'https://bytexd.com/wp-json/social-share/v1/get-shares',
						data: powerkitButtonsData,
						beforeSend: function(){

							// Add Loading Class.
							powerkitButtonsBox.addClass( 'pk-share-buttons-loading' );
						},
						success: function( response ) {

							if ( ! $.isEmptyObject( response ) && ! response.hasOwnProperty( 'code' ) ) {

								// Accounts loop.
								$.each( response, function( index, data ) {

									if ( index !== 'total_count' ) {

										// Find Bsa Item.
										var powerkitButtonsItem = powerkitButtonsBox.find( '.pk-share-buttons-item[data-id="' + index + '"]');

										// Set Count.
										if ( data.hasOwnProperty( 'count' ) && data.count  ) {

											powerkitButtonsItem.removeClass( 'pk-share-buttons-no-count' ).addClass( 'pk-share-buttons-item-count' );
											powerkitButtonsItem.find( '.pk-share-buttons-count' ).html( data.count );

										} else {
											powerkitButtonsItem.addClass( 'pk-share-buttons-no-count' );
										}
									}
								});

								if ( powerkitButtonsBox.hasClass( 'pk-share-buttons-has-total-counts' ) && response.hasOwnProperty( 'total_count' ) ) {
									var powerkitButtonsTotalBox = powerkitButtonsBox.find( '.pk-share-buttons-total' );

									if ( response.total_count ) {
										powerkitButtonsTotalBox.find( '.pk-share-buttons-count' ).html( response.total_count );
										powerkitButtonsTotalBox.show().removeClass( 'pk-share-buttons-total-no-count' );
									}
								}
							}

							// Remove Loading Class.
							powerkitButtonsBox.removeClass( 'pk-share-buttons-loading' );
						},
						error: function() {

							// Remove Loading Class.
							powerkitButtonsBox.removeClass( 'pk-share-buttons-loading' );
						}
					});
				});
			});

		})(jQuery);
	</script>
	<script src="https://stats.wp.com/e-202138.js" defer=""></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.1',blog:'179315647',post:'5339',tz:'0',srv:'bytexd.com'} ]);
	_stq.push([ 'clickTrackerInit', '179315647', '5339' ]);
</script>



<div class="ezmob-footer ezoic-floating-bottom ezo_ad ezmob-footer-desktop" id="ezmobfooter"><center><span id="ezoic-pub-ad-placeholder-100"></span><div class="ezmob-footer ezoic-floating-bottom ezo_ad ezmob-footer-desktop" id="ezmobfooter"><center><span class="ezoic-ad medrectangle-2 medrectangle-2100 adtester-container adtester-container-100" data-ez-name="bytexd_com-medrectangle-2"><span id="div-gpt-ad-bytexd_com-medrectangle-2-0" ezaw="970" ezah="90" style="position:relative;z-index:0;display:inline-block;padding:0;min-height:90px;min-width:970px;" class="ezoic-ad"><script data-ezscrex="false" data-cfasync="false" type="text/javascript" style="display:none;">if(typeof __ez_fad_position != 'undefined'){__ez_fad_position('div-gpt-ad-bytexd_com-medrectangle-2-0')};</script></span></span></center><span class="ezmob-footer-close" onclick="document.getElementById(&#39;ezmobfooter&#39;).style.display=&#39;none&#39;;">x</span></div></center><span class="ezmob-footer-close" onclick="document.getElementById(&#39;ezmobfooter&#39;).style.display=&#39;none&#39;;">x</span></div><script>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</script>
<script>var __ez_tkn_evnt = function() { if(typeof(_ezaq) != 'undefined'){if(typeof window.ezogtk !== "undefined" && window.ezogtk !== "") {__ez.bit.AddAndFire(_ezaq.page_view_id,[new __ezDotData("ext_user_hash",window.ezogtk)]);}}};document.addEventListener("DOMContentLoaded", __ez.queue.addFunc("__ez_tkn_evnt", "__ez_tkn_evnt", event, false, ['/detroitchicago/minneapolis.js','/detroitchicago/memphis.js'], true, true, false, true));</script>
<script async data-ezscrex="false">__ez_fad_load(0,0);__ez_fad_doc_ht=__ez_fad_docht();__ez_fad_vp_ht=__ez_fad_vpht();function __ez_fad_scroll(){return window.pageYOffset||(document.documentElement||document.body.parentNode||document.body).scrollTop}
var __ez_fad_scrollint=setInterval(function(){var sy=__ez_fad_scroll();var isShortPage=__ez_fad_doc_ht<=(__ez_fad_vh+100);var bot=(__ez_fad_vp_ht+sy);var botThresh=bot+__ez_fad_vp_ht;for(var divid in __ez_fad_divpos){if(__ez_fad_fastdiv.indexOf(divid)!=-1){continue;}
var divPos=__ez_fad_divpos[divid];if(divPos>0&&divPos>sy&&divPos<(sy+200)){if(typeof __ez_fad_instaslots[divid]=='function'){__ez_fad_instaslots[divid]();}}else if(divPos>0&&divPos>sy&&divPos<(sy+600)){if(typeof __ez_fad_instaslots[divid]=='function'){__ez_fad_viewslots[divid]();}}}
__ez_fad_chkpos();if(ezslit_run[0]!==true){__ez_fad_load(0,0);}
if((sy>0||isShortPage)&&ezslit_run[1]!=true){__ez_fad_load(1,null);__ez_fad_load(5,null);}
if((sy>100||isShortPage)&&ezslit_run[2]!=true){__ez_fad_load(2,null);}
if(sy>(__ez_fad_vp_ht*.75)&&ezslit_run[3]!=true){__ez_fad_load(3,null);}
if(document.readyState==="complete"&&!__ez_fad_floatshowd&&typeof __ez_fad_floating!=='undefined'&&__ez_fad_floating.length>0&&__ez_fad_count===0){googletag.cmd.push(__ez_fad_floatshow);}
if(ezslit_run[1]==true&&ezslit_run[2]==true&&ezslit_run[3]==true){clearInterval(__ez_fad_scrollint);}},500);function __ez_fad_chkpos(){if(typeof __ez_fad_divs[4]!='undefined'){for(var i=0;i<__ez_fad_divs[4].length;i++){var id=__ez_fad_divs[4][i];__ez_fad_divs[4][i]=null;__ez_fad_position([id]);}}}</script>
<script type="text/javascript">(function(f,a){function g(b,a,c){b.addEventListener?b.addEventListener(a,c):b.attachEvent("on"+a,function(){c.call(b)})}function k(b){b&&("string"==typeof b["class"]&&b["class"]&&a.getElementById("uglipop_popbox").setAttribute("class",b["class"]),b.keepLayout&&!b["class"]&&a.getElementById("uglipop_popbox").setAttribute("style","position:relative;height:300px;width:300px;background-color:white;opacity:1;"),"string"==typeof b.content&&b.content&&"html"==b.source&&(a.getElementById("uglipop_popbox").innerHTML=b.content),"string"==typeof b.content&&b.content&&"div"==b.source&&(a.getElementById("uglipop_popbox").innerHTML=a.getElementById(b.content).innerHTML));a.getElementById("uglipop_overlay_wrapper").style.display="";a.getElementById("uglipop_overlay").style.display="";a.getElementById("uglipop_content_fixed").style.display=""}function h(){a.getElementById("uglipop_overlay_wrapper").style.display="none";a.getElementById("uglipop_overlay").style.display="none";a.getElementById("uglipop_content_fixed").style.display="none"}g(a,"DOMContentLoaded",function(){var b=a.createElement("div"),e=a.createElement("div"),c=a.createElement("div"),d=a.createElement("div");e.id="uglipop_content_fixed";e.setAttribute("style","position:fixed;top: 50%;left: 50%;transform: translate(-50%, -50%);-webkit-transform: translate(-50%, -50%);-ms-transform: translate(-50%, -50%);opacity:1;z-index:10000000;");c.id="uglipop_popbox";d.id="uglipop_overlay_wrapper";d.setAttribute("style","position:absolute;top:0;bottom:0;left:0;right:0;display:none");b.id="uglipop_overlay";b.setAttribute("style","position:fixed;top:0;bottom:0;left:0;right:0;opacity:0.3;width:100%;height:100%;background-color:black;");d.appendChild(b);e.appendChild(c);a.body.appendChild(d);a.body.appendChild(e);a.getElementById("uglipop_overlay_wrapper").style.display="none";a.getElementById("uglipop_overlay").style.display="none";a.getElementById("uglipop_content_fixed").style.display="none";d.addEventListener("click",h);g(f,"keydown",function(a){27==a.keyCode&&h()});f.uglipop=k})})(window,document);var ezRBA=(function(){function init(){var reportAdsBtns=document.querySelectorAll('.ez-report-ad-button');for(var i=0;i<reportAdsBtns.length;i++){reportAdsBtns[i].addEventListener('click',function(e){var url='<iframe src="https://svc.ezoic.com/pub/reportads/reportads.html'+e.target.getAttribute('name')+'" width="400" height="500" style="border-radius: 10px; box-shadow: 2px 2px 30px 6px rgba(0,0,0,0.75); border: 1px solid black;"></iframe>'
uglipop({class:'none',source:'html',content:url,});});}
function bindEvent(element,eventName,eventHandler){if(element.addEventListener){element.addEventListener(eventName,eventHandler,false);}else if(element.attachEvent){element.attachEvent('on'+eventName,eventHandler);}}
bindEvent(window,'message',function(e){if(e.data==='close-report-ad-modal'){document.getElementById('uglipop_overlay_wrapper').style.display='none';document.getElementById('uglipop_overlay').style.display='none';document.getElementById('uglipop_content_fixed').style.display='none';}})}
return{init:init};})();ezRBA.init();</script>
<script type="text/javascript" data-cfasync="false"></script>
<script type="text/javascript" style='display:none;'>var __ez_dims = (function() {
		var setCookie = function( name, content, expiry ) {
			return document.cookie = name+'='+content+((expiry)?';expires='+(new Date(Math.floor(new Date().getTime()+expiry*1000)).toUTCString()):'')+';path=/';
		};
		var ffid = 1;
		var oh = window.screen.height;
		var ow = window.screen.width;
		var h = ffid === 1 ? oh : (oh > ow) ? oh : ow;
		var w = ffid === 1 ? ow : (oh > ow) ? ow : oh;
		var uh = window.innerHeight || document.documentElement.clientHeight || document.getElementsByTagName('body')[0].clientHeight;
		var uw = window.innerWidth || document.documentElement.clientWidth || document.getElementsByTagName('body')[0].clientWidth;
		setCookie('ezds', encodeURIComponent('ffid='+ffid+',w='+w+',h='+h), (31536e3*7));
		setCookie('ezohw', encodeURIComponent('w='+uw+',h='+uh), (31536e3*7));
	})();</script><script type='text/javascript' style='display:none;' async>
</script>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"69504b15ee6b5b05","version":"2021.8.1","r":1,"token":"dbeedbcf02ac41dda836867ed5c5033a","si":10}'></script>
</body></html><!--Cached using Nginx-Helper on 2021-09-25 23:35:27. It took 283 queries executed in 0.665 seconds.--><!--Visit http://wordpress.org/extend/plugins/nginx-helper/faq/ for more details-->